Обновление АСП 7.2

Аватар пользователя SerJ

Такое дело мне 7.2 подходит вообшем во всем для моего сервера!
У него инсталяция сервера 500мб все сконфигурировоно! Идеально!
Все бы нечего еслибы РПМи небили такими старими... Грустный
Я питался обновить но во первих не знаю какоы програмоы во вторих если РПМами то в восьмерку заходит говорит надо етот пакет тот пакет говорит нужен другой......итд
У меня просто комп для сервера К6-2 350мгц,128 памяти (несилно наворочиний) мне буквально надо поставить\обновить PHP, MySQL(???), FTP...

Аватар пользователя SerJ

Re: Обновление АСП 7.2

Видать помочь мне здесь некто не сможет ладно буду линух рок ставить... Грустный

Аватар пользователя Mimino

Re: Обновление АСП 7.2

Да нет, помочь бы можно, но вопросы сформулированы слишком общо и не совсем внятно

Аватар пользователя sergeil

Re: Обновление АСП 7.2

>> Такое дело мне 7.2 подходит вообшем во всем для моего сервера!

Тогда в чем проблема?

>> У него инсталяция сервера 500мб все сконфигурировоно! Идеально!

Просто замечательно...

>> Все бы нечего еслибы РПМи небили такими старими... Грустный

Вам недостаточно функциональности, проблемы с безопасностью, конфликты в зависимостях?
Обычно вполне безболезненно удается использовать пакеты из следующего дистрибутива. Для Вас это 7.3.
Если повезет, то и из более старших...

>> Я питался обновить но во первих не знаю какоы програмоы

Что Вы пытались обновить?

>> во вторих если РПМами то в восьмерку заходит говорит надо етот пакет тот пакет говорит нужен другой......итд

Боюсь, что пакеты из 8-ки Вам будет взять сложно...
Там добавилось много новых библиотек общего назначения, которые задействованы в прикладных пакетах

>> У меня просто комп для сервера К6-2 350мгц,128 памяти (несилно наворочиний) мне буквально надо поставить\обновить PHP, MySQL(???), FTP...

Возможно все не так плохо. Возьмите пакеты исходников из 7.3. Для начала сервер FTP.
ftp://ftp.asplinux.ru/pub/i386/updates/7.3/SRPMS/vsftpd-1.2.2-0.7.3asp.s...
и попробуйте пересобрать.

root# rpm --rebuild vsftpd-1.2.2-0.7.3asp.src.rpm

Если все пройдет успешно, то Вы сможете установить пусть не самую последнюю, но более свежий, тем более исправленную, версию сервера ftp...

И так с каждым пакетом. Это очень нелегкий путь.

Более легкий, хотя и более кординальный - инсталляция нового сервера на более свежем дистрибутиве, например 9.2 и аккуратный перенос настроек. Я так мигрирую свою домашнюю машину начиная, наверное, с BlackCat-6.0

Должен признатся, что у меня в качестве серверов стоят 7.3
Функциональности мне хватает. Стабильность - просто отличная.
Были некоторые сложности подключить clamav и spamassassin, но потом и это побороли...

Кстати, многие разработчики добавляют в исходники *tar.bz2 spec-файл для создания RPM (см. сайты разработчиков пакетов). Такие пакеты, зачасту, значительно проще перекомпилировать под устаревшие дистрибутивы, чем пакеты из следующих дистрибутивов...
Например, openswan, ядро с ftp.kernel.org, ...

RSS-материал