Win4Lin - проблемы с установкой

Автор: ethereal Дата: 31.07.2003 09:26 Hi, all
Люди, у кого получалось устанавливать win4lin5 под ASP9 расскажите пожалуйста как вы это делали.
Я запускаю winsetup указываю путь к папке с win98, указываю путь к образу дискеты (полученной коммандой format /s в Винде, кстати если указывать не образ а саму дискету, то win4lin ругается что на дискете чо-то неправильно, так что я создал образ на винте)
Потом нажимаю install Она пишет Copying windows files
Потом что-то типа Loading minimal Dos configuration а потом
ругается FAILED TO LOAD MDA IMAGE
И все.
Я думал это потому что у меня ядро не пропатченное.
Пропатчил версией патча от RedHat9 2.4.20.13
Патч лег нормально
Ядро скомпилилось
Загрузился с образа
Стал устанавливать win4lin - при установке из rpm ругнулось что ядро не винфолиновское хотя при логине писалось что-то типа Kernel - xxxx-mywin4lin
А когда стал устанавливать - та же ошибка что и раньше была.

Пожалуйста, помогите, бо задолбался уже в винду перезагружаться!!

--
С уважением, Ethereal
Re: Win4Lin - проблемы с установкой 31.07.2003 09:36МихаилZ Во - первых. Если при загрузке win4lin он ругается что ядро не подходит - так оно и есть
После того как ядро пропатчили надо через make xconfig включить поддержку виндов (Windows Applications Support)

Во-вторых.98ая винда должна быть релиза 2222a а не 1998 (правой мышкой на мой компьютер - свойства)
Загрузочную дискету сделайте в винде (есть 2 варианта 1-Панель управление-Установка и удаление... 2 - команда sys c:\ a:-)
Re: Win4Lin - проблемы с установкой 31.07.2003 09:44МихаилZ Во - первых. Если при загрузке win4lin он ругается что ядро не подходит - так оно и есть
После того как ядро пропатчили надо через make xconfig включить поддержку виндов (Windows Applications Support)

Во-вторых.98ая винда должна быть релиза 2222a а не 1998 (правой мышкой на мой компьютер - свойства)
Загрузочную дискету сделайте в винде (есть 2 варианта 1-Панель управление-Установка и удаление... 2 - команда sys c:\ a:-)
Re: Win4Lin - проблемы с установкой 31.07.2003 10:21Solo Доброго дня...

Есть замечательный сайт. Кстати, там и FAQ есть
[murphy.pp.ru]

Почитал там все и как результат --- работает 5 Win4Lin на ASP9. Правда ядро у меня 2.4.21 с kernel.org
Re: Win4Lin - проблемы с установкой 31.07.2003 10:25ethereal Hi, МихаилZ

Поддержку виндов включил
Винда 2222a
Дискету так и создавал

Не работает

--
С уважением, Ethereal
Re: Win4Lin - проблемы с установкой 31.07.2003 10:28ethereal Hi, Solo

Это я читал уже давно.
Все так и делал не помогает.
Ядро пока что хочу оставить родное, если уже ничего не поможет то придеться менять

--
С уважением, Ethereal
Re: Win4Lin - проблемы с установкой 31.07.2003 11:36МихаилZ ethereal писал(а):

> Hi, МихаилZ
>
> Поддержку виндов включил
> Винда 2222a
> Дискету так и создавал
>
> Не работает


Как ядро компилили?
patch -p1 -i kernel-xxxxx.patch
patch -p1 -i mki-adapter.patch
make mrproper
кладем наш .config
make xconfig (включаем поддержку)
make dep bzImage modules modules_install install
Далее правим загрузчик (etc/aspldr.conf или /boot/grub/grub.conf)
Re: Win4Lin - проблемы с установкой 01.08.2003 11:14ethereal Hi, МихаилZ

Ядро так и компилил за исключением того, что make install пока что не делал, а просто загружался с образа bzImage

Win4Lin при установке пишет
Not a Win4Lin Kernel.
Win4Lin Modules not loaded

--
С уважением, Ethereal
Re: Win4Lin - проблемы с установкой 01.08.2003 11:30ip82 а Вы уверены, что у Вас вин4лин пятый
а то у меня такие проблемы были с третей версией
версия рпмки для вин4лин5 - 5.5.0l-d
Re: Win4Lin - проблемы с установкой 01.08.2003 11:54МихаилZ ethereal писал(а):

> Hi, МихаилZ
>
> Ядро так и компилил за исключением того, что make install
> пока что не делал, а просто загружался с образа bzImage
>
> Win4Lin при установке пишет
> Not a Win4Lin Kernel.
> Win4Lin Modules not loaded
>
> --
> С уважением, Ethereal

Прикольно, лучше делайте по иснтрукции
Главное чтобы в выводе команд patch не было слова FAILED
проверьте файл /lib/modules/xxxx/modules.dep - там должен быть модуль mki-adapter (/lib/modules/xxxxx/kernel/arch/i386/mki-adapter)
Re: Win4Lin - проблемы с установкой 01.08.2003 14:04ethereal Hi, ip82.

Точно блин у меня оказалась 5.3
Я то думал первая цифра означает версию а вторая подверсию.
Попробую установить, но уже врятли успею - уезжаю на море.
Спасибо всем за помощь, я еще вернусь!

/С уважением, Ethereal/
Re: Win4Lin - проблемы с установкой 07.08.2003 01:49wizard580 И еще вот вопросик. У кого есть файлик лицензии?
Помогите пожалуйста...
Re: Win4Lin - проблемы с установкой 07.08.2003 11:02Alexandr Yakunin А слать куда?На деревню к дедушке?
Re: Win4Lin - проблемы с установкой 10.08.2003 05:10wizard580 dalues@mail.primorye.ru
только пожалуйста без темы, а то вдруг фильтр зарубит...
Re: Win4Lin - проблемы с установкой 10.08.2003 10:49Alexandr Yakunin Отправил.
Re: Win4Lin - проблемы с установкой 05.09.2003 17:27rmn Alexandr Yakunin писал(а):

> Отправил.
кхм. И мне заодно, плиз Улыбка
Re: Win4Lin - проблемы с установкой 05.09.2003 18:16ethereal Хотел сказать спасибо всем, кто тут мне помагал. Win4Lin получилось прикрутить, и уже месяц реально им пользуюсь. Суперская вещь, работает даже быстрее чем чистая винда. Но будущее все равно за WINE если мы хотим полностью избавиться от мастдая.
RSS-материал