Самостоятельная сборка, devel- пакеты и совместимость версий

Автор: ekkl Дата: 10.09.2009 13:44 Всем добрый день.
Насколько я понимаю, devel пакеты нужны для сомостоятельной сборки модулей для конкретной программы.
Например, есть апач версии, скажем, 2.1.11 к нему идет devel пакет тоже этой версии (2.1.11)
Я собираю к нему php. Делаю rpm-ку и выкладываю на сайт.
1) Если кто нибудь, у кого версия апача, скажем 2.1,13 или 2,1,09 поставит эту сборку, у него она будет правильно работать, или нет?
--
2) Если я сам обновлю версию апача до 2,1,13 мне нужно будет повторно пересобирать?
То как распространяются пакеты, наталкивают меня на мысль, что незначительно различие версий некритично в большинстве случаев.
Если это так, то собранные версии под 2.1.11 и 2.1.13 должны быть идетнтичными. Снова, если это так, то зачем разные версии devel пакетов для этих версий? Вроде бы тогда бы должен быть только один devel пакет 2.1.х
Пожалуйста, хотя бы в двух словах объясните что к чему.
Re: Самостоятельная сборка, devel- пакеты и совместимость версий 10.09.2009 14:55BigAndy 1) зависит от того, к каким библиотекам (версиям) вы прикрутитие свое творение и от того какие библиотеки (версии) установлены у устанавливаеющего.
2) Скорее всего да. Но надо смотреть на спеки. незначительное отличие версий обычно мало влияет на работу пакета, но могут быть и крупные неприятности. так, например, шалить с glibc не рекомендую.
Re: Самостоятельная сборка, devel- пакеты и совместимость версий 10.09.2009 17:06ekkl Значит, сборка того же самого php зависит не только от версии ОС но и от апача?
Тогда вопрос, имея тот жа апач 2,1,13 можна ли сделать пакет для 2,1,11
Чисто теоретически. Ведь девел пакет 2,1,11 я не установлю.
Re: Самостоятельная сборка, devel- пакеты и совместимость версий 10.09.2009 17:24BigAndy
Цитата:
Значит, сборка того же самого php зависит не только от версии ОС но и от апача

Понятия не имею. Посмотрите спеки.
Цитата:
Тогда вопрос

Сначала решите первую часть задачи.
RSS-материал