Опять freeswan!!!!

Автор: klez Дата: 29.09.2003 13:20 Не могу запустить freeswan
набиваю $ipsec auto --up net-to-net набиваю
пишит $021 no connection named "net-to-net пишит

вот ipsec.conf
# /etc/ipsec.conf - FreeS/WAN IPsec configuration file
************
# basic configuration
config setup

klipsdebug=all
plutodebug=dns


conn net-to-net
left=1.2.3.4 # Local vita
leftsubnet=192.168.0.0/24 #
leftid=@sever
leftrsasigkey=*********
leftnexthop=1.2.3.5 # correct in man
right=2.2.3.4 # Remote vit
rightsubnet=192.168.1.0/24 #
rightid=@ug #
rightrsasigkey=********** #
rightnexthop=2.2.3.5 # correct in man
auto=add# т/к запускаю через ipsec auto --up net-to-net
пересылку пакетов включил
echo 1 > /proc/sys/net/ipv4/ip_forward
в чем мой промах?
Зарание благодарен klez
Re: опять freeswan!!!! 29.09.2003 15:50Scarab Там много чего разного может быть. И фрисваны бывают разные, и патчей к ним кучи.

Я относительно недавно пересобирал ASPLinux'овое ядро (в rpm) с поддержкой фрисвана, и паковал т.н. super-freeswan - это сам freeswan плюс набор патчей к нему.

Если интересно - могу кинуть rpms/srpms. Либо - ASP Team, не интересует в качестве контрибов?
Re: опять freeswan!!!! 30.09.2003 09:40Vladimir Dyakov Попробуйте стартовать так: service ipsec start
Re: опять freeswan!!!! 03.10.2003 17:28AKachan Поделитесь опытом насщет super-freeswan.
Я пользую просто freswan-2.02. Хотел попробовать NAT-T.
Поставил super-freeswan-1.99.8, так он с моими
конфигами от freeswan отказался работать.
Сообщения об ошибке сейчас уже точно не помню, что то типа
'не могу авторизировать это соединение'.
Re: опять freeswan!!!! 03.10.2003 17:37Scarab Без сообщения об ошибке вряд ли что смогу сказать, но в общем конфиги там практически те же. А ключи, пути все на месте?
Re: опять freeswan!!!! 03.10.2003 17:54AKachan Самое смешное то, что freeswan-2.02 с этим конфигом работал и работает сейчас. Когда пробовал запускать super-freeswan поменял только version c 2.0 на 1.99 и все.

Нашел таки в логах это сообщение

packet from 192.168.17.11:500: initial Main Mode message received on 192.168.17.91:500 but no connection has been authorized

Конфиг:

config setup
interfaces="ipsec0=eth0"
klipsdebug=none
plutodebug=none

conn second
authby=secret
left=192.168.17.11
leftsubnet=192.168.17.11/32
right=192.168.17.91
rightsubnet=192.168.17.91/32
pfs=no
auto=ignore
Re: опять freeswan!!!! 03.10.2003 18:08Scarab AKachan писал(а):

> Самое смешное то, что freeswan-2.02 с этим конфигом работал и
> работает сейчас. Когда пробовал запускать super-freeswan
> поменял только version c 2.0 на 1.99 и все.
>
> Нашел таки в логах это сообщение
>
> packet from 192.168.17.11:500: initial Main Mode message
> received on 192.168.17.91:500 but no connection has been
> authorized

Так он обычно ругается, когда не может "узнать" клиента. А вот почему оно работает с 2.02 - хрен его знает.

Что я могу сделать - могу дать собранные мной rpm-ки с супер-фрисваном, который работает у меня.
RSS-материал