Неработающий поиск файлов. Болезнь всех Линукс?

Автор: bonta Дата: 29.01.2006 19:54 Неработает поиск файлов - если папка маленькая - то найдет что надо. Нет - займет весь процесор и зависнет. Даже на поиск на CD диске нехватает его. На сидероме лампочка даже уже не горит - а он все че то "ищет"



непомню - помоему раньше, еще на RedHat9. И в Федоре работал поначалу. А потом вроде тоже нет. Но раньше у мя стояли IDE диски. а щас SATA. Может дело в этом.
Вообще дело не в машине - она мощная, и памяяти ей хватает даже без подгрузки свопа.

подскажите как заставить работать поиск.
Re: неработающий поиск файлов. Болезнь всех Линукс? 30.01.2006 00:20SlavaZ какой из поисков не работает?
- find
- slocate
- в mc по ALT+F7
- в KDE "поиск файлов и папок"
- в GNOME поиск
- ...

Как именно искал? чего вводил, какие команды писал?

Сам понимаешь - угадать, что именно ты делал, нереально. Поэтому помоги нам, подскажи чего делал... Улыбка
Re: неработающий поиск файлов. Болезнь всех Линукс? 30.01.2006 18:47BigAndy Гы. Имхо проблемму кривого гуевого тула не есть проблемма линукс.
пиши втерминале locate имя_файла, или, если надо по контексту файла, то "find"
Re: неработающий поиск файлов. Болезнь всех Линукс? 30.01.2006 20:32bonta SlavaZ писал(а):

> какой из поисков не работает?
> Как именно искал? чего вводил, какие команды писал?

kfind
вставляем, к примеру ASP10 CD2 указываем что искать в нем /media/<device_name> и скажем ищем: *kdev* - все подвиснет намертво



BigAndy писал(а):

> Гы. Имхо проблемму кривого гуевого тула не есть проблемма
> линукс.
> пиши втерминале locate имя_файла, или, если надо по контексту
> файла, то "find"

т.е. проблема опять в чем то кде-шном? А как у Вас kfind работает ?

/*
почему говорю опять? да потому что kcalc - неправильно считает. Готовился я к численным методам - решал задачи. Проверял результат - вот значит считаю - проверяю две обычные большие дроби - переводом в десятичные - одну перевел goto mem другую перевел - причем вижу что такая же. Но для верности отнимаю от нее содержимое памяти - неодна циферка встроке не поменялась - т.к. одинаковые - а при вычитании получилась очень мальенькая дробь скажем 0.000434e-14. Вот. Потом пошел в винду - ее калк - нормально сказал что 0. потом вернулся опять в КДЕ но уже запустил Xcalc - он тоже нормально посчитал 0. А kcalc неправильный. Вроде погрешность с действительными числами при вычитании должна быть самой маленькой
x-y=X-Y+E1-E2
Но не такой же как в Kcalc! =)
*/
RSS-материал