Xorg

Автор: Diablus Дата: 18.03.2006 18:50 Проблема вот в чем:
Установил ASP11 на рабочую машину. Используется графический вход в ситсему (rhgb). после того, как загружается сама ОС, и на экране должно появиться окно приветствия, машина выдает на экран странную рябь и виснет наглухо. Сначала я посчитал, что проблема в настройках частоты обновления моего монитора, однако, этот трабл остается даже при разрешении 640х480 и частоте 60Гц. Мой монитор может держать ГОРАЗДО БОЛЬШЕ. И еще. Если я запускаюсь без параметра rhgb в команде запуска, то X-ы пробуют запуститься, и говорят, что не найден экран 0, после чего предлагают окно настройки дисплея и разрешения. Выставляю 1024х768,85Hz и жму ОК. Х-ы запускаются!!!. Хотелось бы, чтобы Х-ы хапускались сразу при запуске.
ПС: Ранее использовал на этой машине АСП10. С ним таких проблем не было.
Re: Xorg 18.03.2006 19:02krep Если вы пользовались ASP-10,то где находится xorg.conf знаете -настройте его.
И удалите rhgb из загрузчика.
Re: Xorg 18.03.2006 19:06Diablus Вы пишите, "Настройте его", но Как. Я уже даже все параметры в Xorg.conf вписал от старого asp10. все равно таже история. Если удалить из загрузчика rhgb, то попытка запуска X сервера всеравно происходит. И происходит с ошибкой.
Re: Xorg 18.03.2006 19:08lg >Если я запускаюсь без параметра rhgb в команде запуска, то X-ы пробуют запуститься, и говорят, что не найден экран 0, после чего предлагают окно настройки дисплея и
udev не успевает создавать устройства?
ошибки в xorg.cong ?
Re: Xorg 18.03.2006 19:20Diablus udev вроде бы все успевает.
А какие ошибки могут быть в Xorg.conf?
Вот мой конфиг:



# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db";-). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "SyncMaster"
DisplaySize 310 230
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "RIVA TNT2"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Re: Xorg 18.03.2006 20:28lg ---
Load "glx"
Load "dri"
---
А это вообще должно работать?
---
Load "type1"
---
Вроде давно уже не нужен, но мешать не должен
Re: Xorg 18.03.2006 21:17Aristarch >Section "ServerLayout"
>Identifier "single head configuration"
>Screen 0 "Screen0" 0 0
>InputDevice "Mouse0" "CorePointer"
>InputDevice "Keyboard0" "CoreKeyboard"
>EndSection

Я думаю проблема в этом месте: Screen 0 "Screen" 0 0 Необходимо убрать лишний 0

>Screen "Screen0" 0 0
Re: Xorg 19.03.2006 11:49BigAndy

>> Screen 0 "Screen" 0 0 Необходимо убрать лишний 0
нет здесь проблемм нет, синтаксис правильный
Почему надо убирать библиотеки glx? - могут не работать некоторые графические приложения (например некоторые апплеты Xscreensaver.
И чем мешает dri?

Нет, скорее всего проблемма в частоте обновления а не в разрешении (вернее в комплексе параметров разрешение-частота обновления)"
Вообще по моему опыту агрейд по асп-шному системы (с версии на версию) проходит довольнок риво и все становится на места только после сноса и переустановки.

еще замечено что не все библиотеки перезаписываются при апгрейде. И можно получить в результате не версию 11 а 10,5 Улыбка
Re: Xorg 20.03.2006 10:04vadim совет по апгрейду - делаешь копию /etc
ставишь с нуля новую asp
подмонтируешь старый /home

правда /home должен быть на отдельном разделе, если не так, то сначала полность его архивируешь, как /etc, при новой установке делаешь для него новый раздел (это на будущее), а после установки распаковываешь свой домашний каталог в требуемое место.

я так обновляю еще с asp9
Re: Xorg 20.03.2006 10:37krep $gtf 1024 768 85 (ili postavte nujnie vam znachenia -zatem napichi v
section Monitor stroky Modeline)
$man gtf
Re: Xorg 20.03.2006 15:36grey У меня было так:
поставил ASP 11 всё настроил, а после перезагрузки Х-сы не грузятся...
настроил опять, перезагрузился - вылетают с ошибкой...
сделал так
в фыйле rc.local
vi /etc/rc.d/rc.local
прописал в самом конце
rm /etc/X11/xorg.conf
cp /etc/X11/xorg.conf.backup-nvidia-glx /etc/X11/xorg.conf
может это не правильно но работает...
Следует сказать что монитор у меня LG Flatron F720B,
а видео Riva TNT2
надеюсь поможет....
Re: Xorg 20.03.2006 15:46poult grey писал(а):

> У меня было так:
> поставил ASP 11 всё настроил, а после перезагрузки Х-сы не
> грузятся...
> настроил опять, перезагрузился - вылетают с ошибкой...
> сделал так
> в фыйле rc.local
> vi /etc/rc.d/rc.local
> прописал в самом конце
> rm /etc/X11/xorg.conf
> cp /etc/X11/xorg.conf.backup-nvidia-glx /etc/X11/xorg.conf
> может это не правильно но работает...
> Следует сказать что монитор у меня LG Flatron F720B,
> а видео Riva TNT2
> надеюсь поможет....

Почему не хочешь воспользоваться драйверами nvidia ? Может кривой драйвер от xorg ? Да и вообще, я только в крайних случаях пользуюсь nv драйвером. Еще попробуй на время уйти от 24 битного цвета
Re: Xorg 20.03.2006 16:15grey позднее попробую применить твой совет, а пока работает ну и ладно....
в игры я не играю, стандартный драйвер вполне устраивает....

я настраивал с помощью system-config-display - всё ок только ло перезагрузки, вот и решил сделать замену файла
Re: Xorg 21.03.2006 14:02Diablus Всем спасибо! Все получилось. Использовал метод "подсовывания" бэкапа Xorg.conf по описанному выше методу.
Re: Xorg 21.03.2006 16:09Raptor Diablus писал(а):

> Всем спасибо! Все получилось. Использовал метод "подсовывания"
> бэкапа Xorg.conf по описанному выше методу.

Вы меня поймите правильно, но такой способ конечно выход, но это не правильно. Видимо что-то с системой не то.
RSS-материал