Два wi-fi адаптера. Как спарить их в режиме Ad-Hoc?

Автор: Cherepulya Дата: 26.09.2005 14:46 Есть два wi-fi адаптера. Один на десктопе PCIйный. Один в ноутбуке PCMCIA. Оба Dlink. Первый G510, второй G650. На десктопе ASP10 с самосборным ядром. На ноуте Debian Sarg с самосборным ядром. Ядра пересобраны так что девайсины определяются. В частности на десктопе
[root@cherep ~]# lspci | grep Ethernet
01:0a.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)

Скачаны драйвера madwifi. Установлены. Девайсины определились как ath0. Настроены соответствующие интерфейсы.
На десктопе
[root@cherep ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:11:95:BF:29:A4
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::211:95ff:febf:29a4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:200
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:5 Memory:e1e20000-e1e30000

На ноуте аналогично только айпишник 192.168.0.5
Роутинг настроен правильно
[root@cherep ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
172.23.21.34 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 ath0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 ath0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ath0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0

ppp0 в данном случае GPRS-интерфейс мобилки через которую я в и-нет вылез.

На обеих машинах сделано iwconfig ath0 mode ad-hoc
iwconfig ath0 говорит:

ath0 IEEE 802.11 ESSID:""
Mode:Ad-Hoc Frequency:2.442 GHz Cell: 00:00:00:00:00:00
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:-0ff RTS thr:-0ff Fragment thr:-0ff
Encryption key:-0ff
Power Management:-0ff
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


Интерфейсы wi-fi на ноуте и десктопе друг друга не видят. Не пингуются и вообще пакеты не бегают (файервол отключен). Что я и где не так сделал? Может кто-то ткнет в хорошую доку (пока ничего толкового не нагуглил). Может какие еще советы будут? Я что-то в растерянности
Re: Два wi-fi адаптера. Как спарить их в режиме Ad-Hoc? 26.09.2005 16:50Cherepulya Вопросы снимаются. Все сразу заработало после остановки сетевого интерфейса e100 на ноутбуке
RSS-материал