Глюк? После запуска mc пропадает русский шрифт

Автор: msk Дата: 19.07.2003 16:05 Захожу я по ssh, потом запускаю mc. Выхожу из mc и теперь по-русски ничего прочитать не могу. Например,
[root@test root]# df -h
æÁÊÌÏ×ÁÑ ÓÉÓÔÅÍÁ òÁÚÍ éÓÐ äÏÓÔ éÓÐ% ÓÍÏÎÔÉÒÏ×ÁÎÁ ÎÁ


В чем грабли?
Re: Глюк? После запуска mc пропадает русский шрифт 23.07.2003 16:40msk У всех все нормально?
Re: Глюк? После запуска mc пропадает русский шрифт 28.07.2003 14:50msk Ну кто-нибудь! Подтвердите или опровергните это! Пожалуйста!
PS.
До запуска mc русский шрифт везде нормально отображается.
Клиент - нормально настроенный putty (в точно такой же конфигурации в ASP Linux 7.3 и ALT Master 2.2 все замечательно работает).

PPS
Поставил mc из ALT'а - проблема осталась. Получается, что проблема не в mc?

Help!
Re: Глюк? После запуска mc пропадает русский шрифт 28.07.2003 15:59manowar у меня нормально, а на свою машину по ыыр заходишь?
Re: Глюк? После запуска mc пропадает русский шрифт 28.07.2003 15:59Raptor Я о таком первый раз слышу.
Re: Глюк? После запуска mc пропадает русский шрифт 28.07.2003 16:05Ustas а локаль у тебя в порядке?..
Re: Глюк? После запуска mc пропадает русский шрифт 28.07.2003 22:24msk да, по ssh.
# locale
LANG=ru_RU.KOI8-R
LC_CTYPE="ru_RU.KOI8-R"
LC_NUMERIC="ru_RU.KOI8-R"
LC_TIME="ru_RU.KOI8-R"
LC_COLLATE="ru_RU.KOI8-R"
LC_MONETARY="ru_RU.KOI8-R"
LC_MESSAGES="ru_RU.KOI8-R"
LC_PAPER="ru_RU.KOI8-R"
LC_NAME="ru_RU.KOI8-R"
LC_ADDRESS="ru_RU.KOI8-R"
LC_TELEPHONE="ru_RU.KOI8-R"
LC_MEASUREMENT="ru_RU.KOI8-R"
LC_IDENTIFICATION="ru_RU.KOI8-R"
LC_ALL=

В чем причина?
Ща пойду к серверу и попробую зайти с локальной консоли.
Re: Глюк? После запуска mc пропадает русский шрифт 29.07.2003 01:57msk Хм... Локально - нормально...
При установке я случайно выбрал Win-1251, но потом поправил конфиги ручками... Может забыл чего?

/etc/sysconfig/i18n:
LANG="ru_RU.KOI8-R"
SYSFONT="UniCyr_8x16"
SYSFONTACM="koi8-r"

/etc/sysconfig/keyboard
KEYTABLE=ruwin_KOI8-R:CTRL_SHFT

После запуска mc по-русски отображается только mc (даже если выйти и заново запустить). И это только по ssh (с локальной консоли ничего такого не наблюдается). Неужели виноват putty? У меня версия 0.53b - новее нет.
Re: Глюк? После запуска mc пропадает русский шрифт 29.07.2003 16:58msk Поставил систему заново, при установке задал "правильную" кодировку.
Ничего не изменилось.

Теперь вопрос - почему с ASP 7.3 и ALT 2.2 и во всех остальных Linux'ах таких проблем нет и никогда не было?
Re: Глюк? После запуска mc пропадает русский шрифт 30.07.2003 01:04stark Потому, что сбиваются шрифты. У меня такое случается, если я включаю фреймбуфер в консоли... Лечится установкой шрифта вручную...

# setfont /lib/kbd/consolefonts/Cyr_a8x16.psfu.gz

Наверное можно эту строчку прописать в ~/.bash_profile
Re: Глюк? После запуска mc пропадает русский шрифт 30.07.2003 02:13msk Не помогает. Насколько я понял, отчасти это зависит от Putty - с тем же ShellGuard'ом все нормально. Но это вариант меня не устраивает - клиент платный и мышкой нельзя в mc работать Мозги набекрень.

Но с другой стороны, что-то не так в самом ASP Linux 9. Ведь, как я уже говорил, несколько лет у меня все было нормально со множеством линуксов.
Re: Глюк? После запуска mc пропадает русский шрифт 30.07.2003 02:51stark Молодой человек, извините меня, конечно, но зачем в mc мышкой? Я понимаю еще если в консоли это нужно для выделения и вставки команд, да и то без этого замечательно живётся...
Re: Глюк? После запуска mc пропадает русский шрифт 05.08.2003 01:47msk кстати, если дать команду reset, то все нормализуется до следующего запуска mc.
У кого какие идеи?
Re: Глюк? После запуска mc пропадает русский шрифт 03.04.2004 19:18Zeus у самого такая же ерунда, не знаю как избавиться, причем я не подозревал, что это проявляется после запуска MC, а теперь подметил это, действительно так Грустный
Re: Глюк? После запуска mc пропадает русский шрифт 03.04.2004 19:45msg Попробуй в настройках Putty,Language поменять кодировку.
RSS-материал