Обновить ASP 11.2 до 12.0

Автор: pv Дата: 30.11.2007 16:27 Подскажите каким образом, имея DVD ASP 12, обновить установленную версию 11.2 до 12. При загрузки с DVD я не увидел приглашения обновить, терять настйки ОС не хотелось бы.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 17:39Bircoph А не нужно загружаться с dvd.
На 11.2 обновите rpm-пакеты до версий с dvd. Можно руками,
можно с помощью yum.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 18:10pv Ну обновить это понятно, но хотелось бы поиметь более дружественный интерфейс. Я хотел бы поинтересоваться, заложена ли функция обновления в дистрибутив? Очень понравилось обновляться с 11 до 11.2.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 18:37oldjoe 2pv.
А проблемы могут быть...
Я так и не смог обновить FC6 до F7 или F8 несмотря на обилие рекомендаций...
Так что дело не только в дружественном интерфейсе.
ЗЫ. Iso качаю еще пока - узкий канал...
А обновить надо и не только на 1 машине.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 20:00pv Если получится да и со всеми прелестями обещаными, буду рад услышать способ обновления. Пока всё что я видел и читал только о новшествах, а про то что у кого-то оно уже есть не упоминается.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 22:19Bircoph Хмм, ну я со времён АСП9.0 систему не переустанавливал,
обновлял да обновлял... теперь свежее fc8 (местами), а
кое-что не обновлял уже года 2-3, т.к. не нужно.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 22:39vadim лучше не обновлять, а поставить с нуля, предварительно сохранив раздел /etc
Если /home у Вас не на отдельном разделе (что весьма желательно), то сохраните и его.

Потом ставьте новую, отметив что надо отформатировать раздел. Если небыло отдельного /home, создайте его отведя под него всё свободное место после системных разделов (/ 8-10 гиг и swap 1-2 гига)

содержимое /home можно просто скопировать на место, а из /etc перенести только то, что Вы сами правили вручную после прошлой установки.
Re: Обновить ASP 11.2 до 12.0 30.11.2007 23:10beduin Bircoph писал(а):
>теперь свежее fc8 (местами)
это как?
Re: Обновить ASP 11.2 до 12.0 30.11.2007 23:30BigAndy Обновляется прекрасно. В Анаконда это позволяет. Но будте внимательны: У вас могут быть установлены пакеты, которых нет в АСП12. Возникнут исключительные ситуации. В этом случае обновитесь через yum.
Перимущества анаконды в том, что сможете подлючить дополнительнее репзитарии, скажем, от tigro или Linva.

В любом случае, перед апдейтом бекапте /etc.
Учтите еще, что в федоре kde ставится в /opt. Проверте размеры директорий.
Re: Обновить ASP 11.2 до 12.0 01.12.2007 02:38Bircoph > лучше не обновлять, а поставить с нуля, предварительно
> сохранив раздел /etc

Чушь и бред. Ещё предложите переформатировать.

> это как?

fc9/pld (из development ветки, или самое свежее прямо с
официальных сайтов, многое из PLD ставлю, а там куда свежее
федоры (ну, тот же gcc))
Re: Обновить ASP 11.2 до 12.0 01.12.2007 04:43keng00ru Ага! Bircoph & BigAndy сейчас будут рассказывать о ручном обновлении с RH-9 до Fedora-8! Катается от смеха
pv писал(а):
> но хотелось бы поиметь более дружественный интерфейс.
Автору явно нужна бубунтовская кнопка: "Проапгрейдить мой десккомп". "Последствия-соответствия", похоже, его мало интересуют.
Re: Обновить ASP 11.2 до 12.0 01.12.2007 07:02pv Меня вобще смущает что могут быть какие-то последствия при обновлении, работаю с solaris, который в свою очередь прекрасно обновляется с версии на версию и имеет волшебную кнопку "update" и все несоответсвия отлавливает самостоятельно. Я считаю дикостью и не дальнозоркость выпускать в 2007 году linux, который апдейтится "в ручную". Меня устравивает ASP, но терять рабочее время на его апргрейд не имею возможности.
Как я понимаю здесь общаются люди, которые имеют уже установленный ASP. Кто как апргрейдить собирается, или же ASP как игрушка используется, которую можно сносить какждый день? Кто апгрейдил отзовитесь!
Re: Обновить ASP 11.2 до 12.0 01.12.2007 10:32smaharbA Тема интересна, подожду...
Re: Обновить ASP 11.2 до 12.0 01.12.2007 11:23BigAndy Как говорил великий Маркс - опыт - это критерийистинности.
На целерон 2400 Сегодня ночью установли АСП 9.2. После этого запустил анаконду, указал там репозитарий от тигры, линвы и f8 и получил почти f8. Абсолютно рабочий.Специально сравнивал diff'ы rpm -qa >file1 и rpm -qa >file2.
Так что правим предварительно /dev/hands и /dev/brain
Re: Обновить ASP 11.2 до 12.0 01.12.2007 15:55redstrannik > Так что правим предварительно /dev/hands и /dev/brain
))))

Дай бог шоб бог ресурсами не обделил...
Хотя... А! И так сойдет...
)
Re: Обновить ASP 11.2 до 12.0 01.12.2007 18:56oldjoe 2Bircoph.
> лучше не обновлять, а поставить с нуля, предварительно
> сохранив раздел /etc

>Чушь и бред. Ещё предложите переформатировать.

Мне эта идея то же не очень, но боюсь, что в случае с ASP 12, придется так и сделать...
Re: Обновить ASP 11.2 до 12.0 01.12.2007 19:07oldjoe 2BigAndy.
>Сегодня ночью установли АСП 9.2. После этого запустил анаконду, указал там репозитарий от тигры, линвы и f8 и получил почти f8.
Я просто в восторге от Вашего мастерства.
Но позволю себе заметить, что не у всех широкий канал.
Я, например, качал iso 5 суток.
И разговор идет о том, как бы обновиться по-человечески именно с DVD.
На системе, где много чужих пакетов.
Тем более, что мне предстоит сделать это и на машинах не подключенных к сети...
Пишет:Невозможго открыть/прочитать repomd.xml для репозитория: asplinux-local
Re: Обновить ASP 11.2 до 12.0 01.12.2007 20:14BigAndy >И разговор идет о том, как бы обновиться по-человечески именно с DVD
Анаконда по умолчанию настроена на внешние репозитарии. Если кого-то хотите бить за это, бейте fedora foundation. Но легче прикрутить локальный репозитарий.
Либо в предыдущей версии создайте репозитарий с DVD (createrepo) и натравите на него yum.
либо поднимие ftp и обновлятесь через него, настроив как удаленный репозитарий.
>На системе, где много чужих пакетов
К сожалению, если ваш репозитарий ничего не знает об установленных Вами программах, то они обновлены не будут. Ни в каком дистрибутиве.Тем более, те, которые собирались из тарболов.

>Пишет:Невозможго открыть/прочитать repomd.xml для репозитория: asplinux-local
Лишний раз подтверждает, что не настроен локальный репозитарий. На диске его нет по умолчанию.
Re: Обновить ASP 11.2 до 12.0 01.12.2007 21:06oldjoe >На диске его нет по умолчанию.
В ASPLinux локальный репозитарий как раз и предусмотрен.
/etc/yum.repos.d/asplinux-local.repo
И для того, что бы он подхватил собственный диск надо раскомментировать строку с дисководом, установить: enabled=1.
И, главное, в раскомментированной строке: baseurl=file:///media/cdrecorder/ASPLinux/RPMS/
Убрать: ASPLinux/RPMS/
Вот за последнее убил бы нахрен федору... Улыбка
И сразу подхватяться правильные core и updates...
А потом начинается игра в зависимости - для присутствующих на диске пакетов.
Missing Dependency: libgnutls.so.11 is needed by package libtranslate
Missing Dependency: pptp-linux is needed by package system-config-pptp
Missing Dependency: libbluetooth.so.1 is needed by package bluez-hcidump
Missing Dependency: gnu-crypto >= 0:2.1.0 is needed by package java-1.4.2-gcj-compat
Missing Dependency: python(abi) = 2.4 is needed by package pyxdg
Missing Dependency: libgcjawt.so.6 is needed by package java-1.4.2-gcj-compat
Missing Dependency: jessie >= 1.0.1 is needed by package java-1.4.2-gcj-compat
Missing Dependency: libiso9660.so.4(ISO9660_4) is needed by package vcdimager
Missing Dependency: python(abi) = 2.4 is needed by package libopensync
Missing Dependency: libicuuc.so.34 is needed by package openoffice.org-core
Missing Dependency: libicule.so.34 is needed by package openoffice.org-core
Missing Dependency: libgcj.so.6 is needed by package gjdoc
Missing Dependency: libcurl.so.3 is needed by package audacious-plugins-scrobbler
Missing Dependency: XFree86-font-utils is needed by package fonts-ISO10646-1
Missing Dependency: libgcjawt.so.6 is needed by package openoffice.org-core
Missing Dependency: libneon.so.24 is needed by package openoffice.org-core
Missing Dependency: libgcj.so.6 is needed by package openoffice.org-core
Missing Dependency: python-abi = 2.4 is needed by package pyxdg
Missing Dependency: libpython2.4.so.1.0 is needed by package openoffice.org-pyuno
Missing Dependency: libiso9660.so.4 is needed by package vcdimager
Missing Dependency: libcdio.so.6(CDIO_6) is needed by package vcdimager
Missing Dependency: libsysfs.so.1 is needed by package cpufreq-utils
Missing Dependency: libpisock.so.8 is needed by package gnome-pilot-conduits
Missing Dependency: libFLAC.so.7 is needed by package audacious-plugins-flac
Missing Dependency: libcdio.so.6 is needed by package vcdimager
Missing Dependency: nautilus-sendto = 0.4-5.0.110asp is needed by package nautilus-sendto-gaim
Missing Dependency: libcurl.so.3 is needed by package openoffice.org-core
Missing Dependency: libgcj.so.6 is needed by package java-1.4.2-gcj-compat
Missing Dependency: libicui18n.so.34 is needed by package openoffice.org-core
Unable to satisfy dependencies
Package libtranslate needs libgnutls.so.11, this is not available.
Package authd needs libcrypto.so.5, this is not available.
Package system-config-pptp needs pptp-linux, this is not available.
Package bluez-hcidump needs libbluetooth.so.1, this is not available.
Package java-1.4.2-gcj-compat needs gnu-crypto >= 0:2.1.0, this is not available.
Package libjingle needs libcrypto.so.5, this is not available.
Package pyxdg needs python(abi) = 2.4, this is not available.
Package java-1.4.2-gcj-compat needs libgcjawt.so.6, this is not available.
Package java-1.4.2-gcj-compat needs jessie >= 1.0.1, this is not available.
Package libjingle needs libssl.so.5, this is not available.
Package vcdimager needs libiso9660.so.4(ISO9660_4), this is not available.
Package perl-Net-SSLeay needs libssl.so.5, this is not available.
Package libopensync needs python(abi) = 2.4, this is not available.
Package openoffice.org-core needs libicuuc.so.34, this is not available.
Package sim needs libcrypto.so.5, this is not available.
Package openoffice.org-core needs libicule.so.34, this is not available.
Package audacious-plugins-scrobbler needs libcrypto.so.5, this is not available.
Package perl-Net-SSLeay needs libcrypto.so.5, this is not available.
Package gjdoc needs libgcj.so.6, this is not available.
Package audacious-plugins-scrobbler needs libcurl.so.3, this is not available.
Package fonts-ISO10646-1 needs XFree86-font-utils, this is not available.
Package openoffice.org-core needs libgcjawt.so.6, this is not available.
Package openoffice.org-core needs libneon.so.24, this is not available.
Package audacious-plugins-scrobbler needs libssl.so.5, this is not available.
Package openoffice.org-core needs libgcj.so.6, this is not available.
Package pyxdg needs python-abi = 2.4, this is not available.
Package openoffice.org-pyuno needs libpython2.4.so.1.0, this is not available.
Package vcdimager needs libiso9660.so.4, this is not available.
Package vcdimager needs libcdio.so.6(CDIO_6), this is not available.
Package sim needs libssl.so.5, this is not available.
Package cpufreq-utils needs libsysfs.so.1, this is not available.
Package gnome-pilot-conduits needs libpisock.so.8, this is not available.
Package audacious-plugins-flac needs libFLAC.so.7, this is not available.
Package vcdimager needs libcdio.so.6, this is not available.
Package nautilus-sendto-gaim needs nautilus-sendto = 0.4-5.0.110asp, this is not available.
Package openoffice.org-core needs libcurl.so.3, this is not available.
Package java-1.4.2-gcj-compat needs libgcj.so.6, this is not available.
Package openoffice.org-core needs libicui18n.so.34, this is not available.
Re: Обновить ASP 11.2 до 12.0 01.12.2007 21:42BigAndy >В ASPLinux локальный репозитарий как раз и предусмотрен.
если вы зайдете на dvd и посмотрите каталог repodata, удивитесь длинам файлов=0
На федоре то же самое.
>И, главное, в раскомментированной строке: baseurl=file:///media/cdrecorder/ASPLinux/RPMS/
В том случае если udev не монтирует диски в /media/<disklabel>
RSS-материал