Настройка оборудования лэптопа Asus M50Sa (не все команды работают)

Автор: angelius Дата: 22.01.2009 11:11 Собственно говоря, нашел статьи по настройке оборудования M50xx, но вот не задача. На деле все немного не так.

1. Настройка Ambient Light.
Вот идет описание по настройке оптического датчика управляющего яркостью экрана (а иначе экран темнеет до минимума при загрузке и настройка яркости не возможна):

The ambient light sensor is the cause of the dim screen, we’ll have to turn it off. To fix this we will have to create a shell script that will be run on boot up that will turn of the ambient light sensor.

A) Open Terminal (Menu->Accessories), and type the following:
sudo nano brightness

B-) Now paste the following in the Terminal window:
#!/bin/sh
echo 0 > /sys/devices/platform/asus-laptop/ls_switch

C) Hit Ctrl-O to save and then Ctrl-X to exit.

D) Now we will copy our new shell script to the appropriate directory, make it executable and add the following links by typing the following in Terminal:
sudo mv brightness /etc/init.d
and then
sudo chmod 755 /etc/init.d/brightness
and then
sudo update-rc.d brightness defaults 90

E) Reboot, and you will have regained control of your brightness level.


Все вроде понятно, вот только команда update-rc.d не работает в ASP, что это такое и как в таком случае окончить настройку?

------------------------------------------------------------

2. Настройка аудиовыхода.
При подключении наушников в аудиовыход, звук из спикерфонов не прекращается, а идет параллельно. Вот описано лекарство:

With the thousands of different notebook sound configurations that are out there, it is no surprise to have yet another ALSA bug. Thanks to Petr Zemek (s3rvac), we now have the correct ALSA option switch that will cause the speakers to mute when the headphones are plugged in. Surprisingly after trying all the generic options, the same option that works for a Haier notebook works with the Asus M50.

A) First we’ll have to edit the ALSA configuration file via terminal:
sudo nano /etc/modprobe.d/alsa-base

B-) Scroll down to the bottom and add this line:
options snd-hda-intel model=haier-w66

C) Hit Ctrl-O to save and then Ctrl-X to exit.

D) Reboot and your speakers will now automatically mute when you plug your headphones in.


А файла alsa-base в /etc/modprobe.d/ нет, создание его и добавление в него скрипта ничего не дает:-((((
Re: Настройка оборудования лэптопа Asus M50Sa (не все команды работают) 23.01.2009 23:42lg 1. скрипт вставить в /etc/rc.d/rc.local.local (создать его при необходимости и сделать исполняемым)
2. добавьте эту строчку в /etc/modprobe.conf
Re: Настройка оборудования лэптопа Asus M50Sa (не все команды работают) 25.01.2009 00:02angelius Спасибо большое! Все как рукой сняло!!!!
-----------------------------------------------------------
Я - уже люблю Linux, но и маздай не забываю......
Re: Настройка оборудования лэптопа Asus M50Sa (не все команды работают) 25.01.2009 00:05angelius Идем дальше..... чем дальше в лес тем больше дров Мозги набекрень Вот в чем может быть дело, когда я долго прокручиваю страницу в Mozile и при этом слушаю музыку, то звук пропадает и возобновляется только после окончания прокрутки!
З.Ы. говорил же мозила томозит у меня Грустный
Re: Настройка оборудования лэптопа Asus M50Sa (не все команды работают) 27.01.2009 15:27BigAndy angelius Пишет:
-------------------------------------------------------
> Идем дальше..... чем дальше в лес тем больше дров
> Мозги набекрень Вот в чем может быть дело, когда я долго
> прокручиваю страницу в Mozile и при этом слушаю
> музыку, то звук пропадает и возобновляется только
> после окончания прокрутки!
> З.Ы. говорил же мозила томозит у меня Грустный


pulseaudio?
Re: Настройка оборудования лэптопа Asus M50Sa (не все команды работают) 27.01.2009 23:05angelius Видео Radeon HD 3650 Mobility.
pulseaudio? - проигрыватель? да не в нем дело, когда делаю reboot из графического режима, то появляется режим консоли и там что-то написано (не важно) - а это написанное как бы размывается линиями и дергается, что-то с видео. Причем такой эффект постоянно после завершения работы в linux. После установки radeonhd
Сейчас изучаю статью по установке run файлов, попробую установить с офф сайта, драйвер для радеонов 3xxx

вот чего накопал:
1й способ
sudo gedit /etc/X11/xorg.conf

В конец файла вставляем:

Section "DRI"
Mode         0666
EndSection


Save&Exit
Далее:

/etc/init.d/gdm stop
sudo sh /путь_к_папке_с_драйвером/имя_пакета.run #например: sudo sh /tmp/ati-driver-installer-8.28.8.run

Далее следуйте инструкциям установщика. Затем сконфигурируйте драйвер:

./aticonfig --initial


Установка завершена.

   Запускаем графический сервер:

/etc/init.d/gdm start


2й способ

chmod +x ati-driver-installer-8.34.8-x86.x86_64.run
./ati-driver-installer-8.34.8-x86.x86_64.run --buildpkg Ubuntu/6.10

Инсталируем полученые .deb пакеты:

sudo dpkg -i xorg-driver-fglrx_8.34.8-1_i386.deb

sudo dpkg -i fglrx-kernel-source_8.34.8-1_i386.deb

sudo dpkg -i fglrx-control_8.34.8-1_i386.deb


Удалсем старый fglrx deb’s из /usr/src/:

sudo rm /usr/src/fglrx-kernel*.deb

Компилируем модули ядра:

sudo module-assistant prepare,update\
sudo module-assistant build,install fglrx
sudo depmod -a

Обновляем xorg.conf:
sudo aticonfig --initial
sudo aticonfig –-overlay-type=Xv

Reboot


Какой из способов применим для установки в ASP ?
RSS-материал