Не получается монтировать флоппи

Автор: desktop user Дата: 29.01.2009 11:56 Из наутилуса флоп был недоступен, попробовал командой:
mount /dev/fd0
.. в ответ "mount: невозможно найти /dev/fd0 в /etc/fstab или /etc/mtab
".

Файл /etc/fstab после установки системы (Кобальт) до этого не изменялся и выглядел следующим образом:
UUID=хххххххх-хххх-хххх-хххх-хххххххххххх /                       ext3    defaults        1 1
UUID=хххххххх-хххх-хххх-хххх-хххххххххххх /home                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
UUID=хххххххх-хххх-хххх-хххх-хххххххххххх swap                    swap    defaults        0 0


Создал папку floppy в /media и добавил следующую строку в fstab:
/dev/fd0 /media/floppy auto rw,user,noauto,exec,utf8 0 0
(которую вытянул из fstab своей Убунты)

В результате при монтировании терминал писал что-то вроде "не могу распознать файловую систему и ни одна не указана в fstab".
Заменил строку в fstab для /dev/fd0 на следующую:
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,codepage=866,iocharset=utf8,managed 0 0

(которую слепо скопировал из примера на этом форуме).

И опять при монтировании пишет "не могу распознать файловую систему и ни одна не указана в fstab".

Помогите пожалуйста.
Re: Не получается монтировать флоппи 29.01.2009 12:33lkanter что говорит команда lshal | grep fd0
Re: Не получается монтировать флоппи 29.01.2009 18:26desktop user lkanter Пишет:
-------------------------------------------------------
> что говорит команда lshal | grep fd0


block.device = '/dev/fd0' (string)
linux.sysfs_path = '/sys/devices/platform/floppy.0/block/fd0' (string)
Re: Не получается монтировать флоппи 29.01.2009 19:04lkanter А эта дискета вообще в чем-то читается? Если рутом набрать команду mount -t vfat /dev/fd0 /mnt и она не смонтируется в /mnt - значит или дискета битая, или дисковод, других вариантов нет. Лампочка на нём хоть загорается при этом?
Re: Не получается монтировать флоппи 29.01.2009 19:27desktop user Леонид, спасибо. Действительно, поставил другую дискету, смонтировалась по доступу через наутилус (обычный пользователь), без каких-либо команд в терминале... Извиняюсь, самый простой вариант не проверил.

Пользуясь случаем: что заменяет fstab для монтирования съемных устройств через интерфейс пользователя (без терминала)? Например, у меня в Ubuntu были такие строки для дисководов в fstab, которых (похожих) в ASP`шном fstab`е нет:
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
Re: Не получается монтировать флоппи 29.01.2009 19:50lkanter При монтировании съемных устройств nautilus через gvfs зовёт команду gnome-mount, которая умеет монтировать такие устройства без записей в fstab. Например, gnome-mount -d /dev/fd0 или gnome-mount -d /dev/sda1. Точка монтирования - или метка тома, если есть, или просто disk с номером.
Re: Не получается монтировать флоппи 29.01.2009 20:18desktop user Спасибо Отлично! Отлично!
Re: Не получается монтировать флоппи 29.01.2009 20:47peter_ir desktop user Пишет:
-------------------------------------------------------
> Из наутилуса флоп был недоступен, попробовал
> командой:
> mount /dev/fd0
> .. в ответ "mount: невозможно найти /dev/fd0 в
> /etc/fstab или /etc/mtab
> ".
>
> Файл /etc/fstab после установки системы (Кобальт)
> до этого не изменялся и выглядел следующим
> образом:
>
> UUID=хххххххх-хххх-хххх-хххх-хххххххххххх /
> ext3 defaults 1 1
> UUID=хххххххх-хххх-хххх-хххх-хххххххххххх /home
> ext3 defaults 1 2
> tmpfs /dev/shm
> tmpfs defaults 0 0
> devpts /dev/pts
> devpts gid=5,mode=620 0 0
> sysfs /sys
> sysfs defaults 0 0
> proc /proc
> proc defaults 0 0
> UUID=хххххххх-хххх-хххх-хххх-хххххххххххх swap
> swap defaults 0 0
>
>
> Создал папку floppy в /media и добавил следующую
> строку в fstab:
> /dev/fd0 /media/floppy auto
> rw,user,noauto,exec,utf8 0 0
> (которую вытянул из fstab своей Убунты)
>
> В результате при монтировании терминал писал
> что-то вроде "не могу распознать файловую систему
> и ни одна не указана в fstab".
> Заменил строку в fstab для /dev/fd0 на следующую:
>
> /dev/fd0 /media/floppy auto
> pamconsole,exec,noauto,codepage=866,iocharset=utf8
> ,managed 0 0
>
> (которую слепо скопировал из примера на этом
> форуме).
>
> И опять при монтировании пишет "не могу распознать
> файловую систему и ни одна не указана в fstab".
>
> Помогите пожалуйста.
Если убрать pamconsole, монтируется командой "mount /dev/fd0".
Re: Не получается монтировать флоппи 29.01.2009 21:03BigAndy lkanter Пишет:
-------------------------------------------------------
> При монтировании съемных устройств nautilus через
> gvfs зовёт команду gnome-mount, которая умеет
> монтировать такие устройства без записей в fstab.
> Например, gnome-mount -d /dev/fd0 или gnome-mount
> -d /dev/sda1. Точка монтирования - или метка тома,
> если есть, или просто disk с номером.

*адеюсь, что ив асп*** /*dora gnomefs не заменит в дальнейщем роадмапе hal/udev к правилам которых уже привыкли???
Ибо к ним уже привыкли. Да и gnome не все испльзуют. Да вообще.DE?DMне на всех машинах привоткнуто... А usb/fdd наопители всё еще пытаются использовать и без картинок на экране/.....
Re: Не получается монтировать флоппи 29.01.2009 21:10desktop user peter_ir Пишет:
-------------------------------------------------------
> Если убрать pamconsole, монтируется командой
> "mount /dev/fd0".

Спасибо, может попробую как-нибудь, хотя теперь неахота править fstab, раз флоп монтируется через наутилус...


Все оказалось из-за загрузочной дискеты граба - это при ее монтировании была ошибка "bad filesystem...". Записал граб на дискету с пом. этих команд:
cd /usr/share/grub/i386-pc
dd if=stage1 of=/dev/fd0 bs=512 count=1
dd if=stage2 of=/dev/fd0 bs=512 seek=1

Дискета была предварительно отформатирована в ext2 (в первом случае, во втором - в ms-dos(vfat)). Причем fat не читалась и под Виндосом.

Но несмотря на все это дискета грузит граб исправно и передает ему управление (попробовал команды)...
RSS-материал