Установка VMware-workstation-4.5.2

Аватар пользователя not_root

Всем привет.

Я скачал VMware-workstation-4.5.2-8848.tar.gz
Установил
После установки запустил скрипт vmware-config.pl
Все прошло без ошибок, модули скопировались в /lib/modules/2.6.9 ........
В /dev появились устройства vmmon и vmnet
Все запускается и работает.
Но после перезагрузки системы пропадают устройства /dev/vmmon и /dev/vmnet
И естественно все перестает работать
Приходится запускать vmware-config.pl каждый раз после рестарта системы
покопался в этом vmware-config.pl но так как с перлом я не знаком то ничего не конкретного там не нашел как создаются эти устойства
Может кто подскажет что нужно сделать что бы это все не терялось после рестарта?

Аватар пользователя not_root

Re: Установка VMware-workstation-4.5.2

Цитата:
скопируй файлы, которые "пропадают", в /etc/udev/devices

попробую.
Завтра скажу что получилось

А можно подробнее, что это дает?

Аватар пользователя slavaz

Re: Установка VMware-workstation-4.5.2

скопируй файлы, которые "пропадают", в /etc/udev/devices

Аватар пользователя slavaz

Re: Установка VMware-workstation-4.5.2

Там статические файлы устройств, которые не поддерживают udev.

Аватар пользователя not_root

Re: Установка VMware-workstation-4.5.2

А тоесть в /dev - то что создается и удаляется на лету
а в /etc/udev/devices то что не поддерживает эту технологию?

Аватар пользователя slavaz

Re: Установка VMware-workstation-4.5.2

угу, верно. При запуске udev файлы устройств скопируются из /etc/udev/devices в /dev
То есть не нужно каждый раз создавать эти файлы устройств в /dev

Аватар пользователя lystor

Re: Установка VMware-workstation-4.5.2

Попробуйте vmware 5.0

Аватар пользователя slavaz

Re: Установка VMware-workstation-4.5.2

При этом надо учесть это, если апдейтами дошлифовать... Улыбка

Аватар пользователя not_root

Re: Установка VMware-workstation-4.5.2

C /etc/udev/devices все получилось
После перезагрузки все работает как и до нее

Спасибо

RSS-материал