Проблема установки диска обновлений для ASPLinux v10

Автор: Олег В. Дата: 03.08.2005 12:01 После запуска Update.sh на экран выводится сообщения о неудовлетворенных зависимостях.
Как мне использовать диск обновлений без необходимости установки каждого из rpm-ов вручную?
Re: Проблема установки диска обновлений для ASPLinux v10 03.08.2005 13:31lystor Вероятно у Вас не установлены какие-то пакеты из самого дистрибутива, а для обновления они требуются.
Скопируйте *.rpm из первых 3 дисков в один каталог на жестком диске, таким же образом обновления в другой.
Настройте yum на использование этих каталогов (http://forum.asplinux.ru/read.php?1,50414/50738/#R50738).
Далее
#yum update yum
#yum update
И, думаю, все у Вас получится.
Re: Проблема установки диска обновлений для ASPLinux v10 03.08.2005 23:07Олег В. Ясно. Благодарю, и буду пробовать, когда починю проделки драйверов от ATI, которые довели систему до "проверки модулей ядра" и зависанию.
Re: Проблема установки диска обновлений для ASPLinux v10 04.08.2005 09:16iandrew Так ведь он требует поставить поддержку cdrecord (сидюка на тачане нет, обновляю по сетке) и ieee1394 (которого там физически тоже нет).
Есть еще несколько модулей в основном дистрибутиве, которые при установке не отображаются (возможно, в какую-то группу входят), но не устанавливаются. Приходится ручками. Я-то разберусь, а как же те, каким я пол-года назад был?
Re: Проблема установки диска обновлений для ASPLinux v10 23.08.2005 12:27MR_WIZARD Помогите разобраться с проблемой. У меня ASPlinux Deluxe 9.2. Приобрёл обновление на двух CD до ASPLinux v10.0 При попытке запустить скрипт с диска Update.sh yum заругался что нет таких у него параметров --disablerepo и --obsoletes. Ну ладно убрал. Потом начал ругаться на то что нет Headerов. Ну создал. Потом вконец меня это уже убило -выдал огромный список пакетов с "неразрешёнными" зависимостями! И написал в скобочках (not provided). Я проверил yum provides КАЖДЫЙ ПАКЕТ! Все они у меня установлены в системе. Почитал форумы. Некоторые тут советуют удалить такие пакеты которые НУЖДАЮТСЯ. Удалил. Список стал меньше. Остался один net-snmp. Удалил и его. Вместе почти с половиной всего оставшегося установленного дистрибутива!!!! После этого система выдала новые установленные ЗАВИСИМОСТИ!!! Удалил и их. Опять минус треть оставшегося дистрибутива, вместе с xfree86 и всем остальным. В результате зависимостей нет, но выдаёт неподемое сообщение
CONFLICT BETWEEN UDEV WITH KERNEL. Это что же такое, господа! Что неужели вот так надо переходить от версии 9.2 к 10?!!! Или мой дистрибутив принципально необновляем?! И ещё проблема с несуществующими параметрами rpm -bb! Ну ладно использовал rpmb. Заглотила spec-файл и ВСЁ! И нигде ничего нет! Как собирать ядро?! Откуда это всё? И кто знает ответ?
Re: Проблема установки диска обновлений для ASPLinux v10 23.08.2005 12:41lystor MR_WIZARD писал:
> Помогите разобраться с проблемой. У меня ASPlinux Deluxe 9.2.
> Приобрёл обновление на двух CD до ASPLinux v10.0
Дальше читать смысла нет.
Объясняю кратко - обновления не ДО ASPLinux10, а ДЛЯ ASPLinux10 недавно были выпущены и есть в продаже на 2-х CD.
Re: Проблема установки диска обновлений для ASPLinux v10 23.08.2005 14:22MR_WIZARD Так я получается круто "промотался" из-за невнимательности? Ладно, что ж теперь. Горю со стыда. Ну хотя бы ядро-то можно взять с этих дисков? Чтоб мой чипсет поддерживало и чтоб UDMA работало...Это же не дело, когда вся мощь Linux сводится к такой низкой скорости работы жёсткого диска без UDMA! Или это всё-таки принципиально невозможно? Кстати новый OpenOffice с этих дисков работает и неплохо! И многие другие приложения. А проблема rpm -bb я смотрю не только у меня. Или что-тот с переводом man-а или он устарел. Но факт остаётся фактом-rpmb *.spec ничего не хочет делать и ошибок не выдаёт.
Re: Проблема установки диска обновлений для ASPLinux v10 23.08.2005 14:29lystor MR_WIZARD писал:
> Так я получается круто "промотался" из-за невнимательности?
Бывает. Это как в анекдоте, в котором Гена с чебурашкой пианино не в тот подъезд на верний этаж занесли...

> Чтоб мой чипсет поддерживало и чтоб UDMA работало...
Чипсет какой и жесткий диск какой? Лучше отдельной темой в раздел аппаратного обеспечения. Только версию ядра старого укажите там.

> Это же не дело, когда вся мощь Linux сводится к такой низкой скорости работы жёсткого диска без UDMA!
Если DMA не включено, то и любая другая ОС также медленно будет выполнять дисковые операции.

> А проблема rpm -bb я смотрю не только у меня.
Не rpm -bb, а rpmbuild -bb (пакет rpm-build).

Где-то встречал в интернет способы прикручивания к ASPLinux 9.2 ядра 2.6, но, если честно, смысла в этом не вижу, т.к. уж больно проблемная задача.
Установите ASPLinux10.
RSS-материал