Ставлю драйвер адаптера WiFi-ругается: помогите советом...

Автор: Mik_ Дата: 13.11.2007 20:42 Прошу пардона - все запущено до безобразия: где править этот параметр?

>Перец ясен только владельцу, у меня 3 WiFi адаптера, встроенный в ноутбук (miniPCI), PCMCIA и PCI, про какой я спрашиваю не знает ни кто, пока я не уточню.

Я к этому стремлюсь - несколько адаптеров, а пока и одному ума не дам... Улыбка
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 13.11.2007 21:26bat Mik_ писал(а):

> Прошу пардона - все запущено до безобразия: где править этот
> параметр?
Всё зависит от того, каким загрузчиком вы пользуетесь.
Если grub, то /boot/grub/grub.conf
Если aspldr то /etc/aspldr.conf и после редактирования конфигурационного файла дать команду:
# /sbin/aspldr
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 13.11.2007 23:39Mik_ Не поверите: думал в этом направлении, даже зашел в папку /boot
Использую lilo
Попробую это исполнить...
Не перестаю рассыпаться в благодарностях за вниманиет ко мне, уважаемый bat!
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 14.11.2007 08:27bat Lilo не пользовался ни разу, но про него много стататей в интернете. Файл конфигурации нашелся в /etc/lilo.conf.
Удачи.
---
Lilo (LInux LOader) - Включен в состав практически любого Linux дистрибутива, до недавнего времени был основным загрузчиком в большинстве дистрибутивов.

Конфигурационный файл lilo находится в каталоге /etc, и называется lilo.conf. После внесения изменений в данный файл вам необходимо выполнить команду lilo -t которая выполнит проверку правильности внесенных изменений, затем выполните команду lilo без параметров - тем самым вы запишете данные в MBR.
---
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 14.11.2007 19:17Mik_ ---
root@localhost ~]# hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?
hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?
usb 1-2: device not accepting address 5, error -71
usb 1-2: device not accepting address 6, error -71

[root@localhost ~]# ifconfig wlan0
rtusb init ====>
wlan0: error fetching interface information: Device not found
[root@localhost ~]# iwconfig wlan0
wlan0 No such device

[root@localhost ~]# iwconfig rtusb0
rtusb0 No such device
---
После удаления строки в лило - команды lilo -t и lilo
Инфа добавлена
перезагрузил
вставил адаптер - снова вышеозначенная чешуя...
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 01:29jogick Если кого интересует мой скромный опыт, то вся вышеописанная дурь (с глюками при втыкании девайса) у меня происходила на самосборном ядре 2.6.22 при включеном ключе USBNET, а когда я его отключил и собрал ядро заново, глюки пропали.
Ну, это я так, малоли может вам даст какую мыслю.
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 01:48bat Фишка в том, что человек не особо "рубит" в системе Линукс, а про ядро, да и про "самосборное", речь даже не идёт.
Что бы я сделал, сравнил бы вывод dmesg приведённый и после удаления параметра загрузки ядра: pci=noacpi
Ясен пень, последующие телодвижения по результатам сравнения.
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 13:00Mik_ Я думал обо мне забыли... Грустный
2 jogick:
Самосборное ядро - для меня это пока сложновато. Пытался ставить ядро просто из пакета - не получилось, а уж что-то править - пока рано...
А за мысль-как-вариант спасибо, ведь широта поведенческого репертуара, это всегда хорошо...

2 bat:
В самую точку - не то что не особо, АРХИ-не особо рублю в системе. Но начинать то когда-то надо, вот и "двигаю булками". Дело тут вот в чем: в соответствии с уровнем понимания системы (моего понимания), мне и нужны советы. Допустим про параметр загрузки ядра - этот совет сопровождаемый инфой о сравнении выводов dmesg дал мне намного больше чем просто совет убрать параметр. При этом - инфа о возможных вариантах развития событий в dmesg еще более укрепит мою веру в исполняемое.
В конце-концов, постепенно, на одного windows-оида становится меньше, а linux-оида больше... Улыбка
Человеческое спасибо, bat, за помощь!
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 13:16BigAndy >на одного windows-оида становится меньше, а linux-оида больше... :-
Это хорошо....
>инфа о возможных вариантах развития событий в dmesg еще более укрепит мою веру в исполняемое.
Только личным изучением dmesg в различных ситуациях и погружением в него. чтбы было легче используйте diff.
__diff <иммя_файла_1> <иммя_файла_2> покажет различие между двумя файлами....__
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 14:59Mik_ Пока ковырялся, не видел последний пост.
Про diff знал, но пока сравнил вручную, точнее "вглазную"
Вот что бают файлы:
---
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 3-1: new full speed USB device using uhci_hcd and address 2
usb 3-1: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
ieee1394: Initialized config rom entry `ip1394'
PCI: Found IRQ 10 for device 0000:02:07.0
PCI: Sharing IRQ 10 with 0000:00:1d.2
PCI: Sharing IRQ 10 with 0000:00:1f.1
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[10] MMIO=[e0204000-e02047ff] Max Packet=[2048] IR/IT contexts=[4/8]#Это фрагмент файла при наличии параметра ...noacpi в загрузке ядра и отсутствующем адаптере.

hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
usb 1-1: new high speed USB device using ehci_hcd and address 3#Это фрагмент файла при наличии параметра ...noacpi в загрузке ядра и вставленном адаптере.




hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 2-1: new full speed USB device using uhci_hcd and address 2 #Это фрагмент файла до подключения адаптера при удаленном параметре ...noacpi в загрузке ядра.


hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?
usb 1-2: new high speed USB device using ehci_hcd and address 3
hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?
usb 1-2: new high speed USB device using ehci_hcd and address 4#Это фрагмент файла после подключения адаптера при удаленном параметре ...noacpi в загрузке ядра.
---

Больше, на мой взгляд, различий не было.
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 15:46Mik_ ---

#< Detected 1295.874 MHz processor.
#---
#> Detected 1295.903 MHz processor.
#78c78
#< Calibrating delay using timer specific routine.. #2592.49 BogoMIPS
#(lpj=1296245)
#---
#353,354d354
#>Calibrating delay using timer specific routine.. #2592.47 BogoMIPS
#(lpj=1296238)
#170c170
#< audit(1195392164.513:1): initialized
#---
#> audit(1195392815.511:1): initialized
#186c186
#< ACPI: Thermal Zone [THRM] (43 C)
#---
#> ACPI: Thermal Zone [THRM] (42 C)
#271c271
#< audit(1195392169.339:2): selinux=0 auid=4294967295
#---
#> audit(1195392820.441:2): selinux=0 auid=4294967295
#285c285
#< intel8x0_measure_ac97_clock: measured 50925 usecs
#---
#> intel8x0_measure_ac97_clock: measured 50978 usecs
#323a324
#> usb 1-2: new high speed USB device using ehci_hcd #and address 2
#332c333,336
#< usb 2-1: new full speed USB device using uhci_hcd #and address 2
#---
#>hub 1-2: new high speed USB device using ehci_hcd and #address 3
#> hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?
#> usb 1-2: new high speed USB device using ehci_hcd and address 4
#333a338,340
#> usb 1-2: device not accepting address 4, error -71
#> usb 1-2: new high speed USB device using ehci_hcd and address 5
#> usb 1-2: device not accepting address 5, error -71
#335,336d341
#< ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[10] MMIO=[e0204000-e02047ff] Max Packet=[2048] #IR/IT contexts=[4/8]
#< usb 2-1: configuration #1 chosen from 1 choice
#337a343
#> ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[10] MMIO=[e0204000-e02047ff] Max Packet=[2048] #IR/IT contexts=[4/8]
#346,349d351
#< Bluetooth: Core ver 2.11
#< NET: Registered protocol family 31
#< Bluetooth: HCI device and connection manager initialized
#< Bluetooth: HCI USB driver ver 2.9
#< usbcore: registered new interface driver hci_usb


---

А это уже сравнение с помощью diff
Я так понимаю < относится к первому файлу, то есть, до подключения адаптера > - ко второму файлу.
Дело в том, что глядя на это, у меня нет никаких идей, в силу того, что нет ожиданий развития событий
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 15:57BigAndy Ну ведь англицким по белому пишет "#> hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?"

Устарините для начала это, потом - дальше.
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 17:05jogick Понимаю, я сам Сижу под линуксом примерно пару месяцев. Личндля меня самостоятельная сборка ядра стала самым простым путём решения проблемы с неработающим оборудованием. При этом не плохо начал разбираться в том что мне пишут dmesg и др. и как лучше обработать их вывод.
Вот ссылка на мои мучения с ядром (мало ли вдруг пригодится)
[forum.xakep.ru]
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 18.11.2007 17:34BigAndy >Личндля меня самостоятельная сборка ядра стала самым простым путём решения проблемы с неработающим оборудованием.

+1

Ничего в этом слождного нет, это не писать ядро самому Улыбка
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 19.11.2007 08:42bat Ну и когда зашли в тупик тупой вопрос, а флэшка именно в этом USB разъеме работает? Странными кажутся сообщения типа:
---
> hub 1-0:1.0: Cannot enable port 2. Maybe the USB cable is bad?
---
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 20.11.2007 13:44Mik_ Вобщем, пошел по сообщению "Maybe the USB cable is bad?"
Вставил кабель ЮСБи, к нему подключил адаптер. Вроде запустился выскочили сообщения об уровне сигнала:0 и прочих характеристиках. На радостях не успел скопировать.
команда lsusb
выдала правильное определение адаптера RT73 Ralinc tech...
Попытка запустить сканирование
#iwlist wlan0 scan
закончилась сообшением о том, что сканирование не поддерживается !!!!
Затем пошли сообщения
unregistered netdev()
idVendor=0x148f idProduct=0x2573
с периодичностью в несколько секунд.
Флешка не видна, блютус через раз.
Может с ЮСБи портами какие-то проблемы? или с их корректной поддержкой?
Перегружаюсь в Винду - флешку видно, адаптер ВайФай пашет, блютус адаптер пашет... Причем выскакивает сообщение при подключении устройств, типа: ... подключена к медленному концентратору....
Я не хочу, чтобы это пахало в Винде, пусть пашет в Линуксе!
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 20.11.2007 13:56Mik_ 2 BigAndy

А как устранить?
Если невозможно предсказать - то флешка видна, то ее нет; адаптер появился потом опять пропал.
Я не могу понять - физическое соединение ненадежно или система нос воротит от девайсов....


2 jogick
Я попробую с ядром двигаться, за ссылку спасибо, пока не могу видеть самого поста - сижу через мобилу, скорость - дрова, не подключает ресурс.

2 bat
Ваша мысль натолкнула на проверку портов с разными устройствами - вобщем-то оно и логично, но как я написал выше, не могу понять какие траблы конкретно случились: контакт плохой или гонки с определением системой.

Еще раз благодарю за участие в моих движениях, я нуждаюсь в вашей помощи, господа!
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 20.11.2007 16:01bat Ядро ядром, а давайте библиотеки УСБ проверим:
---
# rpm -qa *usb*
libusb-devel-0.1.11-2.2
usbutils-0.71-2
libusb-0.1.11-2.2
---
Попробуйте обновить если другие.
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 20.11.2007 17:15BigAndy >Я не могу понять - физическое соединение ненадежно или система нос воротит от девайсов...
Скорее всего соединение ненадежно, но может и hal дурить....
Надо dmesg читатть
Re: Ставлю драйвер адаптера WiFi-ругается: помогите советом... 20.11.2007 18:07Mik_ 2 bat
Вот что у меня выдает:
---
last login: Tue Nov 20 17:40:11 on :0
[root@localhost ~]# rpm -qa *usb*
[root@localhost ~]# rpm -qa usb*
[root@localhost ~]# rpm -qa *usb*
[root@localhost ~]# rpm -qa libusb*
libusb-0.1.10a-1
[root@localhost ~]# rpm -qa usb-devel*
[root@localhost ~]# rpm -qa usbutils*
usbutils-0.71-2
[root@localhost ~]#
---

2 BigAndy
Прикол в том, что воткнутая до загрузки системы флешка - не видна, а становится видна после отсоединения-присоединения.
После загрузкисистемы с невидимой флешкой в dmesg никаких строк типа "Мей би юсби кейбл из бэд..." не наблюдается.
А как посмотреть дурит ли HAL?
RSS-материал