Траблы с ssh

Автор: ApXuTekToP Дата: 17.03.2006 17:33 у меня не запускалась самба
мне посоветовали её обнавить ну скачал 3.0.20 устанавливаю она потребовала обнавить krd5-lib и openssl закачал я те релизы которые самба требовала.. я обновлять а она такие старые не обновляет пишет что требуются новее rpm'ы чем установленны ну я что бы не париться удаляю krd и openssl и устанавливаю новые... теперь надо перезапустить самбу можно командой но мне нужно было перезагрузить машину по другим причинам.. загружается нормально ( у меня init 3 по дефаулту) регюсь запускаю иксы.. и тут нету xorg.conf ну я устанавливаю дрова на видо (Nvidia у меня) они создаюь новый конфиг опять стартую иксы и вот тут лажа
ssh-agent: error while loading shared librares: libcrypto.so.4:cannot open shared object file: No such file or directory
Re: Траблы с ssh 20.03.2006 08:28huan попробуй вручную поставить симлинк libcrypto.so.4 на /lib/libcrypto.so.0.9... или чего там у тебя
Re: Траблы с ssh 20.03.2006 12:42werewolf имхо, не самый лучший способ...
что показывает (выполнять под root'ом):
---
# updatedb
# locate libcrypto.so.4
---
?
если файл существует, то проверь, чтобы директория, в которой он лежит, была перечислена в файле /etc/ld.so.conf и на всякий случай выполни
---
# ldconfig
---
если файл не существует, переставь соответствующий пакет (openssl)
Re: Траблы с ssh 20.03.2006 18:22Woodoo ---
# yum provides libcrypto.so.4
---
Re: Траблы с ssh 23.03.2006 11:14ApXuTekToP
# updatedb
# locate
таких команд вобще не знает ни bash ни csh =\..

# yum provides libcrypto.so.4 - а как её заставить через проксю работать??? я чего то в манах не нашёл
Re: Траблы с ssh 23.03.2006 23:16mescalito ># updatedb
># locate
>таких команд вобще не знает ни bash ни csh =\..
>

slocate - не установлен?
Re: Траблы с ssh 24.03.2006 08:59ApXuTekToP [root@hellhound Tosha]# rpm -q slocate
пакет slocate не установлен

А для чего он нужен?
Re: Траблы с ssh 28.03.2006 15:18Bircoph > пакет slocate не установлен
> А для чего он нужен?

Для индексирования всех файлов на все устройствах (по умолчанию раз в сутки) -- очень удобная штука.
Re: Траблы с ssh 28.03.2006 18:00XMan ln -s /lib/libcrypto.so.0.9.7a /lib/libcrypto.so.4
ldconfig

И смотреть, что получится

PS. Слушай huan-а, потому как libcrypto.so.4 в аспе нет.
Re: Траблы с ssh 28.03.2006 20:05Woodoo XMan писал(а):

> PS. Слушай huan-а, потому как libcrypto.so.4 в аспе нет.

---
# yum provides libcrypto.so.4
...
local.base [1/2]
local.base 100% |=========================| 951 B 00:00
updates-released [2/2]
updates-released 100% |=========================| 951 B 00:00
...
openssl097a.i386 0.9.7a-3.1asp local.base
Matched from:
libcrypto.so.4
---
Re: Траблы с ssh 31.03.2006 08:16huan
RSS-материал