ASPLinux 9 + Aureal Vortex 1 = Help please!!!

Автор: ak Дата: 06.06.2003 09:30 Немогу поставить драйвера для AU8820, выдает ошибку, эти же драйвера хорошо ставились под Mandrake 9.0 и 8.2, подскажите как поставить
Re: ASPLinux 9 + Aureal Vortex 1 = Help please!!! 06.06.2003 11:31shejn Это цитата из старого форума
Сразу примечание ниже аказано, где взять дрова, но это обычные дрова и у вас
я так понимаю они уже есть.
=====================================================================

После продолжительных гемороев удалось прикрутить Aureal Vortex1.
Поскольку пробема не только у одного меня (судя по форуму), то решил написать.
Качаем вот этот драйвер [docencia.mat.utfsm.cl]
Далее открываем файл audio.c (или au_audio.c) в текстовом редакторе.Примерно в строках под номерами порядка 623 , 650 находим следующее
# if LINUX_VERSION_CODE >= KERNEL_VERSION (2, 5, Поражён и меняем на
# if LINUX_VERSION_CODE >= KERNEL_VERSION (2, 4, 20)
Cохраняем.
Далее у меня все откомпилилось , но при запуске модуля драйвера вылезла ошибка:
что файл asp20.o (это для моей карты 20 , может еще быть 10 и 30) скомпилирван версией ? 2 ,а ядро ? 3.
Поэтому перед тем как собирать , открываем Hex редактором (например KhexEdit или что-то вроде этого из меню KDE) файл asp20.o . Формат отображения ставим - двоичный файл. Сверху на панели инстументов видим поиск. Набираем gcc2_compiled (нужно еще выбрать опцию TXT в окошке поиска). В правом поле видим искомую строчку и исправляем gcc2 на gcc3. Сохраняем.
Компилим: make install-all.

=================================================================
RSS-материал