GNOME 2.14 для ASPLinux 11

Аватар пользователя Tigro

Теперь репозиторий Development можно действительно проанонсировать.

Development - на данный момент репозиторий, в котором находится тестовая сборка GNOME 2.14 (если точнее, то пререлиза GNOME 2.14). В будущем этот репозиторий перельется в Other и Extras, и с того времени в нем будут находиться наработки, которые на мой взгляд опасно сразу выкладывать в основные репозитории.

Похоже уже сложившимся фактом является то, что всякая новая версия GNOME, а судя по всему в ближайшем будущем и KDE, будет хотеть новый системный софт. Это в первую очередь связано с такими пакетами, как UDEV, HAL и DBUS. GNOME 2.14 для своей нормальной работы требует DBUS 0.60 и HAL >= 0.5.6, а точнее 0.5.7. Эти пакеты нужны для нормальной работы GNOME-VFS (для автоматического монтирования сменных носителей). В свою очередь HAL 0.5.7 требует UDEV >= 078, а UDEV 078 требует ядро 2.6.15 и mkinitrd >= 4.2.21 (если вы не пользуетесь образами созданными mkinitrd, то mkinitrd вас заботить особо не должен). Ядро 2.6.15 судя по всему будет в обновлениях к ASPLinux 11, так как писутствует в обновлениях Fedora Core 4, так что проблемы с ядром свдятся к минимуму. Максиум что будет нужно, так это командой mkinitrd пересоздать образ inird для ядра.

DBUS - от старого dbus 0.50 зависят в дистрибутиве 26 бинарных пакетов, так как многие из них получаются из одного исходника, то пересобрать их особых проблем не вызывает.

HAL - начиная с версии 0.5.7 никаких записей в /etc/fstab для сменных носителей hal не вносит. 0.5.6 еще что-то умел делать, но с последним GNOME-VFS нормально не работал. Через Компьютер рабочего стола GNOME можно все прекрасно монтировать. Для всех других нужд есть два пакета pmount и gnome-mount. Последний от разработчиков HAL, но с довольно странными замашками, зато GNOME-VFS с ним нормально работает, так что есть и то, и то, но для XFCE, допустим, лучше использовать только pmount. Работать с ним очень просто:

pmount /dev/fd0

Точка монтирования создается сама собой. Вообщем еще проще, чем было с добавлением HAL'ом строк в /etc/fstab.

Приглашаются все желающие потестировать. Если все сложится удачно, то вдруг Леон да включит в официальные обновления и GNOME 2.14. Обновляться нужно через YUM, создать файл asplinux-development.repo в каталоге /etc/yum.repos.d:

[development]
name=ASPLinux $releasever - $basearch - Development
baseurl=ftp://ftp.msiu.ru/pub/asplinux-11/updates/development/
enabled=1
gpgcheck=1
gpgkey=http://updates.msiu.ru/me/GPG-KEY

RSS-материал