Помогите собрать ядро

Аватар пользователя Compman

- Скачал kernel-2.6.14-1.1653.1asp.src.rpm
- rpm -ivh kernel-2.6.14-1.1653.1asp.src.rpm
не могу создать каталог /usr/src/asplinux
-ну я ему ручками создал
-появилось два каталога
/usr/src/asplinux/SOURCES
/usr/src/asplinux/SPECS
Что дальше?
И вообще я исходники скачал?Пол дня качал
:-o

Аватар пользователя sergeil

Re: помогите собрать ядро

Цитата:
Compman пишет:
- Скачал kernel-2.6.14-1.1653.1asp.src.rpm

ОК

Цитата:
не могу создать каталог /usr/src/asplinux
-ну я ему ручками создал
-появилось два каталога
/usr/src/asplinux/SOURCES
/usr/src/asplinux/SPECS

Вместо всего этого устанавливаем пакет rpm-build
`yum install rpm-build`

Цитата:
Что дальше?
И вообще я исходники скачал?Пол дня качал
:-o

1. Читаем статью, которую не поленился написать Ульяницкий Николай (aka lystor) http://asplinux.net/node/46
2. Следуем рекомендациям...

Аватар пользователя Compman

Re: помогите собрать ядро

ОК.Буду разбираться

Аватар пользователя sergeil

Re: помогите собрать ядро

Цитата:
Compman пишет:
ОК. Буду разбираться

Ну и как Ваши результаты?

Аватар пользователя mad_shef

Re: помогите собрать ядро

Следуя этой инструкции пытался пересобрать ядро.
rpmbuild -bp --target=i586 kernel-2.6.spec
Платформы для сборки: i586
Сборка для платформы i586
ошибка: Неудовлетворенные зависимости сборки:
gnupg нужен для kernel-2.6.9-1.667.rootasp
Прочитал в инете что вроде как нужно установить этот самый gnupg
пишу rpm -ihv gnupg-1.2.6-9.rpm( пробовал и rpm -Uhv gnupg-1.2.6-9.rpm)
вроде как пакет установился, во всяком случае в /usr/src/asplinux/BUILD/ появился каталог gnupg-1.2.6-9
Пробую опять
rpmbuild -bp --target=i586 kernel-2.6.spec
Платформы для сборки: i586
Сборка для платформы i586
ошибка: Неудовлетворенные зависимости сборки:
gnupg нужен для kernel-2.6.9-1.667.rootasp
та же пестня
Пробовал собрать этот gnupg, ругается на
rpmbuild -bp --target=i586 gnupg-2.6.spec
Платформы для сборки: i586
Сборка для платформы i586
ошибка: Неудовлетворенные зависимости сборки:
gettext-devel нужен для gnupg-1.2.6-9
Подскажите,пожалуйста, что я не так делаю? Почему не видно что я установил требуемый пакет?

Пробовал пойти другим путем, распаковал исходники ядра в /usr/src/asplinux/BUILD/kernel-2.6.9/linux-2.6.9 и дальше по книжке make mrproper, make menuconfig, make dep, make clean, make bzImage, make modules - тут все прошло нормально, но как только попробовал make modules_install выскакивает ошибка, какая уже не помню, завтра пройду все еще раз и напишу точно какая ошибка. Дело в том что при загруженных Х у меня вообще тачка виснет при компиляции(тачка слабая 1-й пень 200 МГц, 56Мб ОЗУ), пришлось при установке Линуха снять галку "Использовать графический вход", тогда все компилится более-менее нормально, без зависаний.

RSS-материал