Установка gcc-4.0.2-8.fc4.i386

Аватар пользователя antigrustin

После установки системы АСП11 в конфигурации Сервер возникла необходимость в установке некоторых пакетов из исходников. Оказалось в такой конфигурации отсутствуют компиляторы...

[root@Gnet irc2.11.1p1]# ./configure
retrieving the system name, type and OS release...
  your system seems to be i686-pc-linux-gnu.
now working in directory i686-pc-linux-gnu...
checking for a BSD-compatible install... /usr/bin/install -c
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH

пытаюсь поставить gcc...

[root@Gnet gcc]# rpm -i --test ./gcc-4.0.2-8.fc4.i386.rpm
ошибка: Неудовлетворенные зависимости:
        glibc-devel >= 2.2.90-12 нужен для gcc-4.0.2-8.fc4.i386

[root@Gnet gcc]# rpm -i --test ./glibc-devel-2.3.5-10.3asp.i386.rpm
ошибка: Неудовлетворенные зависимости:
        glibc-headers нужен для glibc-devel-2.3.5-10.3asp.i386
        glibc-headers = 2.3.5-10.3asp нужен для glibc-devel-2.3.5-10.3asp.i386

[root@Gnet gcc]# rpm -i --test ./glibc-headers-2.3.5-10.3asp.i386.rpm
ошибка: Неудовлетворенные зависимости:
        kernel-headers нужен для glibc-headers-2.3.5-10.3asp.i386
        kernel-headers >= 2.2.1 нужен для glibc-headers-2.3.5-10.3asp.i386

а где взять этот kernel-headers??? в дистрибутиве АСП11 его нет. Или это можно пустить через --nodeps? будет ли после этого проходить нормально компиляция, а то как-то эксперементировать неохота=)

Аватар пользователя Tigro

Установка gcc-4.0.2-8.fc4.i386

Этот пакет называется glibc-kernelheaders и боже мой, указывайте все пакеты сразу, а не по одному.

Аватар пользователя antigrustin

Установка gcc-4.0.2-8.fc4.i386

Tigro писал(а):
Этот пакет называется glibc-kernelheaders и боже мой, указывайте все пакеты сразу, а не по одному.

действительно... вопщем прописал все вместе... поставилось все нормально)
сегодня поставил yum... удобная штука.
Тока вот вопрос... createrepo нужно запускать каждый раз при добавлении пакетов?
И такой вопрос... возможно ли удаление какого нибудь одного пакета через команду yum remove XXX без удаления зависимых пакетов? Или для этого опять нужно смотреть в сторону rpm?

RSS-материал