Не могу собрать xfce-4.3.90.1

Аватар пользователя WebCode

Здравствуйте.

Имеется желание поюзать XFCE, решил взять последнее что имеется - 4.3.90.1. При сборке второго пакета (libxfce4util-4.3.90.1) получил сообщение об ошибке:

checking for pkg-config >= 0.9.0... 0.15.0
checking for gobject-2.0 >= 2.6.0... found, but 2.4.7
*** The required package gobject-2.0 was found on your system,
*** but the installed version (2.4.7) is too old.
*** Please upgrade gobject-2.0 to atleast version 2.6.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.

Вопрос: что это за gobject? Толком ничего не нашел про него, т.е. нашел много, но, как я понял, это не то.

О системе:
ASP: 10.0
Kernel: 2.6.16.16
GCC: 3.4.5

Пожалуйста, подскажите, что делать, что поставить?

Заранее спасибо.

Аватар пользователя Tigro

Re: Не могу собрать xfce-4.3.90.1

glib2-devel он хочет.... и еще весрии не ниже чем 2.6.0.

Аватар пользователя WebCode

Re: Не могу собрать xfce-4.3.90.1

Tigro, спасибо...

Сейчас буду пробовать.

Аватар пользователя WebCode

Re: Не могу собрать xfce-4.3.90.1

Пора начинать новую тему Грустный.

И так, обновил:

Цитата:
# rpm -qa | grep glib
glib2-devel-2.6.4-1
....
glib2-2.6.4-1
....

В результате:

Цитата:
# mc
/usr/bin/mc: relocation error: /usr/lib/libglib-2.0.so.0: symbol __vsnprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference

И что мне делать? Грустный

Аватар пользователя WebCode

Re: Не могу собрать xfce-4.3.90.1

За то пошла сборка XFCE Улыбка

Аватар пользователя WebCode

Re: Не могу собрать xfce-4.3.90.1

Я ошибся Грустный. ./configure прошел, а вот на make трабл:

Цитата:
gcc -g -O2 -Wl,-O1 -o .libs/xfce4-kiosk-query xfce4_kiosk_query-main.o ../libxfce4util/.libs/libxfce4util.so -lgobject-2.0 -lglib-2.0 -Wl,--rpath -Wl,/usr/local/lib
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libgobject-2.0.so: undefined reference to `__memcpy_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__vfprintf_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__fprintf_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__vprintf_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__snprintf_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__vsnprintf_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__sprintf_chk@GLIBC_2.3.4'
/usr/lib/gcc/i386-asplinux-linux/3.4.5/../../../libglib-2.0.so: undefined reference to `__vsprintf_chk@GLIBC_2.3.4'
collect2: ld returned 1 exit status
make[2]: *** [xfce4-kiosk-query] Ошибка 1
make[2]: Leaving directory `/usr/src/xfce-4.3.90.1/src/libxfce4util-4.3.90.1/xfce4-kiosk-query'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/usr/src/xfce-4.3.90.1/src/libxfce4util-4.3.90.1'
make: *** [all] Ошибка 2

Аватар пользователя WebCode

Re: Не могу собрать xfce-4.3.90.1

Все, я умер Грустный, даже MC не работает, откат на старые версии не помог, буду стреляться.

Аватар пользователя Tigro

Re: Не могу собрать xfce-4.3.90.1

Вообще-то в обновлениях все было.... А GLIBC не трогали? Если трогали, то пулю в висок будет оптимальным решением.

В любом случае все познается на ошибках, мой первый Linux прожил 1 неделю в далеком 98 году Катается от смеха

Аватар пользователя WebCode

Re: Не могу собрать xfce-4.3.90.1

Вот сижу и выбераю: беретта или ТТ? :plusomet:

Вот найду куда 60гигов слить, буду ставить ASP 11.

:hammer:

Аватар пользователя sergeil

Re: Не могу собрать xfce-4.3.90.1

Цитата:
Tigro пишет:
В любом случае все познается на ошибках, мой первый Linux прожил 1 неделю в далеком 98 году Катается от смеха

мой меньше...
И год, примерно, совпадает...
Катается от смеха

Аватар пользователя Archont

Re: Не могу собрать xfce-4.3.90.1

Надо было не МЕНЯТЬ glib или glib2, а ДОУСТАНОВИТЬ glib-2.6, предварительно пересобрав его с именем glib26.
А с glibc вообще нужно быть предельно осторожным.
В принципе при наличии live-CD все еще не так уж страшно, все можно восстановить.

RSS-материал