Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

Аватар пользователя Radik

Спасибо Tigro, проблема с монтированием устройств с кодировками не UTF-8 может быть решена.
Но вот странная зависимость:

Цитата:
ошибка: Неудовлетворенные зависимости:
glibc > 2.3.6 конфликтует сglibc-common-2.3.6-3asp.i386
glibc < 2.4 конфликтует сglibc-common-2.4-8msiu.i386

Такого пакета сglibc-common-2.3.6-3asp.i386 у меня вообще не стоит... И даже в репозитариях его нет... Как же быть? :-?

Аватар пользователя Radik

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

Разбор полетов:
Может быть такое: "ошибка: Неудовлетворенные зависимости:
glibc > 2.3.6 конфликтует с glibc-common-2.3.6-3asp.i386
glibc < 2.4 конфликтует с glibc-common-2.4-8msiu.i386"
Тогда получается, что новый пакет конфликтует со старым...

Аватар пользователя Radik

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

Полет окончен. Нужно было просто устанавливать коммандой rpm -U...
Читать всякие статьи нужно почаще... Простите меня

Аватар пользователя Radik

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

Можно теперь тему переименовать "Проблемы после установки... " Грустный
Обновился. Теперь автоматически не монтируются ни флешка ни CD/DVD-диски...
Выдает:
Cannot mount volume
Unable to mount the volume 'My disk'

Где нужно подкрутить?

Аватар пользователя sergeil

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

Цитата:
rrraD пишет:
Можно теперь тему переименовать "Проблемы после установки... " Грустный
Обновился. Теперь автоматически не монтируются ни флешка ни CD/DVD-диски...
Выдает:
Cannot mount volume
Unable to mount the volume 'My disk'
Где нужно подкрутить?

[Offtopic]
Скажите, rrraD, только откровенно, что Вам не хватало в стандартном обновлении ASPLinux-11?
Или Вы забыли (не знали) несколько прописных истин:
1. Лучшее - это враг хорошего...
2. Ползучий улучшизм - очень распространенная болезнь...
[/Offtopic]

После столь существенных обновлений из репозитария MSIU Ваш дистрибутив, IMHO, трудно называть ASPLinux. Это уже MSIULinux...

Аватар пользователя Radik

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

sergeil писал(а):
[Offtopic]
Скажите, rrraD, только откровенно, что Вам не хватало в стандартном обновлении ASPLinux-11?
Или Вы забыли (не знали) несколько прописных истин:
1. Лучшее - это враг хорошего...
2. Ползучий улучшизм - очень распространенная болезнь...
[/Offtopic]

Да не осудят нас остальные члены форума:
Стандартные обновления? Они выходят не так часто как хотелось бы... Стараюсь обновляться yum-ом (asp-овские репозитарии включены обязательно), но что-то сейчас с репозитариями (обоими) проблемы...
1/2. Согласен. Но очень надоело, когда подключаешь флешку, а там одни кракозябры... Напрягает. Хотелось от этого избавиться.
Я не улучшаю дистрибутив без особой надобности. Только если уже критично или нужны новые финкции приложений.

Цитата:
После столь существенных обновлений из репозитария MSIU Ваш дистрибутив, IMHO, трудно называть ASPLinux. Это уже MSIULinux...

Именно, Сергей. У меня дистрибутив MSIU ASPLinux. На самом начальном этапе загрузки так и высвечивается.
ASP-овские пакеты дополнены пакетами msiu. Пока особых глюков не замечено, кроме как с F-Spot и Beagle, которые разработчики ASPLinux думают собрать только для следующих версий дистрибутива...

Аватар пользователя sergeil

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

Цитата:
rrraD пишет:
Стандартные обновления? Они выходят не так часто как хотелось бы...

Частота обновления - показатель нестабильности...

Цитата:
...очень надоело, когда подключаешь флешку, а там одни кракозябры... Напрягает. Хотелось от этого избавиться.

Странно, никогда не испытывал таких неудобств... Может быть дело в том, что я не полагаюсь на новомодные технологии, а использую проверенные решения?
[sergeil@homedesk ~]$ grep flash /etc/fstab

/dev/sda    /mnt/flash  vfat    noauto,codepage=866,iocharset=utf8,noexec,user 0 0
/dev/sda1 /mnt/flash1 vfat noauto,codepage=866,iocharset=utf8,noexec,user 0 0

И всегда предсказуемый результат...

Цитата:
ASP-овские пакеты дополнены пакетами msiu.

Не только дополнено, но и часть стандартных компонент заменено... IMHO, MSIU-Linux это ASPLinux-11+FC5.

Цитата:
Пока особых глюков не замечено

Ну... не все еще потеряно...

Цитата:
кроме как с F-Spot и Beagle, которые разработчики ASPLinux думают собрать только для следующих версий дистрибутива...

IMHO, не все так просто и разработчики ASPLinux не торопятся...
Скажу больше. Я не против потянуть прикладные пакеты из репозитария MSIU(как и из репозитария FC), но не фундаментальные компоненты, которые могут глобально повлияющие на систему...

Аватар пользователя Radik

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

sergeil писал(а):
Частота обновления - показатель нестабильности...

Поэтому и обновляю я обычно браузер, почтовик и yum...

Цитата:
Может быть дело в том, что я не полагаюсь на новомодные технологии, а использую проверенные решения?

А я использую. Мало того, я хочу чтобы они были стабильны и работали так, как хотятели разработчики при их написании... Возможно это добавляет мне некоторые проблемы, но я не сетую на то что они не правильно собраны кем-то (к примеру), а хочу найти выход КАК это исправить... Ну и это приносит некоторый опыт...

Цитата:
IMHO, MSIU-Linux это ASPLinux-11+FC5.

Согласен. Некоторые решения, которые реализованы в FC5, будут доступны только в следующем релизе ASP, а Tigro дает возможность на свой страх и риск опробовать их уже сейчас...

Цитата:
Ну... не все еще потеряно...

Так же как и в ASP v.11... Дистрибутивы/программы развиваются и ошибки неизбежны...

Цитата:
Я не против потянуть прикладные пакеты из репозитария MSIU(как и из репозитария FC), но не фундаментальные компоненты, которые могут глобально повлияющие на систему...

Возможно я поторопился. Если лекарство не найду, то откачусь (если найду как). Но думаю попытка стоит того, чтобы получить желаемое...

Аватар пользователя sergeil

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

rrraD писал(а):
Возможно я поторопился. Если лекарство не найду, то откачусь (если найду как).

Не спешите...
Я думаю, что Tigro сможет Вам помочь...

Цитата:
Но думаю попытка стоит того, чтобы получить желаемое...

Без всякого сомнения...

Аватар пользователя Radik

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

sergeil писал(а):
Не спешите...
Я думаю, что Tigro сможет Вам помочь...

Да, он помог в решении проблемы. Оказывается в файле /usr/share/hal/fdi/polisy/10osvendor/95-vfatcharset.fdi не были проставлены кавычки после cp1251:

Цитата:
<?xml version="1.0" encoding="ISO-8859-1"?>

true
true
true

true

true
true

После того как кавычки поставил все заработало.
Спасибо, Tigro! :good:

Аватар пользователя sergeil

Re: Проблемы с установкой hal-0.5.7-3.msiu.2.i386.rpm

rrraD писал(а):
Оказывается в файле /usr/share/hal/fdi/polisy/10osvendor/95-vfatcharset.fdi не были проставлены кавычки после cp1251:

Баг, однако...

RSS-материал