Gcc4 (gcc34) + libstdc-5

Аватар пользователя Aladdin

компиляция с исп. не только более раннего gcc (CC=gcc34), но и библиотек. В системе они есть - прикрутил. Теперь мне надо указать ./configure не толькго GCC=34, но и исп. библиотек libstdc++.so.5. Возможно ли это и как?

Аватар пользователя Tigro

Re: gcc4 (gcc34) + libstdc-5

GCC их должен сам цеплять...

Аватар пользователя Aladdin

Re: gcc4 (gcc34) + libstdc-5

Цитата:
Aladdin пишет:
компиляция с исп. не только более раннего gcc (CC=gcc34), но и библиотек. В системе они есть - прикрутил. Теперь мне надо указать ./configure не толькго GCC=34, но и исп. библиотек libstdc++.so.5. Возможно ли это и как?

тем не менее - gcc4 - юзает 7версию, gcc34 - 6-ю Грустный Простите меня значит, что-то не так делаю :-?

Аватар пользователя Tigro

Re: gcc4 (gcc34) + libstdc-5

А вам 5-я нужна? Тогда нужен gcc 3.2.x...

Аватар пользователя Aladdin

Re: gcc4 (gcc34) + libstdc-5

Цитата:
Aladdin пишет:
компиляция с исп. не только более раннего gcc (CC=gcc34), но и библиотек. В системе они есть - прикрутил. Теперь мне надо указать ./configure не толькго GCC=34, но и исп. библиотек libstdc++.so.5. Возможно ли это и как?

вобщем - вопрос ве тот же - сборка kde-3.5.3 из исходников. Дома ASP11 - почему-то отсутсвуют некоторые аплеты настройки. На на работе ASP10 (gcc 3.3) - без проблем. kde, как выяснилось, рекомендуется собирать gcc-3.3.3. Но новые ядра - корректно можно скомпилить только gcc4 - ранние не поддерживают регистровую передачу параметров.

Аватар пользователя Tigro

Re: gcc4 (gcc34) + libstdc-5

Ядро тоже рекомендовали очень долго собирать gcc 2.95.3...

RSS-материал