ASP11: Косо устанавливается и не загружается

Аватар пользователя ManuelCalavera

При установке ASP 11 (скачанного с ASP-шного сайта) мыша PS/2 вообще не работала, пришлось ставить клавой.
После установки при загрузке оно пишет буквально следующее:

Цитата:
Welcome to ASPLinux

Press 'I' to enter interactive startup

Запускается udev:
Инициализируется оборудование... диски сеть звукBUG: spinlock bad magic on CPU#0, modprobe/885 (Not tainted)
lock: c133e738, .magic: 00000000, .owner:/1, .owner_cpu: 0
BUG: spinlock backup on CPU#0, modprobe/885, c133e738 (Not tainted)

И на этом всё заканчивается. Единственное, на что он может реагировать, - это на кнопку Reset. Пытался переустанавливать - не помогло.

Аватар пользователя Andre

Re: ASP11: Косо устанавливается и не загружается

На контрольную сумму слитые диски проверялись?

Аватар пользователя DRVTiny

ASP11: Косо устанавливается и не загружается

Цитата:
BUG: spinlock bad magic

По идее Вам нужно отключить эти самые "новомодные" spinlock'и в параметрах ядра. Посмотрите на Google/Linux, как это делается (сам я ни разу не пробовал, но подозреваю, что как-то spinlock'и вырубить можно).

Аватар пользователя ManuelCalavera

Re: ASP11: Косо устанавливается и не загружается

Не нашлось... М-да... Видимо Linux мне так и не удастся поднять.

Аватар пользователя KAS

Re: ASP11: Косо устанавливается и не загружается

ManuelCalavera писал(а):
Welcome to ASPLinux

Press 'I' to enter interactive startup

Запускается udev:
Инициализируется оборудование... диски сеть звукBUG: spinlock bad magic on CPU#0, modprobe/885 (Not tainted)
lock: c133e738, .magic: 00000000, .owner:/1, .owner_cpu: 0
BUG: spinlock backup on CPU#0, modprobe/885, c133e738 (Not tainted)

С английским у меня не важно... это он процессор не может инициализировать? Или, что-то другое? И вы пробовали устанавлимать его в минимальном варианте?

Аватар пользователя AlexRKononoff

Re: ASP11: Косо устанавливается и не загружается

ManuelCalavera писал(а):
М-да... Видимо Linux мне так и не удастся поднять.

Не надо опускать руки!
Попробуте загрузить ядро с параметром "spinlock=no", либо "debug no", либо и с тем и с другим.
И еще что за машинка такая и проц какой у Вас?
Не Toshiba ли, или DELL-какой из новых?
На всех PC-compatible(Pentium-II/III/IV/Celeron) такого быть не может!

Аватар пользователя RedBeard

Re: ASP11: Косо устанавливается и не загружается

KAS писал(а):
ManuelCalavera,
Цитата:

Welcome to ASPLinux

Press 'I' to enter interactive startup

Запускается udev:
Инициализируется оборудование... диски сеть звукBUG: spinlock bad magic on CPU#0, modprobe/885 (Not tainted)
lock: c133e738, .magic: 00000000, .owner:/1, .owner_cpu: 0
BUG: spinlock backup on CPU#0, modprobe/885, c133e738 (Not tainted)

С английским у меня не важно... это он процессор не может инициализировать? Или, что-то другое? И вы пробовали устанавлимать его в минимальном варианте?

Английским можно не владеть, но где же логика? Как это процессор может не инициализироваться, если Линукс запускается??? Без движка поехали??? А spinlock в Линуксе - это что-то вроде GPF в Виндах: может быть вызван чем угодно. У меня например, возникает при попытке подключить драйвера для 53с400а SCSI карточки...

Подсказка: spinlock - это основной признак того, что некий драйвер не способен работать с предназначенным ему железом. Почему? А кто его знает!

Аватар пользователя KAS

Re: ASP11: Косо устанавливается и не загружается

RedBeard писал(а):
Английским можно не владеть, но где же логика? Как это процессор может не инициализироваться, если Линукс запускается??? Без движка поехали???

Прекрасно понимаю, что звучит крайне нелепо... но вот, что мне выдаёт dmesg | grep CPU:

Initializing CPU#0
CPU 0 irqstacks, hard=c03fd000 soft=c03fc000
CPU: After generic identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000
00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 0 0000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383f3ff c1c3fbff 00000000 00000020 00000000 0000000 0 00000000
Intel machine check reporting enabled on CPU#0.
CPU: AMD Athlon(tm) XP 1700+ stepping 01
ACPI: CPU0 (power states: C1[C1] C2[C2])

Инициализация проца - это его определение... дело в том, что одно дело общаться с процом на уровне базовых команд, а совсем другое дело юзать его на полную, а как именно будет юзаться процессор зависит от того, как он определиться... Рассмотрим пример на процессорах: 386 и Pentium III и OS FreeBSD 4.11 (для i386) по умолчанию в ядре FreeBSD включена поддержка процессора 386. Pentium III совместим с 386, но имеет больше возможностей, для того что бы юзать на полную Pentium III (подтачить ядро под этот проц) рекомендуют убрать из ядра поддержку 386, 486 и оставить 586 или 686(для начала нужно узнать модель проца командой dmesg, чтобы знать что оставить) , но всё это черевато тем, что если поменять проц на другой, FreeBSD просто навсего может не запуститься... То есть, ядро не будет поддерживать "базу" ... А то, что грузится линуха - это вполне естественно(ибо поддерживается сама "база"), а вот что проблемы с определением проца - это 100%... Хотя может быть я и ошибаюсь...

Аватар пользователя KAS

Re: ASP11: Косо устанавливается и не загружается

Хотя вполне вероятно, что более логично, эта критическая ошибка вызвана при загрузке какого-нибудь модуля программой modprobe!

Аватар пользователя RedBeard

ASP11: Косо устанавливается и не загружается

KAS писал(а):
RedBeard,
Цитата:

Английским можно не владеть, но где же логика? Как это процессор может не инициализироваться, если Линукс запускается??? Без движка поехали???

Прекрасно понимаю, что звучит крайне нелепо... но вот, что мне выдаёт dmesg | grep CPU:

Initializing CPU#0
CPU 0 irqstacks, hard=c03fd000 soft=c03fc000
CPU: After generic identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000
00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 0 0000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383f3ff c1c3fbff 00000000 00000020 00000000 0000000 0 00000000
Intel machine check reporting enabled on CPU#0.
CPU: AMD Athlon(tm) XP 1700+ stepping 01
ACPI: CPU0 (power states: C1[C1] C2[C2])

Инициализация проца - это его определение... дело в том, что одно дело общаться с процом на уровне базовых команд, а совсем другое дело юзать его на полную, а как именно будет юзаться процессор зависит от того, как он определиться... Рассмотрим пример на процессорах: 386 и Pentium III и OS FreeBSD 4.11 (для i386) по умолчанию в ядре FreeBSD включена поддержка процессора 386. Pentium III совместим с 386, но имеет больше возможностей, для того что бы юзать на полную Pentium III (подтачить ядро под этот проц) рекомендуют убрать из ядра поддержку 386, 486 и оставить 586 или 686(для начала нужно узнать модель проца командой dmesg, чтобы знать что оставить) , но всё это черевато тем, что если поменять проц на другой, FreeBSD просто навсего может не запуститься... То есть, ядро не будет поддерживать "базу" ... А то, что грузится линуха - это вполне естественно(ибо поддерживается сама "база"), а вот что проблемы с определением проца - это 100%... Хотя может быть я и ошибаюсь...

То, что ты привел - это и есть нормальное определение типа процессора, а то, что никаких ошибок при этом не возникло говорит о том, что процессор опознан системой (в твоей терминологии - инициализирован), и все остальные ошибки конкретно к процессору никакого отношения иметь не могут!

Аватар пользователя RedBeard

ASP11: Косо устанавливается и не загружается

KAS писал(а):
Хотя вполне вероятно, что более логично, эта критическая ошибка вызвана при загрузке какого-нибудь модуля программой modprobe!

А вот это - абсолютно правильный ход мысли! Я же привел подобный пример.

Аватар пользователя ManuelCalavera

Re: ASP11: Косо устанавливается и не загружается

AlexRKononoff писал(а):
Попробуте загрузить ядро с параметром "spinlock=no", либо "debug no", либо и с тем и с другим.

Пробовал Но может быть я не так пробовал?.. В ASPLoader'е я выбирал Configuration -> Linux kernel settings и там в строке вводил сначала "spinlock=no" потом "debug no" потом "spinlock=no; debug no", затем запускал Linux. Но каждый раз всё заканчивалось тем же.

AlexRKononoff писал(а):
И еще что за машинка такая и проц какой у Вас?
Не Toshiba ли, или DELL-какой из новых?
На всех PC-compatible(Pentium-II/III/IV/Celeron) такого быть не может!

Celeron 2400.

Попробовал поставить 11.2, та же реакция.

Аватар пользователя RedBeard

ASP11: Косо устанавливается и не загружается

ManuelCalavera писал(а):
AlexRKononoff,
Цитата:

Попробуте загрузить ядро с параметром "spinlock=no", либо "debug no", либо и с тем и с другим.

Пробовал Но может быть я не так пробовал?.. В ASPLoader'е я выбирал Configuration -> Linux kernel settings и там в строке вводил сначала "spinlock=no" потом "debug no" потом "spinlock=no; debug no", затем запускал Linux. Но каждый раз всё заканчивалось тем же.

AlexRKononoff,
Цитата:

И еще что за машинка такая и проц какой у Вас?
Не Toshiba ли, или DELL-какой из новых?
На всех PC-compatible(Pentium-II/III/IV/Celeron) такого быть не может!

Celeron 2400.

Попробовал поставить 11.2, та же реакция.

А я ведь, писал уже о чем-то подобном тут! Тема была насчет установки ASP на ноутбук. Так вот, не debug=no, не spinlock=no, а просто, и со вкусом - noprobe!

Аватар пользователя ManuelCalavera

ASP11: Косо устанавливается и не загружается

RedBeard писал(а):
просто, и со вкусом - noprobe!

Не помогло! Катается от смеха

Аватар пользователя alex789

Re: ASP11: Косо устанавливается и не загружается

Такая же проблема, только последние строчки

Bug: spinlock bad magic on CPU#0, modprobe/869 (Tainted: P )
lock ef1f885c, .magic 00000000, owner: /-1, owner_cpu: 0

Аватар пользователя alex789

Re: ASP11: Косо устанавливается и не загружается

НАШЕЛ нужно удалить pci=noacpi

Работает!!!!!!!

RSS-материал