1Cv8.1 на ASPLinux11

Аватар пользователя Pauli

Бета сервера 1Cv8.1 прекрасно устанавливается и работает на ASPLinux11, кроме WEB-сервисов. Ошибка при попытке запуска Apache: *** glibc detected *** /usr/sbin/httpd: free(): invalid pointer: 0x05e0a160 ***
В файл httpd.conf программа wsinst добавила, кроме прочего, строку LoadModule _1cws_module "/opt/1cv81/wsapch2.so" Похоже, этот модуль оказался несовместим с httpd-2.0.54-10.2asp. Из 1С мне ответили вполне вежливо и обоснованно, что: "В настоящий момент мы утверждаем, что сервер Предприятия 8.1 работоспособен в Linux Fedora Core 4.
Используйте, пожалуйста, именно эту операционную систему." И тем не менее, не хочу я бросать любимый дистрибутив, основанный, тем более, на том же самом Core 4! Может, помочь им в повышении совместимости? Представляете эффект, если удастся сделать ASPLinux стандартным для 1С:Предприятия?

Аватар пользователя AS_Pushkin

1Cv8.1 на ASPLinux11

Pauli писал(а):
В файл httpd.conf программа wsinst добавила, кроме прочего, строку LoadModule _1cws_module "/opt/1cv81/wsapch2.so" Похоже, этот модуль оказался несовместим с httpd-2.0.54-10.2asp. Из 1С мне ответили вполне вежливо и обоснованно, что: "В настоящий момент мы утверждаем, что сервер Предприятия 8.1 работоспособен в Linux Fedora Core 4.

А может, стоит попробовать установить Apache от FC4?

Кстати, а где взять 1Сv8.1?

Аватар пользователя RedBeard

Re: 1Cv8.1 на ASPLinux11

AS_Pushkin писал(а):
Pauli,
Цитата:

В файл httpd.conf программа wsinst добавила, кроме прочего, строку LoadModule _1cws_module "/opt/1cv81/wsapch2.so" Похоже, этот модуль оказался несовместим с httpd-2.0.54-10.2asp. Из 1С мне ответили вполне вежливо и обоснованно, что: "В настоящий момент мы утверждаем, что сервер Предприятия 8.1 работоспособен в Linux Fedora Core 4.

А может, стоит попробовать установить Apache от FC4?

Кстати, а где взять 1Сv8.1?

Да тут ясен пень, надо в 1С спрашивать, с каким httpd у них это работает, и если ответят, то такой и ставить.

А насчет последнего вопроса я очень долго смеялся!!!

Дополнение: Я не сказал бы, что в 1С работают одни недоумки, но поддержка там весьма... своеобразная (чтобы хуже не сказать). От них очень сложно добиться чего-нибудь толкового, проще самому сделать. Это не удивительно, они народ в службу поддержки буквально с улицы за гроши нанимают.

Аватар пользователя AS_Pushkin

Re: 1Cv8.1 на ASPLinux11

RedBeard писал(а):
Да тут ясен пень, надо в 1С спрашивать, с каким httpd у них это работает, и если ответят, то такой и ставить.

Apache от FC4 отлично ставится и работает на ASPLinux 11.

RedBeard писал(а):
А насчет последнего вопроса я очень долго смеялся!!!

Я очень много слышал про 1Сv8.1, но никогда не видел, чтобы кто-то его продавал или "давал" на тестирование. У наших белорусских франчайзи его еще нету. Ну, по крайней мере две недели назад не было.

Аватар пользователя RedBeard

1Cv8.1 на ASPLinux11

AS_Pushkin писал(а):
Я очень много слышал про 1Сv8.1, но никогда не видел, чтобы кто-то его продавал или "давал" на тестирование. У наших белорусских франчайзи его еще нету. Ну, по крайней мере две недели назад не было.

Тоже ни разу не видел, хоть я и в Москве, и у меня много юзеров, которые 8.0 купили официально. Но здесь больше под виндами.

Аватар пользователя antigrustin

1Cv8.1 на ASPLinux11

Дайти ссылку откуда скачать хоть какойнить 1С... лиш бы под линукс шоб :-o

Аватар пользователя vyacheslav

Re: 1Cv8.1 на ASPLinux11

На сайте 1с сказано, что 1c v8.1 под linux будет на февральском номере ИТС
http://www.1c.ru/news/info.jsp?id=6316

Аватар пользователя arckadyr

Re: 1Cv8.1 на ASPLinux11

И вышел-таки 1С 8.1 в феврале. и даже есть ASPLinux, получивший "совместимо с 1С". Однако версия 1С 8.1 пока ещё настолько сырая (особенно в части различных конфигураций), что ставить её я бы пока поостерегся. разве что в порядке тестирования... Может, через годик...

RSS-материал