Не могу установить пакет, требуется libm.so.5

Аватар пользователя Sewix

rpm -ivh SNNS-4.1-2.i386.rpm
ошибка: Неудовлетворенные зависимости:
libm.so.5 нужен для SNNS-4.1-2.i386
libc.so.5 нужен для SNNS-4.1-2.i386
Пробовал решить проблему слудующим образом.
ln -s libc-2.4.so libc.so.5
ln -s libm-2.4.so libm.so.5
Не помогло.
ASPLinux 11.

Аватар пользователя RedBeard

Не могу установить пакет, требуется libm.so.5

Sewix писал(а):
rpm -ivh SNNS-4.1-2.i386.rpm
ошибка: Неудовлетворенные зависимости:
libm.so.5 нужен для SNNS-4.1-2.i386
libc.so.5 нужен для SNNS-4.1-2.i386
Пробовал решить проблему слудующим образом.
ln -s libc-2.4.so libc.so.5
ln -s libm-2.4.so libm.so.5
Не помогло.
ASPLinux 11.

Установите необходимые библиотеки с Федоровских репозиториев: http://fedora.redhat.com/download/mirrors/fedora-core-5, или что-то вроде (ну,не помню я точно!)

Аватар пользователя Sewix

Не могу установить пакет, требуется libm.so.5

Тут не все так просто.
Файлы libc.so.5 и libm.so.5 достаточно древние Как я нашел входили в RedHat 6.X. http://rpm.pbone.net/index.php3/stat/4/idpl/2396362/com/libc-5.3.12-31.i...
У меня уже есть установленные libc-2.4.so и libm-2.4.so. Я так понимаю что это этаже библиотека только более новая верся.
Но если даже установить смволическую ссылку пакет не устанавливается. Всеравно просит эти библиотеки.

Аватар пользователя Tigro

Не могу установить пакет, требуется libm.so.5

Версии должны совпадать. Ваш пакет хочет более старые библиотеки, однако может вам повезет и при помощи "rpm -ihv" вы сможете поставить без конфликтов более старые библиотеки.

Аватар пользователя Sewix

Не могу установить пакет, требуется libm.so.5

Всем спасибо. Проблема решилась сборокой пакети из исходинков.

Аватар пользователя paw

Re: Не могу установить пакет, ...

Похожая проблема на CentOS. Откуда исходники брали и можно подробнее расписать...

Аватар пользователя Alk-13

Re: Не могу установить пакет, ...

Не могу установить приложения( пишет libgnutls.so.13(GNUTLS_1_3) is needed by package kvm-65-1.fc9.i386 (fedora)
Подскажите

Аватар пользователя Подсказчик

Re: Не могу установить пакет, ...

АСП !Федора.

Цитата:
пишет libgnutls.so.13(GNUTLS_1_3) is needed by package kvm-65-

Так дайте ему их.

RSS-материал