Когда наконец будет GLibC 2.4 в апдейтах?

Аватар пользователя DRVTiny

Собственно сабж.
У меня ни один пакет от Федоры 5 не ставится из-за того, что в официальных апдейтах всё ещё лежит GLibC 2.3.6
Таким образом:
а) На данный момент текущая версия Федоры и ASPLinux 11 со всеми обновлениями несовместимы ПОЛНОСТЬЮ (кто бы мне ещё объяснил, зачем вообще в таком случае эти обновления нужны?) Т.е. все декларации о совместимости ASPLinux с Федорой - полная чушь. В ASPLinux обновляется всё, что угодно, только не критически важные библиотеки, от которых зависят все (до)устанавливаемые в систему приложения за редким исключением;
б) Мы имеем дистрибутив, в котором даже из исходников при наличии необходимых библиотек и заголовочных файлов далеко не все программы ставятся (поскольку те разработчики, которые "не на бронепоезде", уже давно используют GLibC 2.4);
в) Если и в ASPLinux 11.2 не будет GLibC 2.4, с точки зрения rpm мы фактически получим вместо Fedora Core IV, "запоздалым" клоном которого которой являлся ASPLinux 11, некую "Fedora Core IV+", нечто среднее между полгода назад вышедшей V'кой и годовалой давности IV'кой. В таком случае этот "новый" дистрибутив может купить разве что совсем уж конченный пользователь. Ни один человек в здравом уме за ЭТО отдавать свои кровные не будет.

Вообще интересно, в ASPLinux понимают хотя бы, что rpm-пакеты для любого свежего ПО сейчас собираются для пятой Федоры? Или эти перманентно "сильно занятые" люди предполагают, что все просто обязаны ограничиться софтом, входящим в состав их дистрибутива и, что называется, "не рыпаться"?!

Аватар пользователя RedBeard

Когда наконец будет GLibC 2.4 в апдейтах?

DRVTiny писал(а):
Собственно сабж.
У меня ни один пакет от Федоры 5 не ставится из-за того, что в официальных апдейтах всё ещё лежит GLibC 2.3.6
Таким образом:
а) На данный момент текущая версия Федоры и ASPLinux 11 со всеми обновлениями несовместимы ПОЛНОСТЬЮ (кто бы мне ещё объяснил, зачем вообще в таком случае эти обновления нужны?) Т.е. все декларации о совместимости ASPLinux с Федорой - полная чушь. В ASPLinux обновляется всё, что угодно, только не критически важные библиотеки, от которых зависят все (до)устанавливаемые в систему приложения за редким исключением;
б) Мы имеем дистрибутив, в котором даже из исходников при наличии необходимых библиотек и заголовочных файлов далеко не все программы ставятся (поскольку те разработчики, которые "не на бронепоезде", уже давно используют GLibC 2.4);
в) Если и в ASPLinux 11.2 не будет GLibC 2.4, с точки зрения rpm мы фактически получим вместо Fedora Core IV, "запоздалым" клоном которого которой являлся ASPLinux 11, некую "Fedora Core IV+", нечто среднее между полгода назад вышедшей V'кой и годовалой давности IV'кой. В таком случае этот "новый" дистрибутив может купить разве что совсем уж конченный пользователь. Ни один человек в здравом уме за ЭТО отдавать свои кровные не будет.

Вообще интересно, в ASPLinux понимают хотя бы, что rpm-пакеты для любого свежего ПО сейчас собираются для пятой Федоры? Или эти перманентно "сильно занятые" люди предполагают, что все просто обязаны ограничиться софтом, входящим в состав их дистрибутива и, что называется, "не рыпаться"?!

В официальных нет, а в Тигриных MSIU - есть! Я уже с месяц, как пользую, и вам того же советую!

Аватар пользователя redd

Когда наконец будет GLibC 2.4 в апдейтах?

DRVTiny писал(а):
Если и в ASPLinux 11.2 не будет GLibC 2.4, с точки зрения rpm мы фактически получим вместо Fedora Core IV, "запоздалым" клоном которого которой являлся ASPLinux 11, некую "Fedora Core IV+", нечто среднее между полгода назад вышедшей V'кой и годовалой давности IV'кой. В таком случае этот "новый" дистрибутив может купить разве что совсем уж конченный пользователь. Ни один человек в здравом уме за ЭТО отдавать свои кровные не будет.

Я вообще не понимаю смысла выпуска 11.2 версии. Зачем выпускать заведомо мертвый и ненужный продукт. Согласно списку софта который будет там представлен это какое-то подобие debian sarge(куча старых пакетов) с нестабильностью mandrake(куча багов, дырок и проблем). И это даже если в 11.2 будет GlibC 2.4. Уже сейчас понятно что 11-ка не успевает за Федорой. Отсюда и проблемы совместимости.

RedBeard писал(а):
В официальных нет, а в Тигриных MSIU - есть! Я уже с месяц, как пользую, и вам того же советую!

А это так к слову.
http://updates.msiu.ru/blog/article/po-povodu-asplinux-112

Ключевой текст опубликованный Тигро:
"Наверно уже не секрет, что в ближайшем будущем выйдет новый (с точки зрения линейки дистрибутивов от ASPLinux и старый с точки зрения програмного обеспечения) ASPLinux 11.2. Это некий обновленный вариант ASPLinux 11, который в свою очередь будет несовместим с Fedora Core 5 из-за старой GLIBC.
По поводу этого дистрибутива, я делаю официальное заявление, что поддерживаться он НЕ БУДЕТ. Причин несколько. И спорное место этого дистрибутива в соверменном мире, и более старые пакеты чем для ASPLinux 11, и вообще, возможно очень скоро моим любимым дистрибутивом станет Ubuntu, как знать."

Это про то куда катиться асп со своей политикой и отношением к пользователям. И все на фоне того что тот же убунту продвигается с дикой африканской скоростью, недавно поставил для теста Убунту 6.06 ЛТС - отличная локализация, современный софт, отличная документация и русский форум. Оличная профессиональная коммерческая поддержка, своевременные обновления(чего от аспа не дождаться), и теперь 5-ти летняя тех поддержка дистрибутива в сервер версии(включая апдейты) и 3-х летняя в десктоп версии. Отличный репозиторий, и дебиановская система пакетов(давайте смотреть правде в глаза, до которой yum-у топать и топать), и при этом доступ к дебиановским репозиториям, не будем говорит о количестве софта там, тем более что полная совместимость и доступ к проприетарным пакетам.

Тогда о чем речь?

Аватар пользователя Tigro

Когда наконец будет GLibC 2.4 в апдейтах?

redd писал(а):
Оличная профессиональная коммерческая поддержка, своевременные обновления(чего от аспа не дождаться), и теперь 5-ти летняя тех поддержка дистрибутива в сервер версии(включая апдейты) и 3-х летняя в десктоп версии. Отличный репозиторий, и дебиановская система пакетов(давайте смотреть правде в глаза, до которой yum-у топать и топать),

Значится так, дебайновская система пакетов ни к YUM, ни к APT никакого отношения не имеет. В случае FC/RH - это RPM, в случае Debian/Ubuntu - это DEB. DEB (как раз система пакетов) - это наверно пример того, как не нужно делать эти самые пакеты. После RPM просто страшно смотреть. Что касается YUM и APT, то принципиальной разницы нет никакой, можно и на FC накрутить APT, благо он есть в FC extras.

Аватар пользователя KAS

Когда наконец будет GLibC 2.4 в апдейтах?

RedBeard писал(а):
В официальных нет, а в Тигриных MSIU - есть! Я уже с месяц, как пользую, и вам того же советую!

А адресок можете подсказать? И как я правильно понимаю, после установки GLibC 2.4 я смогу ставить пакеты от Fedora Core 5?

Аватар пользователя Tigro

Когда наконец будет GLibC 2.4 в апдейтах?

LINK. Ставить-то сможете, но только будте бдительны!

Аватар пользователя KAS

Re: Когда наконец будет GLibC 2.4 в апдейтах?

Скачал :

[root@localhost glibc-2.4]# ls | sort
glibc-2.4-8msiu.i386.rpm
glibc-common-2.4-8msiu.i386.rpm
glibc-devel-2.4-8msiu.i386.rpm
glibc-headers-2.4-8msiu.i386.rpm
glibc-utils-2.4-8msiu.i386.rpm
[root@localhost glibc-2.4]#

При установке следующие проблемы:

[root@localhost glibc-2.4]# rpm -Uih glibc-2.4-8msiu.i386.rpm
предупреждение: glibc-2.4-8msiu.i386.rpm: Заголовок V3 DSA signature: NOKEY, key ID 6b85f346
ошибка: Неудовлетворенные зависимости:
glibc-common = 2.4-8msiu нужен для glibc-2.4-8msiu.i386
gdb < 6.3.0.0-1.111 конфликтует сglibc-2.4-8msiu.i386
glibc > 2.3.5 конфликтует сglibc-common-2.3.5-10.3asp.i386
glibc = 2.3.5-10.3asp нужен для (установлен)glibc-devel-2.3.5-10.3asp.i386
glibc = 2.3.5-10.3asp нужен для (установлен)glibc-headers-2.3.5-10.3asp.i386
[root@localhost glibc-2.4]#

Как разрешить эту проблему, чтобы с другим софтом не было проблем? Расскажите свой процесс установки.

Аватар пользователя KAS

Re: Когда наконец будет GLibC 2.4 в апдейтах?

Tigro писал(а):
rpm -Uhv glibc*

Это нормально:

[root@localhost glibc-2.4]# rpm -Uhv glibc*
предупреждение: glibc-2.4-8msiu.i386.rpm: Заголовок V3 DSA signature: NOKEY, key ID 6b85f346
ошибка: Неудовлетворенные зависимости:
gdb < 6.3.0.0-1.111 конфликтует сglibc-2.4-8msiu.i386
[root@localhost glibc-2.4]#

Как я понимаю в итоге ни чего не поставилось...

И странно, что не работает ключ force :

[root@localhost glibc-2.4]# rpm -Uhv --force glibc*
предупреждение: glibc-2.4-8msiu.i386.rpm: Заголовок V3 DSA signature: NOKEY, key ID 6b85f346
ошибка: Неудовлетворенные зависимости:
gdb < 6.3.0.0-1.111 конфликтует сglibc-2.4-8msiu.i386
[root@localhost glibc-2.4]#

Как тут быть?

Аватар пользователя KAS

Когда наконец будет GLibC 2.4 в апдейтах?

Нашёл gdb-6.3.0.0-1.122 на http://updates.msiu.ru/pack/other11.html . Вроде бы установка прошла успешно... Для окончательной проверке не плохо поставить пакетик от FC5.

Аватар пользователя Tigro

Re: Когда наконец будет GLibC 2.4 в апдейтах?

gdb еще нужен, зависимости как вы думаете, для чего придуманы? А --force не для этого, в этом случае нужен --nodeps.

Аватар пользователя KAS

Re: Когда наконец будет GLibC 2.4 в апдейтах?

Tigro писал(а):
LINK. Ставить-то сможете, но только будте бдительны!

Спасибо за пакет! Всё работает! А что значит быть бдительным? Могут быть какие-то проблемы?

Аватар пользователя Tigro

Re: Когда наконец будет GLibC 2.4 в апдейтах?

Это смотря что из федоры ставить будете!

Аватар пользователя KAS

Когда наконец будет GLibC 2.4 в апдейтах?

Tigro писал(а):
Это смотря что из федоры ставить будете!

В основном пользовательские приложения.

Аватар пользователя redd

Когда наконец будет GLibC 2.4 в апдейтах?

Tigro писал(а):
Значится так, дебайновская система пакетов ни к YUM, ни к APT никакого отношения не имеет. В случае FC/RH - это RPM, в случае Debian/Ubuntu - это DEB. DEB (как раз система пакетов) - это наверно пример того, как не нужно делать эти самые пакеты. После RPM просто страшно смотреть. Что касается YUM и APT, то принципиальной разницы нет никакой, можно и на FC накрутить APT, благо он есть в FC extras

Это понятно что в федоре и аспе rpm, а у дебиан/убунту deb Катается от смеха . Но ведь сама система пакетов без системы управления этимим пакетами ничто, я как раз это и имел ввиду, Вы просто не поняли, а я не четко выразился. Я не оспариваю что внутри пакета, я не разработчик, поэтому мне все равно что дебиановский пакет хуже редхатовского, только вот система пакетов вместе с системой управления пакетами гораздо лучше у дебиана чем у редхата и аспа. Это конечно не принципиальный спор и у каждого свое мнение, кому то может и yum+rpm лучше чем deb+apt(хотя я пробовал и то и другое, и последнее оприятней будит). А прикрутить apt к аспу или федоре конечно не проблема, тем более конвертация пакетов. Недавно сам перегонял драйвера к canon LBP 810 из rpm в deb. Так что это абсолютно не ключевой довод. Я долгое время балдел от системы портов BSD. Гораздо важнее другое - отношение к пользователям, своевременные обновления, техподдержка. Что у аспа сильно хромает учитывая что все таки техподдержка за денежку продается.
И естественно большое спасибо таким как Вы Тигро за помощ и энтузиазм в усовершенствовании дистрибутива. Я лично очень не хочу чтобы Вы сменили АСП на убунту. Катается от смеха

RSS-материал