ASP Linux Server+Postgre=1C8

Аватар пользователя FDDS

Добрый день! Кто-нибудь пробовал устанавливать postgre и 1С8.1 на ASP Linux Server CPE?
При установке 1С8.1 пишет "пакет не найден" 1C_Enterprise-server, хотя на 3х предыдущих пакетах ошибок не было...
При установке postgre сразу же на пакете postgresql-libs также пишет "пакет не найден" libpg.so.3.

Использовались:

сервер под управлением ASP Linux Server CPE;
сервер 1С:Предприятия 8.1 релиз 8.1.8.76;
СУБД PostgreSQL 8.1.5-14.1C.

Аватар пользователя BigAndy

ASP Linux Server+Postgre=1C8

Устанавливал на 11.2 Никаких таких проблемм не возникло. За исключением описанных на etersoft.
Странно.
libpq.so.3 - это от pg 7x.
pg 8.0 испрользует /usr/lib/libpq.so.4
pg 8.1.x /usr/lib/libpq.so.5

подробнее, плз, как вы устанавливаете. Через какой-нть "Установка/удаление программ?" Если так, то забейте сразу. Пользуйте yum.

Аватар пользователя FDDS

ASP Linux Server+Postgre=1C8

Так и есть устанавливал просто двойным щелчком, использовал инфу с http://life.screenshots.ru/the-code-inside/php-platform/linux-1c-setup/
а как через консоль, можно поподробней?

Аватар пользователя BigAndy

ASP Linux Server+Postgre=1C8

FDDS писал(а):
а как через консоль, можно поподробней?

yum install
и rpm -ivh

Подробнее: man rpm, man yum

Аватар пользователя FDDS

ASP Linux Server+Postgre=1C8

Попробовал с помощью rpm -ivh :

[root@localhost ~]# rpm -ivh 1C_Enterprise-common-8.1.8-76.i386.rpm
Подготовка... ########################################### [100%]
пакет 1C_Enterprise-common-8.1.8-76 уже установлен
[root@localhost ~]# rpm -ivh 1C_Enterprise-common-nls-8.1.8-76.i386.rpm
Подготовка... ########################################### [100%]
пакет 1C_Enterprise-common-nls-8.1.8-76 уже установлен
[root@localhost ~]# rpm -ivh 1C_Enterprise-server-8.1.8-76.i386.rpm ошибка: 1C_Enterprise-server-8.1.8-76.i386.rpm: дайджест MD5:BAD Expected(31f50e e041ef4963da2fe1004c98a1cc) != (8a7f57e53f9ec7cf3b0bb3f2da81b1c8)
ошибка: 1C_Enterprise-server-8.1.8-76.i386.rpm не может быть установлен
[root@localhost ~]#

[root@localhost ~]# rpm -ivh postgresql-libs-8.1.5-14.1C.i386.rpm
Подготовка... ########################################### [100%]
1:postgresql-libs ########################################### [100%]
[root@localhost ~]# rpm -ivh postgresql-8.1.5-14.1C.i386.rpm
Подготовка... ########################################### [100%]
файл /usr/bin/clusterdb из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/createdb из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/createlang из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/createuser из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/dropdb из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/droplang из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/dropuser из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/pg_dump из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/pg_dumpall из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/pg_restore из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/psql из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr
файл /usr/bin/vacuumdb из устанавливаемого пакета postgresql-8.1.5-14.1C конфликтует с файлом из пакета postgr

может я делаю что то не так?

Аватар пользователя BigAndy

Re: ASP Linux Server+Postgre=1C8

FDDS писал(а):
[root@localhost ~]# rpm -ivh 1C_Enterprise-server-8.1.8-76.i386.rpm ошибка: 1C_Enterprise-server-8.1.8-76.i386.rpm: дайджест MD5:BAD Expected(31f50e e041ef4963da2fe1004c98a1cc) != (8a7f57e53f9ec7cf3b0bb3f2da81b1c8)
ошибка: 1C_Enterprise-server-8.1.8-76.i386.rpm не может быть установлен

Кривой пакет. Проверьте его md5

postgresql увас уже установлен. Либо удалите предыдущий, либо заапгредте (опция U )

Вообще все ошибки в выводе указаны. будте внимательнее, чтобы не констатировать базовые истины.

Аватар пользователя FDDS

Re: ASP Linux Server+Postgre=1C8

postgre: так точно, в первый раз пробовал через графический интерфейс - неудача, оказывается в Linux CPE уже есть компоненты Postgre и при чем естественно не свежего, пришлось его деинсталировать, а далее через rpm -ivh все пакеты встали.
1С: буду пробовать другой релиз, о результатах напишу.
Спасибо!

Аватар пользователя EVil

Re: ASP Linux Server+Postgre=1C8

Ребят а где вы брали 1C_Enterprise-common-8.1.8-76.i386.rpm 1C_Enterprise-server-nls-8.1.8-76.i386.rpm 1C_Enterprise-common-nls-8.1.8-76.i386.rpm 1C_Enterprise-server-8.1.8-76.i386.rpm?

Аватар пользователя СМВ

Re: ASP Linux Server+Postgre=1C8

У меня эти вещи с диска подписки 1С - ИТС-овский диск который.

Аватар пользователя manflow

Re: ASP Linux Server+Postgre=1C8

Устанавливайте с ключем --force --nodeps

RSS-материал