Ntfs-3g не видит руские файлы при автомонтировании

Аватар пользователя wertyq

поставил ntfs-3g, ntfsprogs, fuse, примонтировал,
mount -t ntfs /mnt /dev/sda5
все нормально русские файлы отображаются корректно в консоли и в иксах, но когда прописал в fstab монтирование разделов

/dev/sda1 /media/windows ntfs exec,fm
ask=133,dmask=022 0 0

(при ntfs-3g вместо ntfs то же самое)
при загрузке системы, обнаружил отсутствие папок и файлов с русскими именами. Никак не пойму с чем это связано. Есть подозрение на то, что локализация устанавливается после монтирования дисков(хотя это врятли) и поэтому нет rus букв.

вывод mount (без параметров)

default из fstab-а
/dev/sda1 on /media/windows type fuse (rw,nosuid,nodev,noatime,allow_other,default_permissions)

ручное монтирование
/dev/sda5 on /mnt type fuse (rw,nosuid,nodev,noatime,allow_other)

как привести монтирование из fstab по опциям к ручному???
как убрать флаг default_permissions и для чего от вообще???
может после снятия этой опции русские файлы будет видно?
Заранее благодарен.
============================
mount -t ntfs /mnt /dev/sda5
Это Вы монтируете через драйвер ntfs, вкомпиленный/добавленный в ядро.
Надо бы:

ntfs-3g /mnt /dev/sda5 (man ntfs-3g) -o some_options,locale=ваша_локаль

,если задумали монтировать через ntfs-3g.
соответственно в /etc/fstab:

/dev/sda1 /media/windows ntfs-3g some_options,locale=ваша_локаль 0 0

Аватар пользователя shmel

Re: ntfs-3g не видит руские файлы при автомонтировании

насколько помню в fstab надо выставлять параметр ioencoding = [кодировка]... или как там его....

Аватар пользователя ks

Re: ntfs-3g не видит руские файлы при автомонтировании

насколько помню в fstab надо выставлять параметр ioencoding = [кодировка]... или как там его....

Ну, у меня в 7-й и 8-й Федорах:

$ grep ntfs-3g /etc/fstab
/dev/sda6 /mnt/E ntfs-3g umask=0,dmask=0,fmask=111,locale=uk_UA.UTF-8 0 0

Не может быть, чтобы в аспе было так плохо! Улыбка

Аватар пользователя shmel

Re: ntfs-3g не видит руские файлы при автомонтировании

ks писал(а):
насколько помню в fstab надо выставлять параметр ioencoding = [кодировка]... или как там его....

Ну, у меня в 7-й и 8-й Федорах:

$ grep ntfs-3g /etc/fstab
/dev/sda6 /mnt/E ntfs-3g umask=0,dmask=0,fmask=111,locale=uk_UA.UTF-8 0 0

Не может быть, чтобы в аспе было так плохо! Улыбка

О! правильно:))) локаль:)

RSS-материал