Установка пакета

Аватар пользователя Yurycar

Неделю назад впервые инсталлировал ASPLinux 12 Carbon. Теперь хочу установить xneur-0.9.1-alt2.src.rpm
В терминале запускаю команду: yum install xneur-0.9.1-alt2.src.rpm получаю 2 или 3 страницы англ. строчек и в конце 2 ошибки.
В прикрепленном файле скриншот последней страницы. Тогда даю команду rpm -ivh xneur-0.9.1-alt2.src.rpm, получаю следующую ошибку (см. второй скриншот)
Может ли кто-нибудь сказать, что я, "чайник" не так делаю и как надо?
Спасибо

Аватар пользователя BigAndy1

Re: Установка пакета

Указанный вами файл надо устанавливать rpmbuild'ом
Как именно - прочтите man rpmbuild ,man rpm.

Для yum'а надо указывать только имя пакета.
man yum

Аватар пользователя shibatov

Re: Установка пакета

Доброго времени суток! Тож решил поставить xneur на ASPLinux 14.x. Пробовал xneur-0.12.0,0. 9.9. Остановился на xneur-0.11.1. Скачал XNeur-0.11.1.tar.bz2 и gXNeur-0.11.1.tar.bz2 здесь. XNeur-0.11.1.tar.bz2 после непродолжительных мучений установился. А вот с gXNeur-0.11.1.tar.bz2 возникли проблемы. ./configure выдала вот это:

checking for XNEURLIB... configure: error: Package requirements (xneur = 0.11.1) were not met:
No package 'xneur' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables XNEURLIB_CFLAGS
and XNEURLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Чего дальше делать так и не понял. Поиски привели сюда. Более менее похоже на то, что и я делал. Но не то. Указанное решение не помогло. Сижу... Куру... Читаю man pkg-config. Подскажите други чего дальше делать. Спасибо.

Аватар пользователя shibatov

Re: Установка пакета

Прошла ночь...Всказках правильно сказано: "Утро вечера мудренее...". И вот, что за ночь надумал:

ln -s /usr/local/lib/pkgconfig/xneur.pc /usr/lib/pkgconfig

Получил на выходе:

checking for GCONF... configure: error: Package requirements (gconf-2.0 >= 2.0) were not met:
No package 'gconf-2.0' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables GCONF_CFLAGS
and GCONF_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Это уже проходили. Поставил недостающий пакет и вот долгожданное:

gxneur 0.11.1 configured successfully:

Ура! Продолжаем... make, make install...
И вот о небо все заработало.
Если кому нибудь пригодится буду рад.

Аватар пользователя Димaфей

Re: Установка пакета

ln -s /usr/local/lib/pkgconfig/xneur.pc /usr/lib/pkgconfig ln: создание символьной ссылки `/usr/lib/pkgconfig/xneur.pc': Отказано в доступе
почему?

RSS-материал