AverTv 507

Аватар пользователя kbu

Помогите плиз разобраться с тв-тюнером AverTv 507...на многих каналах нет звука,а точнее можно сказать на всех..
ОС ASP Cobalt
создал Файлики /etc/modprove.conf/aliases
alias char-major-81 videodev
options i2c-algo-bit bit_test=1
options saa7134 card=45 tuner=38 i2c_scan=1 radio_nr=1
options tuner pal=d port2=0 port1=1
alias char-major-81-0 saa7134
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off

/etc/modprobe.d/saa7134
options saa7134 card=35 tuner=38 alsa=1
options tuner pal=d

и

/etc/modprobe.conf
alias char-major-81 videodev
options i2c-algo-bit bit_test=1
# YaST configured TV card
# oxTw.aWwYwEpmda8:User-Defined TV Card
alias char-major-81-0 saa7134
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off
options saa7134 card=45 i2c_scan=1
options tda9887 pal=d
options tuner pal=d

В чем может быть проблема что нет звука почти на всех каналах и радио тоже без звука хотя по всем признакам станции нашел и играет,но не воспроивзодит....
в /dev есть @radio, radio0, @video, video0
вот что пишет dmesg

saa7130/34: v4l2 driver version 0.2.14 loaded
saa7134 0000:00:08.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
saa7133[0]: found at 0000:00:08.0, rev: 209, irq: 11, latency: 32, mmio: 0xeb000000
saa7133[0]: subsystem: 1461:a14b, board: Avermedia AVerTV Studio 307 [card=45,insmod option]
saa7133[0]: board init: gpio is 20006c8
input: saa7134 IR (Avermedia AVerTV St as /devices/pci0000:00/0000:00:08.0/input/input6
ACPI: CPU0 (power states: C1[C1] C2[C2])
processor ACPI0007:00: registered as cooling_device1
thermal LNXTHERM:01: registered as thermal_zone0
ACPI: Thermal Zone [THRM] (40 C)
saa7133[0]: i2c eeprom 00: 61 14 4b a1 ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: ff d1 f7 ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c scan: found device @ 0x86 [tda9887]
saa7133[0]: i2c scan: found device @ 0xa0 [eeprom]
saa7133[0]: i2c scan: found device @ 0xc2 [???]
parport_pc 00:0b: reported by Plug and Play ACPI
parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP,TRISTATE]
tuner' 0-0043: chip found @ 0x86 (saa7133[0])
tda9887: Unknown parameter `pal'
DVB: Unable to find symbol tda9887_attach()
tuner' 0-0061: chip found @ 0xc2 (saa7133[0])
tuner-simple 0-0061: creating new instance
tuner-simple 0-0061: type set to 38 (Philips PAL/SECAM multi (FM1216ME MK3))
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
firewire_ohci 0000:01:00.1: PCI INT B -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
sd 0:0:0:0: Attached scsi generic sg0 type 0
sd 0:0:1:0: Attached scsi generic sg1 type 0
scsi 1:0:0:0: Attached scsi generic sg2 type 5
saa7134 ALSA driver for DMA sound loaded
saa7133[0]/alsa: saa7133[0] at 0xeb000000 irq 11 registered as card -1

Помогите плиз разобраться...

Аватар пользователя Телепат_

Re: AverTv 507

Вы пытаетесь звук передать через шину?
Есть отрывочные сведения, что пока линукс с осторожностью относится к таким картам...

Аватар пользователя kbu

Re: AverTv 507

прости,не понял что ты имешь ввиду...

Аватар пользователя ocioty

Re: AverTv 507

тоесть не через шнурок. мож не те дрова. говорит "305". 'стетоскопом' там по гнездам пройтися?

Аватар пользователя VSL

Re: AverTv 507

http://poplinux.ru/node/18
Гляньте здесь, может что и пригодится. Улыбка

Аватар пользователя kurlyak

Re: AverTv 507

У меня были аналогичные проблемы с тюнером Beholder TV607FM. Я взял подключил выход с тюнера на линейный вход звуковой карты, выставил все микшеры по максимуму и заработало. Кроме того если у тебя ядро меньше 2.6.27 то такие проблемы будут. Поставь ядро последнее например 2.6.30 с сайта http://www.kernel.org/ и проблем с тюнером поверь будет гораздо меньше. В данной ситуации микшер alsa вытавляеться такими командами:
alsamixer -c -0
alsamixer -c -1
Так же выставь на максимум микшер с ГУИ(граф. интерфейсом) в Линуксе.
Кроме того, как ты по-моему и делал добавь в modprobe.conf:
options saa7134 card=35 tuner=38 alsa=1
options tuner secam=d
Тут заметь должно быть secam а не pal как у тебя и смотри через kdetv это самая лучашя программа, работатет и под Гномом.

RSS-материал