Не показывает видео

Аватар пользователя Aleshka

Уважаемые эксперты!

Подскажите, пожалуйста - в чем может быть проблема - установил ASP Linux 12 на компьютер. Машина старая - P-III, RAM 256Mb, V-Card S3 Inc. Savage 4. Никаких проблоем при установке не было. Все стало хорошо. Но никакие видео файлы не проигрываются - в плеере просто "рябь" какая-то, вместо картинки. Подскажите, пожалуйста, как это настроить.

Аватар пользователя Alabay

Re: не показывает видео

Слабовата немного машинка - попробуйте оперативной памяти добавить (PC-133 объёмом 256мб стоит максимум 300 рублей) и процессор до допустимого максимума "доапгрейдить" (насколько я понимаю Tualatin - это предел, но Pentium III 1,2 Ггц опять-таки копейки стоит) , Gnome довольно прожорлив - 256 Mb это половина минимальных требований и для Cobalt и для Carbon (http://www.asplinux.ru/homeoffice/products/asplinux/cobalt/standard/), попробуйте посмотреть в сторону xfce, openbox и fluxbox. В идеале купите посвежее машину или исходите из "потолка" - это печатная машинка Улыбка Сам пользуюсь машиной эпохи 3-его пня (http://www.nix.ru/autocatalog/motherboards_chaintech/CHAINTECH_CT6AIV5_V...) с 512 Мб и PIII 733 Мгц, но понимаю, что не фонтан Грустный
Сборок под слабые машины довольно много, вот одна из них - http://forum.runtu.org/index.php/topic,5209.0.html

Аватар пользователя Телепат_

Re: не показывает видео

Огорчу: на PIII -800 mplayer крутит видео а HDкачестве.
Однако топегстартеру следовало бы просветить на телепатов: Что он, где, как и чем пробует смотреть видео? Потоковое ли/ с DVD ли? Ну, в общем, понимаете..

Аватар пользователя Alabay

Re: не показывает видео

Ну почему "огорчу", сам иногда смотрю mkv-фильмы, но с максимальной загрузкой памяти и swap'а, система крякает, прогибается, но вроде кажет. Про железо конечно поподробнее бы узнать, а то даже характеристики видюхи не совсем ясны! Памяти в любом случае добавить не мешало, Вы согласны? 256 мб - это не комильфо!

Аватар пользователя Телепат_

Re: не показывает видео

Alabay писал(а):
Вы согласны? 256 мб - это не комильфо!

почему не "комильфо". С lightweight DE и, еще лучше, с допиленным ядром - все работает вполне комфортно. Несколько тормозится переключение между тяжелыми приложениями типа ООО/Firefox.

Аватар пользователя Alabay

Re: не показывает видео

Aleshka, как он написал, использует систему в дефолтной комплектации (Gnome, можно чисто гипотетически рассмотреть его последующий переход и "допил" ядра, но понятно, что не "сию секунду" это произойдёт Улыбка ), про другую среду пока речь не идёт. Пусть, согласно вашему совету, попробует использовать не Totem, а Mplayer (я сам больше предпочитаю Xine, хотя и mplayer и VLC тоже вполне устраивают) в связке c win32-кодеками (вдруг действительно дело ещё и в проигрываемых видеофайлах (Xvid или другая экзотика).
# yum install mplayer mplayer-gui mencoder w32codecs libdvdcss2 (ну последнюю вообщем-то только для проигрывания защищённых DVD-дисков, ну уж пусть будет Улыбка )

Аватар пользователя Aleshka

Re: не показывает видео

Систему использую действительно в дефолтной конфигурации. При попытке проиграть видео с ДВД-диска ничего не выходит - на экране что-то типа "ряби" - даже силуэты картинки не видны. Видеокарта S3 Inc. Savage 4 на 32 Мб. В результате опытов понял, что видео размеров до 1 Гб с заиканием, но играется. Все, что больше приводит к описанному выше результату. При проигрывании видео даже до 1 Гб(например, кусок из ДВД диска - воб-файл) компьютер проигрывает его, но остановит его уже не выходит - только резет. система не реагирует уже ни на нажатие мышкой, ни на клавиатуру. Пользовался Totem и mplayer

Аватар пользователя Alabay

Re: не показывает видео

С видеокартой понятно, уточните остальное железо, ведь Pentium III и "машина старая" - слишком размыто.
И попробуйте открыть vob-файл не в gui, а в консоли, т.е. командой - http://itmages.ru/view.php?action=view&id=5870&key=ddcbf2, ещё раз уж на mplayer'e остановились прочтите http://www.opennet.ru/base/faq/mplayer_faq.txt.html

Аватар пользователя Aleshka

Re: не показывает видео

P-III 600 MHz
256Mb RAM
10 Gb HDD
DVD-RW
LAN
больше ничего в этой машине нет

Аватар пользователя Alabay

Re: не показывает видео

даже материнки? Озвучьте и чипсет "до кучи" Улыбка

Аватар пользователя Alabay

Re: не показывает видео

Самые главные вопросы, про которые в самую первую очередь забыли спросить:
* все обновления установлены?
* ненужные службы отключены (cups (если нет принтера), bluetooth (если его нет), apmd (у вас не ноутбук) и т.п.)?
* DVD-диски, которые проигрываются, без царапин и на каких скоростях записаны (может проблемы и в приводе)?

Аватар пользователя Aleshka

Re: не показывает видео

Обновления установлены все.
Принтер есть(Canon BLC-1000. старенький, с LPT-портом) поэтому cups включен. Остальные службы я не трогал. Как было при установке, так все и сейчас. никаких блютусов нет(вы что, смеетесь, на такой машине? Улыбка)
Это не ноутбук, а обычная стационарная машинка.
DVD-диски в идеальном состоянии. Лицензионные(лицензия настоящая - не липа). Привод новый.

Аватар пользователя Alabay

Re: не показывает видео

я не смеюсь - у меня машина чуть-чуть помощнее вашей (мать - CHAINTECH CT6AIV5, 512мб опер.памяти и Pentium III 733МГц), но и Wi-Fi (PCI-плата), и bluetooth (usb-брелок) есть, так что и для вас не всё потеряно.
Со службами советую "покумекать", там есть куда стремиться, может особо летать система и не будет, но посвободнее "вздохнёт".
Что у вас десктоп я уже понял Улыбка, выше ( "cups (если нет принтера), bluetooth (если его нет), apmd (у вас не ноутбук) и т.п.") - это комментарии к службам, а не вопросы Улыбка.
Всё таки, пока мой диагноз - вам ресурсов не хватает, пробуйте поработать с более лёгкими оконными средами - xfce, openbox, fluxbox...

RSS-материал