Не устанавливаетмя odesk на ASPLinux 14

Аватар пользователя mstdmstd

Всем привет
Установил ASPLinux 14 c KDE

uname -r : 2.6.27.25-78.2.56.0.140asp.i686.PAE

Мне надо установить odesk http://www.odesk.com/downloads
скачиваю версию для Fedora 10 так как для 9 нет и пробую запустить

rpm -ihv odesk-2.0.7-1fc10.i386.rpm :
ошибка: Неудовлетворенные зависиости:
libxml2.so.2(LIBXML2_2.4.30) нужен для odesk-2.0.7-1fc10.i386

[root@localhost oDesk]# yum search libxml2
Loaded plugins: refresh-packagekit
================================================================================= Matched: libxml2 =================================================================================
perl-XML-LibXML.i386 : Perl interface to the libxml2 library
libxml2.i386 : Library providing XML and HTML support
libxml2-devel.i386 : Libraries, includes, etc. to develop XML and HTML applications
libxml2-python.i386 : Python bindings for the libxml2 library
libxml2-static.i386 : Static library for libxml2
libxslt.i386 : Library providing the Gnome XSLT engine
libxslt-devel.i386 : Libraries, includes, etc. to embed the Gnome XSLT engine
libxslt-python.i386 : Python bindings for the libxslt library
python-lxml.i386 : ElementTree-like Python bindings for libxml2 and libxslt

Я установил те их этих пакетов которые не были установлены ранее но проблема осталась

Могу ли я установить libxml2-2.7.1-1.0.140asp.i386.rpm и если да то как?

В дистрибутиве пакета для ASPLinux 14 я нашел libxml2-2.7.1-1.0.140asp.i386.rpm для него выполнил :

[root@localhost oDesk]# rpm -qpl libxml2-2.7.1-1.0.140asp.i386.rpm
/usr/bin/xmlcatalog
/usr/bin/xmllint
/usr/lib/libxml2.so.2
/usr/lib/libxml2.so.2.7.1
/usr/share/doc/libxml2-2.7.1
/usr/share/doc/libxml2-2.7.1/AUTHORS
/usr/share/doc/libxml2-2.7.1/ChangeLog.gz
/usr/share/doc/libxml2-2.7.1/Copyright
/usr/share/doc/libxml2-2.7.1/NEWS
/usr/share/doc/libxml2-2.7.1/README
/usr/share/doc/libxml2-2.7.1/TODO
/usr/share/man/man1/xmlcatalog.1.gz
/usr/share/man/man1/xmllint.1.gz
/usr/share/man/man3/libxml.3.gz

И еще так как я делал yum -y update для системы этот пакет мог отновиться то как определить какая либа щас установлена то как?
То есть получить rpm -qpl но не для файла на диске а для установленного пакета?

 whereis  libxml2 :
libxml2: /usr/lib/libxml2.so /usr/lib/libxml2.a /usr/include/libxml2

Аватар пользователя телепат_

Re: Не устанавливаетмя odesk на ASPLinux ...

Вы действительно уверены, что пакет, собранный для F10 должен встать на АСП14?
Ваши слова

Цитата:
Могу ли я установить libxml2-2.7.1-1.0.140asp.i386.rpm и если да то как?

противоречат выводуrpm -qpl libxml2-2.7.1-1.0.140asp.i386.rpm
И, вообще, рекомендую аккуратнее обращаться с русскимйазыка. ЧИтать ваш пост не возможно.

RSS-материал