Установка rpm, пусто

Автор: antyan Дата: 04.02.2007 09:11 [root@antyan Krusader]# ls
krusader-1.50-1asp.src.rpm krusader-1.70.1.tar.gz
[root@antyan Krusader]# rpm -i --test krusader-1.50-1asp.src.rpm
[root@antyan Krusader]#

Тоесть ничего не выводиться в чем трабла? (Ни ошибок просто ничего ): )
Re: Установка rpm, пусто 04.02.2007 09:58Vascom Наверное это означает, что тест прошёл успешно, ошибок нет.
Re: Установка rpm, пусто 04.02.2007 10:53antyan Но и при rpm -i (-install) ничего не происходит.
Re: Установка rpm, пусто 04.02.2007 10:57Vascom > Но и при rpm -i (-install) ничего не происходит.

Конечно ничего не будет происходить. Если вы хотите увидеть процесс установки, то пишите rpm -ivh
Re: Установка rpm, пусто 04.02.2007 12:13antyan Писал и опять ничего Улыбка))
Re: Установка rpm, пусто 04.02.2007 12:57Vascom Ну не знаю, должно работать, если rpm не сломан. Остаётся только man rpm, man yum.
Re: Установка rpm, пусто 04.02.2007 13:15esvaf В идеальном варианте rpm и не должен ичего выводить - он пакет ставит, а выводит только сообщения об ошибках. Или вым ошибок хочется?
Re: Установка rpm, пусто 04.02.2007 14:25antyan Я немного ошибся, получаеться идёт этакая табличка загрузки точнее полоска доходит до 100% и всё опять с пустой строки. Но если пакет ставиться нормально почему тогда неработает софт который ставлю? Улыбка
Re: Установка rpm, пусто 04.02.2007 14:50BigAndy Означает что установка должна пройти без проблемм. без--test выполняется установка.
Проверте установку rpm -qi <имя_пакетов_без_версии>
Re: Установка rpm, пусто 04.02.2007 23:06mallory Начал ставить rpm-пакет, через 3 секунды передумал, нажал Ctrl+C. Позже решил ставить его. Дал команду __rpm -ivh имя_пакета__. Ответило, что уже стоит. Я сделал __rpm -e имя_пакета__ - сказало, что не установлен. Сделал rpm --rebuilddb. Потом повторил прежние две команды. Такие же ответы.
Почему linux так врет?
Поставил используя --force.
Re: Установка rpm, пусто 05.02.2007 01:53antyan Дай плиз точную команду для установки с --force
Юзал так;

[root@antyan Krusader]# rpm -ihv --force krusader-1.50-1asp.src.rpm
1:krusader ########################################### [100%]
[root@antyan Krusader]#

Опять ничего, проверял пишет пакет не стоит ):
Re: Установка rpm, пусто 05.02.2007 05:58bat Установлен пакет с исходниками, для работы программы необходимо скомпилировать пакет для установки, а за тем установить полученный после компиляции пакет в систему.
Re: Установка rpm, пусто 05.02.2007 11:18BigAndy antyan писал(а):

> Дай плиз точную команду для установки с --force
> Юзал так;
>
> [root@antyan Krusader]# rpm -ihv --force
> krusader-1.50-1asp.src.rpm
> 1:krusader
> ########################################### [100%]
> [root@antyan Krusader]#
>
> Опять ничего, проверял пишет пакет не стоит ):
>

как проверял? каким образом?
Учтите, что с параметром force пакет будет установлен даже без установки зависимых модулей, поэтому,, весьма вероятно неработоспособен.

Потом какиv боком вы устанавливаете командой rpm нескомпилированный пакет?
Вы man rpm читали?
Для вашего случая надо использовать rpmbuild со всеми необходимыми опциями?
--force здесь с вами сыграл злую шутку.
Вы вообще faq по установке src.rpm читали?
RSS-материал