Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал?

Автор: biv Дата: 14.06.2007 09:41 Суть проблемы: сервер имеет 2 гигабитных интерфейса NC324i, как я понял, они же Broadcom 57xx. Модуль tg3.ko (ядро 2.6.9) собрал, в ядро добавил. но видится только сетевой интерфейс lo. Ручками прописал /etc/sysconfig/network-scripts/ifcfg-eth0 и ./ifcfg-eth1. Но система не видит таких девайсов. В файле /etc/sysconfig/hwconf оба устройства присутствуют в классе NETWORK, но kudzu при каждом своем запуске ставит ему драйвер unknown. По команде service network restart получаю сообщения типа "Поднимается интерфейс eth0 ОК". Но команда ifcongig eth0 192.168.xxx.xxx приводит к обидному сообщению, что я опять в дураках. Где еще копать, коллеги?
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 14.06.2007 09:42Eraserus наверно система дров под них не знает...
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 14.06.2007 10:17biv Да в том-то и дело, что заявлено, что дрова должны быть под ядро 2.4 - tg3.o, а 2.6 - tg3.ko. Качал и у HP и у Broadcom - одни и те же rpm-ы, при компиляции одни и те же глюки. Но модуль собирается. По команде lsmod - показывается. А вот девайс eth0 или eth1 не появляется.
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 14.06.2007 10:44Eraserus а что за глюки то? экстрасенсы как обычно балду пинают, работать не хотят Улыбка
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 14.06.2007 19:15BigAndy 1 lspci что говорит?
2 убейте kudzu, тем более на сервере. Оно может настроить все что угодно, но как угодно.
3 приведите конфиги и логи
>Но команда ifcongig eth0 192.168.xxx.xxx приводит к обидному сообщению, что я опять в дураках. Где еще >пать, коллеги?
Пока я чувствую себя в дураках. Из-за тумана
Копать в логах и конфигах. Пока все, что моно ответить.
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 18.06.2007 10:10biv По lspci получаю:
05:04.0 Ethernet controller: Broadcom Corporation: Unknown device 1668 (rev a3)
05:04.1 Ethernet controller: Broadcom Corporation: Unknown device 1668 (rev a3)
kudzu убил, но пока ни eth0, ни eth1 не видятся.
Просмотр логов ничего не дает. Кроме фразы "Активируется интерфейс eth0: succeeded".
Что касается конфигов:
Файл /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
IPADDR=192.168.0.254
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
Соответственно, для eth1 похожие настройки, только там еще присутствует шлюз по умолчанию. Ну и адреса, конечно, другие.

Файл /etc/sysconfig/hwconf
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: tg3
desc: "Broadcom Corporation: Unknown device 1668"
vendorId: 14e4
deviceId: 1668
subVendorId: 103c
subDeviceId: 7039
pciType: 1
pcidom: 0
pcibus: 5
pcidev: 4
pcifn: 1
-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: tg3
desc: "Broadcom Corporation: Unknown device 1668"
vendorId: 14e4
deviceId: 1668
subVendorId: 103c
subDeviceId: 7039
pciType: 1
pcidom: 0
pcibus: 5
pcidev: 4
pcifn: 0

Такая вот загогулина...
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 18.06.2007 19:44BigAndy >>но пока ни eth0, ни eth1 не видятся.
Как это определяется?
Ну так IPADDR=192.168.0.254 пингуется?
Вроде все завелось.
ifconfig что показывает?
Re: Коллеги, на HP DL320 G4 кто-нибудь сеть настраивал? 19.06.2007 16:32biv Нет, не пингуются. Да и как они могут пинговаться, если сами интерфейсы отсутствуют?
RSS-материал