ASP 11.2 не видит NV nForce4 SATA

Автор: Kirillnow Дата: 01.06.2007 16:12 Собственно мое знакомство с ASP Linux ограничилось первыми страницами мастера установки и консолью там же. Жесткий диск не определяется. Пробовал действия из FAQ - не видит. В списке поддерживаемых устройств NF4 вообще не фигурирует Грустный :-( Грустный :-(
В биосе ни намека на какую-лбо настройку SATA.
Вопрос: реально ли поставить ASP при данной конфигурации оборудования?

P.S. sorry если такой вопрос уже был. я искал....
Re: ASP 11.2 не видит NV nForce4 SATA 01.06.2007 18:29Kirillnow на сайте Nvidia:

"Open source drivers for NVIDIA nForce hardware are included in the standard Linux kernel and leading Linux distributions. This page includes information on open source drivers, and driver disks for older Linux distributions including 32-bit and 64-bit versions of Linux."

Вобщем, типа у вас все должно работать Улыбка.
Скачал данную хрень: htтp://download.nvidia.com/XFree86/nforce/1.21/NFORCE-Linux-x86-1.21.zip
Там есть рпм-ки и исходник sata_nv.c,
но для Fedora Core 5 (2.6.15-1)
И как это использовать (поставить то систему я не могу)?
Re: ASP 11.2 не видит NV nForce4 SATA 02.06.2007 18:10Bircoph Отуомпилируйте под АСП, раз есть исходники. Там должно быть
какое-нибудь readme, почитайте его.
Re: ASP 11.2 не видит NV nForce4 SATA 03.06.2007 10:26BigAndy >>но для Fedora Core 5 (2.6.15-1)
А вчем проблеммы поставить rpm-ку под АСП? Что rpm ругается?
Re: ASP 11.2 не видит NV nForce4 SATA 03.06.2007 13:06bat Поставить эту самую ASP не могет, вот и спрашивает. Где-то видел подобный вопрос, но не помню чем дело кончилось, у меня бук.
Re: ASP 11.2 не видит NV nForce4 SATA 04.06.2007 10:50Kirillnow Вот что я придумал:
1. Под виндой вытащить из рпм-ки модуль ядра (там тока один файл)
2. Записать его вместе с рпм-кой на дискету
3. Загрузиться с АСП-диска, открыть консоль и примонтировать дискету
4. Скопировать модуль в соотв. папку на рамдиске
5. Прописать рпм-ку с дискеты в список устанавливамых
6. Загрузить модуль и начать установку

Отсюда вопрос, как выполнить пункт 5?
Re: ASP 11.2 не видит NV nForce4 SATA 04.06.2007 11:37Bircoph > Отсюда вопрос, как выполнить пункт 5?

Файл Packages.$i для $i-го диска.

> 1. Под виндой вытащить из рпм-ки модуль ядра (там тока один файл)

И как вы это намерены делать? Имхо, нужно использовать blin.
Re: ASP 11.2 не видит NV nForce4 SATA 04.06.2007 17:38Kirillnow >Файл Packages.$i для $i-го диска.
Т.е. для DVD это будет Packages.1? И где он лежит?

>И как вы это намерены делать? Имхо, нужно использовать blin.
7-Zip спокойно открывает .rpm как архив
Re: ASP 11.2 не видит NV nForce4 SATA 04.06.2007 20:12Bircoph > И где он лежит?

Вы хоть раз внутрь этого dvd смотрели?
Он лежит в каталоге со всеми rpm.
Re: ASP 11.2 не видит NV nForce4 SATA 05.06.2007 10:35Kirillnow Блин, не удалось замеить модуль ядра так как вся эта хрень смонтирована только для чтения.
Придется таки качать образ диска и править его.

Позже:
Скачал образ, поправил с помощью UltraISO live.img,
теперь при загрузке с диска выдает
request_module: runaway loop modprobe binfmt-9653
подозреваю что загрузчик не понимает формат live.img.
live.img - ISO9660+Joilet

Позже:
Сделал более "правильный" live.img с помощью ISO Commander.
Ошибка та же.

Позже:
Поставил WMware, при загрузке с поправленного образа та же ошибка, при загрузке с исходного в консоли поправленный образ монтируется нормально. Live.img как /dev/hda тоже монтируется нормально.

Позже:
С помощью WMware установил, что всетаки не монтируется live.img. Чем его вообще можно редактировать? Что используют для создания этих img файлов (я не говорю про initrd) для линукс-дистрибьютивов?
Re: ASP 11.2 не видит NV nForce4 SATA 06.06.2007 11:54Kirillnow Все, сделал, надо было Rock Ridge включить.
Только мои надежды не оправдались - модуль не запускается Грустный
[kavcrl.dyndns.org]

Так что придется ждать АСП 12
Re: ASP 11.2 не видит NV nForce4 SATA 06.06.2007 12:11Vascom Странно всё как-то.
Модуль sata_nv должен быть встроен в ядро, и в версии 2.6.17 должен поддерживать NF4.
Re: ASP 11.2 не видит NV nForce4 SATA 24.06.2007 13:32Kirillnow Если обновлять ядро не из rpm, то для работы в АСП достаточно настроек по-умолчанию?
Re: ASP 11.2 не видит NV nForce4 SATA 24.06.2007 14:53BigAndy Более чем. только если не ванильное.

Тем более что из исходников вы можете сделать make menuconfig и выставить нужные опции.
Re: ASP 11.2 не видит NV nForce4 SATA 24.06.2007 15:52bat >Более чем. только если не ванильное.
# uname -a
Linux mobail 2.6.20-1.2312.1.112asp #1 Thu Apr 19 13:58:03 EEST 2007 i686 i686 i386 GNU/Linux

Недавно скачал с kernel.org: The latest stable version of the Linux kernel is: 2.6.21.5 [kernel.org]

make menuconfig
Сразу же вышел, сохранил изменения.

make all
make modules_install
make install

Перезагрузился с новым ядром, ругнулось на отсутствие модуля fglrx.ko (у меня видео от ATI) и правильно, драйвера я не ставил. На первый взгляд всё работало как обычно: DMA на DVD приводе не включилось, инфракрасник не работает, всё как было. Ядро ванильное, я его специально не конфигурировал. Кстати, собралось в 2 раза быстрее, чем kernel-****.src.rpm от ASP.
Re: ASP 11.2 не видит NV nForce4 SATA 25.06.2007 00:14Kirillnow Гм, а если ядро ванильное, то его надо самому конфигурировать (нет настройки по-умолчанию)?
Re: ASP 11.2 не видит NV nForce4 SATA 25.06.2007 00:22BigAndy >А что значит ванильное ядро и как отличить от нормального?
[asplinux.net]
Будте с ним осторожно... не забудте при компиляции включить x_tables (поддержку iptables) Там по умолчанию этот парметр выключен.
Re: ASP 11.2 не видит NV nForce4 SATA 27.06.2007 23:45Viruson Прочитал, аналогичная проблема, но у меня так и не получается запустить...
Kirillnow, у тебя запустилась?
Re: ASP 11.2 не видит NV nForce4 SATA 28.06.2007 02:58Kirillnow Нет, как освобожусь поставлю на IDE'шный хард, обновлю ядро а потом буду думать как перенести это все на SATA.
Re: ASP 11.2 не видит NV nForce4 SATA 12.07.2007 23:43Kirillnow Потавил АСП на IDEшный хард, обновил ядро до 2.6.22.1 (с кернел.орг).
Загрузился нормально, но сата-хард и встроенная сетевуха не видны.
modprobe -l показывает что модуль загружен. В выводе dmesg SATA не проскакивает.

К сожалению у меня больше идей нет. Может кто-нибудь подскажет в чем может быть дело?
RSS-материал