Ошибка при установке обновлений

Автор: Sergei Дата: 23.05.2009 13:12 Только что попытылся установить последние обновления для ASPLinux-14. На шаге "Testing Changes" получил следующую ошибку:

Error Type: <type 'exceptions.TypeError'>
Error Value: sequence item 0: expected string, tuple found
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2280, in <module>
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2277, in main
backend.dispatcher(sys.argv[1:])
File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 600, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 578, in dispatch_command
self.update_system()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1105, in update_system
self._runYumTransaction(allow_skip_broken=True)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1534, in _runYumTransaction
message = _format_msgs(ye.value)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 170, in _format_msgs
text = "
".join(msgs)
Re: Ошибка при установке обновлений 23.05.2009 13:30BigAndy Пытались это сделать yum'ом?
Re: Ошибка при установке обновлений 24.05.2009 07:19Sergei Я пытался установить обновления с помощью вот этой программы:

gpk-update-viewer

До сих пор она замечательно работала.
Re: Ошибка при установке обновлений 24.05.2009 10:40Sergei Я только что заметил кое что интересное: окно программы gpk-update-viewer выдаёт "86 updates", а если навести курсор мышки на иконку в System Tray то выдаётся "There are 85 updates pending".
Re: Ошибка при установке обновлений 24.05.2009 11:10BigAndy Sergei Пишет:
-------------------------------------------------------
> Я пытался установить обновления с помощью вот этой
> программы:
> > gpk-update-viewer
> > До сих пор она замечательно работала.
yum check-update - и будет вам счастье
Re: Ошибка при установке обновлений 25.05.2009 02:48Sergei Спасибо! И Вам я счастья желаю!!! Улыбка

Попробовал запустить:

yum check-update

и эта команда только выдала мне список доступных обновлений, но ничего не обновила.
Re: Ошибка при установке обновлений 25.05.2009 10:01Sergei Может Вы знаете какую команду/программу используют разработчики ASPLinux, когда они тестируют обновления? Использовать ту же команду был бы оптимальный вариант! Заранее Большое Спасибо!!!!
Re: Ошибка при установке обновлений 25.05.2009 10:26JustUser Sergei Пишет:
-------------------------------------------------------
> Может Вы знаете какую команду/программу используют
> разработчики ASPLinux, когда они тестируют
> обновления? Использовать ту же команду был бы
> оптимальный вариант! Заранее Большое Спасибо!!!!

man yum

(вот до чего докатился - уже в man'ы отсылать начал:-D)

если хотите обновить всё, то

yum update
Re: Ошибка при установке обновлений 25.05.2009 11:41lkanter Sergei Пишет:
-------------------------------------------------------
> Может Вы знаете какую команду/программу используют
> разработчики ASPLinux, когда они тестируют
> обновления? Использовать ту же команду был бы
> оптимальный вариант! Заранее Большое Спасибо!!!!

yum update

но в графике тоже тестируем, вроде проблем не было.
Re: Ошибка при установке обновлений 25.05.2009 21:44BigAndy Sergei Пишет:

> и эта команда только выдала мне список доступных
> обновлений, но ничего не обновила.
А должн была?
man yum на предмет update
RSS-материал