Как обновить glibc или glibc-2.11.1 против ASPLinux 11.2(glibc-2.3.6)

Автор: doctor.ua Дата: 10.02.2010 20:58 Здравствуйте!
Товарищи разработчики на Вас последняя надежда….
Возникла необходимость обновить “glibc” ибо без версии выше 2.4 сейчас никуда.
скомпилил новые необходимые пакеты (gcc 4.4.3, binutils… и что там ему не хватало) для обновления “glibc” , но как всегда на мейке мы приехали….
In file included from nscd.c:46:
selinux.h:26:29: error: sys/capability.h: Нет такого файла или каталога
In file included from nscd.c:46:
selinux.h:49: ошибка: expected '=', ',', ';', 'asm' or '__attribute__' before 'preserve_capabilities'
selinux.h:51: ошибка: expected ')' before 'new_caps'
make[2]: *** [/usr/src/gnu/glibc-build/nscd/nscd.o] Ошибка 1
make[2]: Leaving directory `/usr/src/gnu/glibc-2.11.1/nscd'
make[1]: *** [nscd/others] Ошибка 2
make[1]: Leaving directory `/usr/src/gnu/glibc-2.11.1'
make: *** [all] Ошибка 2
конфигурил так:
../glibc-2.11.1/configure --prefix=/usr --with-headers=/usr/headers/include --enable-kernel=2.6.32.8
В каталоге /usr/headers/include находятся хеадеры которые туда положились по завершении компиляции ядра….
make headers_install ARCH=х86 INSTALL_HDR_PATH=/usr/headers

ума не приложу в чем проблема, 2 недели воюю с glibc все никак (((((


если для того чтобы было Вам легче разобраться с проблемой ,нужно знать версии установленных пакетов я их предоставлю только скажите каких именно.

p.s. переставить сразу на 14й нет возможности, за 2.5 года столько всего отстроено и работает , не хочется заново настраивать.

Спасибо за помощь!
Re: Как обновить glibc или glibc-2.11.1 против ASPLinux 11.2(glibc-2.3.6) 10.02.2010 21:52peter_ir sys/capability.h - из пакета libcap-devel,
но в несколько раз быстрее было бы установить новую систему,
чем две недели бороться с glibc, и настраивать пришлось бы не с нуля,
а только что-нибудь поправить.
Re: Как обновить glibc или glibc-2.11.1 против ASPLinux 11.2(glibc-2.3.6) 10.02.2010 22:56doctor.ua ))), я же говорю что переставить не могу. ....сайт. mysql , raid настроен, + ftp и пользователей не перенно, дисковые квоты ... и так далее....+ те пакеты которые обновил из исходников давно устарели в 14м asp (((.
Re: Как обновить glibc или glibc-2.11.1 против ASPLinux 11.2(glibc-2.3.6) 19.02.2010 10:28Eraserus скачайте src.rpm пакеты для вашей версии ОС, потом поправьте spec-файл, замените исходники глибса новыми, и соберите рпм - пакет уже с новыми исходниками... дальнейшая установка рпм-пакета думаю сложностей не вызовет...
RSS-материал