Странные проблемы ...

Автор: wmd Дата: 24.02.2007 05:45 Приветствую!
Уважаемые, вот возникла проблема, не понятно в чём дело ...
На машинке* стоит ASP 11.2 (ядро 2.6.18-1.2257.0.112asp).
Стоит sata-шный хард. После загрузки hdparm показывает режим udma6.
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5*udma6
Однако, после непродолжительного времение в логах происходит следующее:

kernel: ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
kernel: ata1.01: tag 0 cmd 0xb0 Emask 0x4 stat 0x40 err 0x0 (timeout)
kernel: ata1: soft resetting port
kernel: ata1.00: configured for UDMA/133
kernel: ata1.01: configured for UDMA/133
kernel: ata1: EH complete
kernel: ata1.01: limiting speed to UDMA/100
ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
kernel: ata1.01: tag 0 cmd 0xb0 Emask 0x4 stat 0x40 err 0x0 (timeout)
kernel: ata1: soft resetting port
kernel: ata1.00: configured for UDMA/100
kernel: ata1.01: configured for UDMA/100
kernel: ata1: EH complete

т.е. он начинает методично скидывать UDMA режимы ... и в плоть до MDMA ...
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5 udma6
в чём может быть проблема?

*машинка: Xeon 2x3000/800, SE7520JR2 (ICH5), RAM 2Gb, Seagate 2x750 ST3750640AS
Re: Странные проблемы ... 25.02.2007 03:53Bircoph > в чём может быть проблема?

Обычно система начинает понижать уровни dma, если возникают
ошибки dma, что говорит о сбое железа. smart что-нибудь
подозрительное говорит?

У меня с одним PATA-винтом всё вплоть до PIO падало, через
день винт сдох.
Re: Странные проблемы ... 24.04.2007 23:42vinni-pooh Не знаю, не думаю что есть прямая связь. Хотя в приведенных примерах может и не без этого.
У меня например вот такая ситуация.
Когда загружается система, и проходит этап проверки конфигурации оборудования при помощи kudzu, на этот момент винт останавливается с характерным щелчком, а в логах я вижу вот такое:
dmesg:
pr 23 23:58:17 den kernel: [ 49.444096] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Apr 23 23:58:17 den kernel: [ 49.455442] ata1.00: configured for UDMA/100
Apr 23 23:58:17 den kernel: [ 49.460982] ata1: EH pending after completion, repeating EH (cnt=4)
Apr 23 23:58:17 den kernel: [ 49.466658] ata1: EH complete
Apr 23 23:58:17 den kernel: [ 66.828176] ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x90000 action 0x2 frozen
Apr 23 23:58:17 den kernel: [ 66.828185] ata1.00: cmd c8/00:08:d5:24:3a/00:00:00:00:00/e2 tag 0 cdb 0x0 data 4096 in
Apr 23 23:58:17 den kernel: [ 66.828198] ata1: hard resetting port
Apr 23 23:58:17 den kernel: [ 67.549682] ata1: COMRESET failed (device not ready)
Apr 23 23:58:17 den kernel: [ 67.549686] ata1: hardreset failed, retrying in 5 secs
Apr 23 23:58:17 den kernel: [ 72.539519] ata1: hard resetting port
Apr 23 23:58:17 den kernel: [ 73.260372] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Apr 23 23:58:17 den kernel: [ 73.266725] ata1.00: configured for UDMA/100
Apr 23 23:58:17 den kernel: [ 73.266733] ata1: EH pending after completion, repeating EH (cnt=4)
Apr 23 23:58:17 den kernel: [ 73.266746] ata1: EH complete
Apr 24 21:27:41 den kernel: [ 30.910374] ata1: SATA max UDMA/100 cmd 0xE081E080 ctl 0xE081E08A bmdma 0xE081E000 irq 19
Apr 24 21:27:41 den kernel: [ 31.386598] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Apr 24 21:27:41 den kernel: [ 31.394949] ata1.00: ATA-7, max UDMA/133, 488397168 sectors: LBA48 NCQ (depth 0/32)
Apr 24 21:27:41 den kernel: [ 31.400012] ata1.00: ata1: dev 0 multi count 16
Apr 24 21:27:41 den kernel: [ 31.407926] ata1.00: configured for UDMA/100
Apr 24 21:27:42 den kernel: [ 53.433349] ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x90000 action 0x2 frozen
Apr 24 21:27:42 den kernel: [ 53.433358] ata1.00: cmd c8/00:08:5d:fb:13/00:00:00:00:00/e2 tag 0 cdb 0x0 data 4096 in
Apr 24 21:27:42 den kernel: [ 53.433370] ata1: hard resetting port
Apr 24 21:27:42 den kernel: [ 54.154507] ata1: COMRESET failed (device not ready)
Apr 24 21:27:42 den kernel: [ 54.154512] ata1: hardreset failed, retrying in 5 secs
Apr 24 21:27:42 den kernel: [ 59.143346] ata1: hard resetting port

та же самая ситуация с vmware, в момент запуска виртуальной машины происходит в точности такой же бок.
Все бы ничего, но это уже задолбало, особенно после того как ко всему прочему уже приходилось пару раз ремонтировать fs, я уже и не рад тому, что в свое время ide-винт поменял на sata.
Винт новый, проверяя его утилитами ничего плохого на нем не нахожу.
Мать у меня с контроллером SATA Silicon Image, Inc. SiI 3112, вроде с драйверами на него в ядре все уже давно ок. Винт Seagate ST3250820AS.
Вот такая вот грустная история.
Если кто че знает, как бороться - отпишитесь ...
RSS-материал