KDevelop & ASP9

Автор: wizard580 Дата: 25.06.2003 03:57 Я тут наслушавшись советов (ветка C++ Templates & ASP9), решил сгенерить новый проект и перести туда свой старый проект (gcc 2.96 -> gcc 3.x.x).

Запускаю KDevelop (естественно 2.1.5), выбираю Qt MDI, пара глупых (читай "мне не нужных";-) вопросов. Нажимаю на создать.
На создании configure падает с ошибкой. Проект создан наполовину и соотв. ни чего не работает.

Кто знает, в чем дело?
Re: KDevelop & ASP9 26.06.2003 06:30wizard580 [www.kdevelop.org]

там есть решение этой проблемы. Это баг RH9.
А АСП'шники неудосужились проверить/оттестить то, что они продают. Как в прочем и RedHat. Но опять-же, это не отмазка. Деньги то мы кому платим?

Короче, я запостил баг. Ждем обновления.
Re: KDevelop & ASP9 27.06.2003 14:37Raynor у меня не компилится KDevelop
configure не находит X includes
в каком они пакете, не могу найти?
kde-devel стоит
qt стоит
Re: KDevelop & ASP9 27.06.2003 14:45zakon XFree86-devel
Re: KDevelop & ASP9 27.06.2003 15:29Raynor огромное спасибо!

однако дальше:
configure:21734: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!

rpm -qa | grep qt
licq-qt-1.2.6-20030425.0asp
qt-3.1.1-6asp
qtcups-2.0-15
qt-devel-3.1.1-6asp
qt2-2.3.1-13

Грустный
Re: KDevelop & ASP9 27.06.2003 15:54Raynor покопался в скрипте, все понял
./configure --with-qt-includes=/usr/lib/qt-3.1/include --with-qt-libraries=/usr/lib/qt-3.1/lib
помогло
Re: KDevelop & ASP9 27.06.2003 16:03Raynor далее Грустный

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

rpm -qa | grep kde
kdebase-3.1.1-1.1asp
kdeadmin-3.1.1-1asp
kdegraphics-3.1.1-1asp
kdeutils-3.1.1-1asp
switchdesk-kde-3.9.8-15.2asp
kdebase-devel-3.1.1-1.1asp
lockdev-1.0.0-23
kdelibs-3.1.1-1.1asp
kdegames-3.1.1-1asp
kdeaddons-3.1.1-1asp
kdeartwork-3.1.1-1asp
kdeedu-3.1.1-1asp
kdenetwork-3.1.1-1asp
kdetoys-3.1.1-1asp
licq-kde-1.2.6-20030425.0asp
lockdev-devel-1.0.0-23
kde2-compat-2.2.2-9
kdegraphics-devel-3.1.1-1asp
kde-i18n-Russian-3.1.1-1asp
kdemultimedia-3.1.1-1asp
kdebindings-3.1.1-1asp
kdepim-3.1.1-1asp
wordtrans-kde-1.1pre12-7

для инклудников KDE в конфиге никаких префиксов нет
добавил --with-extra-includes=/usr/include/kde

чего не хватает?
Re: KDevelop & ASP9 27.06.2003 16:06zakon Видать
kdelibs-devel
Re: KDevelop & ASP9 27.06.2003 16:18Raynor Улыбка
THANKS
Re: KDevelop & ASP9 27.06.2003 16:50Raynor make
компилит компилит минут 10, потом ругается
/usr/bin/ld: cannot find -lart_lgpl_2
collect2: ld returned 1 exit status

не подскажете, что еще за -lart_lgpl_2
man ld здоровенный, нахрапом не возьмешь
Re: KDevelop & ASP9 27.06.2003 16:55zakon rpm -qa | grep libart?
Re: KDevelop & ASP9 27.06.2003 16:56Raynor libart_lgpl-2.3.11-2
намек понял, ставлю devel Улыбка

далее:
/usr/bin/ld: cannot find -lpng
collect2: ld returned 1 exit status

попробую найти
зря я devel пакеты не выбрал при установке... учту
Re: KDevelop & ASP9 27.06.2003 17:05Raynor libart_lgpl2 нет такого в поставке
поставил libart_lgpl-devel-2.3.11-2.i386.rpm
выше
прошел дальше
Re: KDevelop & ASP9 27.06.2003 17:06zakon Да, это мой глюк, извини!
Re: KDevelop & ASP9 27.06.2003 17:08Raynor а rpm то тут при чем? Улыбка
компилю типа Улыбка
Re: KDevelop & ASP9 27.06.2003 17:10zakon Когда компилю, у меня устанавливается всё: проги, библиотеки и заголовки!
А в rpm всё разбросано!
Re: KDevelop & ASP9 27.06.2003 17:18Raynor разбросано - да
не каждый день KDevelop собирать Улыбка
в общем, прошел еще дальше make
make install
ошибок не выдают
но и непонятно правильно все встало или нет
kdevelop - command not found
ищу его
Re: KDevelop & ASP9 27.06.2003 17:19Raynor /usr/local/kde/bin/kdevelop
хе-хе
ну мать его Улыбка
день возился
смотрю то ли что мне надо Улыбка
Re: KDevelop & ASP9 27.06.2003 17:20Raynor спасибо огромное за помощь, zakon!
как в винде застрянешь - пиши Улыбка))
Re: KDevelop & ASP9 27.06.2003 17:20zakon make install стучит, куда он кидает файлы!
Re: KDevelop & ASP9 27.06.2003 17:30Raynor на первый взгляд - чиста сишный редактор, в принципе, он так и задуман.
блин, когда ж я найду номальный аналог UltraEdit под линукса Грустный
Re: KDevelop & ASP9 27.06.2003 17:38zakon Хе-хе, не знаю что такое UltraEdit, vi правит!
Re: KDevelop & ASP9 27.06.2003 18:15Raynor другого от тебя услышать не ожидал
сам я в ви(м) не врубаюсь, хотя пытался несколько раз вникнуть в его крутость. мимо.
мне нужно постоянно править десятки файлов, прыгать по каталогам и т.д.
и делать это быстро, потому что я думаю быстро Улыбка
даже gvim выглядит убого, что там о vim/vi
я не говорю о мощи, я говорю о скорости и удобстве
KDevelop - слишком простая вещь для чего-то кроме си
Java-based (JEdit, Zend) - более менее, но все равно - зеленоваты, хотя ход мыслей там верный
про что-то более простое нет смысла говорить
на форуме UE давно идет флейм о переносе его на никсы
но мне сейчас проще его под wine портировать, ибо идет
в линуксовых редакторах я разочаровался Улыбка

p.s. Kate конечно, милая весчь, но - малофункционален.
p.p.s. Komodo, VSlick - более менее мощные монстеры, но дорогие. А ультру я еще куплю Улыбка
RSS-материал