Проблема с установкой новых приложений

Автор: tradakad Дата: 14.09.2004 09:52 Приветствую всех! у меня ASP Linux 9
имеется такая проблема. Когда пытаюсь через Иксовую оболочку добавить или удалить программу происходит следующее - если к примеру нужный пакет находится на ASP Cd 1 , программа просит этот диск, я вставляю его - все ставиться, но только доходит дело до ASP Cd 2 - программа этот диск не видит. говорит "вставь" - вставляю , а она выбрасывает его и все. то же самое и с третьим диском Грустный пробую вручную копировать пакеты на винт и ставить их - все работате. диски в отличном состоянии, не поцарапанные и т.п. кроме того систему я ставил именно с них - определялись все корректно (когда инсталлятор спрашивает 2-й и 3-й диски - проблем не было никаких), и более того , к примеру если я ставлю Koffice при первоначальной установке - он ставиться, если пытаюсь добавить его "установкой удалением" - вылазит этот глюк. копирую пакет на диск - все ок. Грустный Подскажите плиз, что это может быть?
Заранее спасибо!
Re: Проблема с установкой новых приложений 14.09.2004 10:03bigbiker Redhat-install-packages никогда по-нормальному не работала, поэтому рекомендую работать с RPM напрямую или пользоваться другими менеджерами пакетов(Yum, KPackage и пр.)
Вот решение проблемы с диском: [www.asplinux.ru]
Re: Проблема с установкой новых приложений 14.09.2004 12:17tradakad Спасибо большое! а что это за Yum и т.п.?
Re: Проблема с установкой новых приложений 14.09.2004 20:02Violet Yum (http://community.asplinux.ru/yum/wakka.php?wakka=-OProgramme)- это утилита установки-обновления программ. Предназначена для установки rpm-пакетов с нашего ftp-сервера, зеркал сайта, локального сервера и т.д. Утилита учитывает зависимости, проверяет уже установленные пакеты. Есть русский man.
Re: Проблема с установкой новых приложений 15.09.2004 09:02bigbiker > Спасибо большое! а что это за Yum и т.п.?
Не за что, всегда рад помочь.
Yum, кстати, можно настроить на локальный репозитарий (поищите поиском по форуму, тут много про это написано), а KPackage - это RPM-менеджер для KDE (должен быть в пакете kdeadmin, но в некоторых сборках его нет).
Удачи!
Re: Проблема с установкой новых приложений 15.09.2004 10:00Vladimir Dyakov Ставьте Мандряку, там есть гениальные утилиты urpmi, urpmq, urpmf, которые сами ищут похожий по названию пакет, просят вставить нужный инсталляционный диск и в конце-концов сами инсталлируют программу. Ещё есть программа rpmdrake, которая делает всё то же самое, только графически. Не жизнь - сказка ;-)
Re: Проблема с установкой новых приложений 15.09.2004 12:00tradakad >Redhat-install-packages никогда по-нормальному не работала, поэтому рекомендую >работать с RPM напрямую или пользоваться другими менеджерами пакетов(Yum, >KPackage и пр.)
>Вот решение проблемы с диском: [www.asplinux.ru] /support /? /aspl9.0

Добрый день! Скачал указанный пакет, удалил версию 1, поставил новую (2) и у меня вылезла следующая ошибка. при попытке запуска "Установка удаление" , появляется как обычно окно "Проверка состояния системы" , а потом сразу выскакивает окно ошибки "Установочное дерево не найдено" "Путь /mnt/cdrom не является действительным деревом установки"
Пробовал удалил 2 версию, поставил 1, - и она перестала работать с той же ошибкой. пробовал обновлял 1 на 2. удалял и т.п. - результат тот же. Грустный что могло произойти?
Заранее спасибо!
Re: Проблема с установкой новых приложений 15.09.2004 14:46bigbiker 2 Vladimir Dyakov:

> Ставьте Мандряку...

К сожалению, есть linuxoid'ы, несовместимые с Mandrake ;-))

2 tradakad:

Redhat-install-packages вряд ли когда-нибудь будет нормально работать; советую Вам не мучаться, а воспользоваться каким-либо альтернативным решением.
Re: Проблема с установкой новых приложений 15.09.2004 15:22tradakad bigbiker писал(а):

> Redhat-install-packages вряд ли когда-нибудь будет нормально
> работать; советую Вам не мучаться, а воспользоваться каким-либо
> альтернативным решением.

Попробую наверное Yum )
Спасибо!
Re: Проблема с установкой новых приложений 16.09.2004 10:03tradakad Violet писал(а):

> Yum
> (http://community.asplinux.ru/yum/wakka.php?wakka=-OProgramme)-
> это утилита установки-обновления программ. Предназначена для
> установки rpm-пакетов с нашего ftp-сервера, зеркал сайта,
> локального сервера и т.д. Утилита учитывает зависимости,
> проверяет уже установленные пакеты. Есть русский man.
>

Здравствуйте! пробовал вчера поставить yum-1.2.13 вместе с yum repos - вскакивает ошибка что нужен еще какой-то PyXML
Подскажите плиз что это такое?
Спасибо!
Re: Проблема с установкой новых приложений 16.09.2004 11:36lg >пробовал вчера поставить yum-1.2.13 вместе с yum repos
не сходите с ума, ставьте yum-2.1.0cvs
>какой-то PyXML
[ftp.asplinux.ru]
Re: Проблема с установкой новых приложений 16.09.2004 12:09tradakad lg писал(а):

> не сходите с ума, ставьте yum-2.1.0cvs
а где его взять? скажите пожалуйста? и нужен к нему ли тот же repos?
Re: Проблема с установкой новых приложений 16.09.2004 12:48lg >а где его взять?
на ftp.asplinux.ru (для 9: [ftp.asplinux.ru]) или в дистрибутиве (для 9.2)
Что ему нужно не помню, у меня он ничего не просил Улыбка
Re: Проблема с установкой новых приложений 16.09.2004 12:56tradakad lg писал(а):

> >а где его взять?
> на ftp.asplinux.ru (для 9:
> [ftp.asplinux.ru])
> или в дистрибутиве (для 9.2)
> Что ему нужно не помню, у меня он ничего не просил Улыбка
Ну у Вас же 9.2 а у меня 9.0 )
попробую его )
RSS-материал