Есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер

Автор: userl Дата: 09.12.2009 16:43 вопрос какой браузер на них можно поставить? какая версия браузера самая современная на них будет работать? есть ли вообще привязка версии браузера к версии опер системы или только к конфиге компа ? Вообщем какой браузер можно поставить на эти операционки самые современные версии?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 09.12.2009 16:56msv2 И что вам приспичило на колесницы ставить ракетную установку?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 09.12.2009 17:00userl там встроенный браузер старый и некоторые страницы плохо отоброжает
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 09.12.2009 17:58BigAndy msv2 Пишет:
-------------------------------------------------------
> И что вам приспичило на колесницы ставить ракетную
> установку?


Некрофилия....
А вообще elinks/w3m рулит...
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 09.12.2009 19:34oldjoe >есть ли вообще привязка версии браузера к версии опер системы или только к конфиге компа ?
*nix'ы в общем и Линукс в частности это идея динамически подключаемых библиотек.
И эти библиотеки общие для нескольких пакетов.
В общем и целом: попытка установить браузер от следующей версии ОС тянет за собой кучу зависимых пакетов с массой конфликтов старых и новых версий библиотек.
Попробуй в /etc/yum.repos.d создать новый файл с описанием репозитария от современного дистрибутива, подключи его, попробуй с него обновиться и посмотри, что тебе скажет yum.
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 09.12.2009 19:36msv2 А yum скажет: "Тебе п****ц, парень!!!
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 09.12.2009 20:01userl в версии 11 как на www работает браузер?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 01:04userl так как он работает на http ://www? asp 11
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 08:08msv2 Я все никак не могу врубиться в суть и (или) причину таких вопросов. Я бы еще понял, если бы чел свою ось писал, а тут....
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 11:27userl [www.mozilla.com] такие вот системные требования для файрфокс 3, только как ставить программу я не знаю. подскажите??
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 11:37userl только пакеты надо обновлять
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 13:15BigAndy userl Пишет:
-------------------------------------------------------
> [www.mozilla.com]
> ements-v3.html такие вот системные требования для
> файрфокс 3,
ну так сровните со свими установленными библиотеками.
>только как ставить программу я не знаю. подскажите??
пожскажем, если будутт вопросы.
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 13:24userl сравнил, почти все пакеты надо обновлять. только ядро не надо
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 13:31userl firefox-2.0.tar.gz вот такой браузер как поставить?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 13:45userl [root@localhost root]# sudo tar -C /opt -xjf firefox-1.5.0.12.tar.gz
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error exit delayed from previous errors
[root@localhost root]# sudo tar -c /opt -xjf firefox-1.5.0.12.tar.gz
tar: You may not specify more than one `-Acdtrux' option
Try `tar --help' for more information.
[root@localhost root]# sudo tar -C /opt -xjf firefox-1.5.tar.gz
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error exit delayed from previous errors
[root@localhost root]#
то, что я делаю в терминале, команда с сайта файрфокса в разделе как установить
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 13:51BigAndy Есть подозрение, что bzip иgzip заархивированные файлы есть суть вещи разные. gzip у вас установлен?

Вообще возьмите MC и разархивируйте с помощью оного, если не хочется хардкора
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 14:23userl [root@localhost root]# rpm -ihv opera-9.01-20060728.2-shared-qt.ppc-en.rpm
ошибка: неудовлетворенные зависимости:
ld.so.1 нужен для opera-9.01-20060728.2
[root@localhost root]#вот так оперу ставит где мне такой пакет взять?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 14:24userl [root@localhost root]# rpm -ihv opera-9.01-20060728.2-shared-qt.ppc-en.rpm
ошибка: неудовлетворенные зависимости:
ld.so.1 нужен для opera-9.01-20060728.2
[root@localhost root]#
вот так оперу ставит , где такой пакет взять и как поставить
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 14:33userl [root@localhost root]# yum install ld.so.1
Gathering package information from servers
Getting headers from: ASPLinux 7.3 Master Site
Getting headers from: ASPLinux 7.3 Updates
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Cannot find a package matching ld.so.1
You have new mail in /var/spool/mail/root
[root@localhost root]# rpm -ihv opera-9.01-20060728.2-shared-qt.ppc-en.rpm
ошибка: неудовлетворенные зависимости:
ld.so.1 нужен для opera-9.01-20060728.2
[root@localhost root]#
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 14:49BigAndy Изучаем для начала yum, а в частности про опцию deplist.
Если не находим, собираем ручками.

Но есть предположение, что в не-lts дистрибутиве для установки более нового ПО вам придется пересобрать его вручную
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 10.12.2009 23:17kosmonavt > opera-9.01-20060728.2-shared-qt.ppc-en.rpm

Это пакет для маков на ppc! Вам нужен пакет для i386. Здесь найдете залежи древних опер: [arc.opera.com]
Качайте статическую сборку, чтобы не морочь себе голову зависимостями.
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 11.12.2009 02:07userl :-)что значит статическая сборка ?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 12.12.2009 11:29userl что такое статическая сборка?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 12.12.2009 11:30userl чем статическая сборка от других отличается?
Re: есть 2 а асп: 7.3 и 9 надо на них поставить современный браузер 12.12.2009 15:13kosmonavt Это значит, что библиотеки линкуются в программу статически. Удобно для распространения софта, для которого недоступны исходники. В минусе: при обнаружении ошибки в библиотеке нужно пересобрать всю программу (все баги ношу с собой). Например, в начале года, когда AOL гнобила альтернативу (кстати, допрыгалась Показывает язык ), пользователям квипа прихошлось качать весь квип, в то время как пользователи миранды заменили у себя только один модуль.

В данном случае, опера зависит от конкретной версии Qt и других библиотек, т.е. вам нужно согласовать версию оперы с версиями этих библиотек. Это если вы будете ставить динамическую сборку оперы. Если версии не совпадут, то придется собрать на вашей машине нужные версии библиотек. Эта задача для новичка, а иногда не только для новичка, достаточно нетривиальна.
RSS-материал