Yum не хочет обновляться ищет какието библиотеки

Автор: borgez`s Дата: 22.03.2007 08:29 Error: Missing Dependency: libdbus-1.so.2 is needed by package avahi
Error: Missing Dependency: libpoppler-qt.so.1 is needed by package kdegraphics
Error: Missing Dependency: libgstreamer-0.8.so.1 is needed by package libvisual-plugins
Error: Missing Dependency: libdbus-1.so.2 is needed by package totem-mozplugin
Error: Missing Dependency: libdbus-1.so.2 is needed by package krb5-auth-dialog
Error: Missing Dependency: libgsf-1.so.113 is needed by package libwpd
Error: Missing Dependency: gstreamer08-plugins = 0.8.12-3.112asp is needed by package gstreamer08-plugins-devel
Error: Missing Dependency: libvte.so.4 is needed by package grip
Error: Missing Dependency: libdbus-1.so.2 is needed by package tapioca-xmpp
Error: Missing Dependency: libdbus-1.so.2 is needed by package bind-sdb
Error: Missing Dependency: libdbus-1.so.2 is needed by package cups
Error: Missing Dependency: libgsf-gnome-1.so.113 is needed by package goffice
Error: Missing Dependency: libvte.so.4 is needed by package anjuta
Error: Missing Dependency: libedata-cal-1.2.so.5 is needed by package libopensync-plugin-evolution2
Error: Missing Dependency: libdbus-1.so.2 is needed by package bind
Error: Missing Dependency: libavcodec.so is needed by package k3b
Error: Missing Dependency: libgsf-1.so.113 is needed by package wv2
Error: Missing Dependency: libecal-1.2.so.6 is needed by package libopensync-plugin-evolution2
Error: Missing Dependency: libgsf-1.so.113 is needed by package koffice-filters
Error: Missing Dependency: libgsf-1.so.113 is needed by package libwpd-tools
Error: Missing Dependency: libdbus-1.so.2 is needed by package kdebase
Error: Missing Dependency: libdbus-1.so.2 is needed by package tapioca
Error: Missing Dependency: libdbus-1.so.2 is needed by package xchat
Error: Missing Dependency: libdbus-1.so.2 is needed by package gphoto2
Error: Missing Dependency: libavformat.so is needed by package k3b
Error: Missing Dependency: libpoppler-qt.so.1 is needed by package koffice-kritaError: Missing Dependency: libebook-1.2.so.5 is needed by package libopensync-plugin-evolution2
Error: Missing Dependency: gstreamer08 = 0.8.12-4.112asp is needed by package gstreamer08-devel
Error: Missing Dependency: libgsf-1.so.113 is needed by package orange
Error: Missing Dependency: libgsf-1.so.113 is needed by package goffice
Error: Missing Dependency: libdbus-1.so.2 is needed by package tapiocaui

использую yum update
Re: yum не хочет обновляться ищет какието библиотеки 22.03.2007 19:03malamba В теории он должен сам искать зависимости...
Я вчера обновлял kde
он сразу сказал, что зависит от того-то и того-то, нужно ли их качать.
Сказал да, сегодня утром смотрю, уже KDE 3.4
Re: yum не хочет обновляться ищет какието библиотеки 22.03.2007 20:00ywg Просьба к опытным товарищам - потратьте чуточку времени - разобъясните как решать подобные проблемы. Мой случай:
--> Running transaction check
--> Processing Dependency: ati-fglrx >= 8.21.7.1-0.lvn.1 for package: kernel-module-fglrx-2.6.14-1.1653.1asp
--> Processing Dependency: ati-fglrx = 8.26.18-1.110asp for package: ati-fglrx-devel
--> Processing Dependency: ati-fglrx >= 8.21.7.1-0.lvn.1 for package: kernel-module-fglrx-2.6.14-1.1653.1aspsmp
--> Finished Dependency Resolution
Error: Missing Dependency: ati-fglrx = 8.26.18-1.110asp is needed by package ati-fglrx-devel
Error: Missing Dependency: ati-fglrx >= 8.21.7.1-0.lvn.1 is needed by package kernel-module-fglrx-2.6.14-1.1653.1asp
Error: Missing Dependency: ati-fglrx >= 8.21.7.1-0.lvn.1 is needed by package kernel-module-fglrx-2.6.14-1.1653.1aspsmp

То, что мне рекомендовали сделать год назад - не работает:-(
Re: yum не хочет обновляться ищет какието библиотеки 22.03.2007 20:27lg Скорее всего ядро и модули не обновляются, а к старому дополнительно ставится новое (точно не знаю, но эти настройки вполне разумны). Yum видит новый пакет ati-чтототам, пытается обновить старый на новый и обламывается, т.к. они предназначены для разных ядер.
Варианты решения:
1) попробовать сделать yum install ati-fglrx-нужная_вам_версия
2) удалить kernel-module-fglrx c зависимостями, потом обновиться и поставить последнюю версию ati-* с помощью yum
3) установить с помощью rpm (самый муторный, но 100% рабочий)

>То, что мне рекомендовали сделать год назад - не работает:-(
Это вежливый намек, на то, что отвечающие должны воспользоваться поиском? Улыбка))
RSS-материал