После обновления ядра (на 2.6.10) перестала появляться графическая загрузка...

Автор: B.X Дата: 20.01.2005 09:26 после обновления ядра, перестала включаться графическая загрузка (это такой типа скриншот с компьютером посередине и с надписью ASPLinux в правом нижнем углу на сером фоне...

как я понимаю, необходимо передать ядру какие-то параметры загрузки... где это сделать и как? может кто-то знает? Повторю, речь идёт не о gdm, а о самом процессе загрузки ядра, устройств и тд...

А yum новый мне понравился очень сильно... быстрый стал, красивый, в консоли с ним работать просто за счастье... разобрался с ним за пять минут... Так всё просто и понятно, сделал себе локальные репозитарии, просто не нарадуюсь... Спасибо разработчикам, из-за yum'a я полюбил консоль...
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 09:31Mycopka Какой загрузчик стоит?
Например если ASPLoader, то нужно просто в строчке ядра дописать команду **rhgb**.
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 11:41B.X Да, конечно, загрузчик стоит ASPLoader (разве может быть иначе, да и зачем?). Спасибо за информацию... А как обновить загрузчик? То есть, я знаю, что это делается командой aspldr, но по моему это делается один раз? Во всяком случае, с lilo.conf мне удавалось обновить только один раз, второй раз bash пишет, что "не знает такой команды"...
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 12:15DrCasper Что B.X писал(а):

>А как обновить
> загрузчик? То есть, я знаю, что это делается командой aspldr,
> но по моему это делается один раз? Во всяком случае, с
> lilo.conf мне удавалось обновить только один раз, второй раз
> bash пишет, что "не знает такой команды"...
>

ерунда какая-то..! что в "lilo", что в "aspldr" технология одна: изменил конфиг -- выполни lilo/aspldr (возможно, иногда нужно указать полный путь, например, /sbin/aspldr или даже путь к файлу загрузчика+путь к конфигу, типа /sbin/lilo -c /etc/lilo.conf, если, скажем, конфиг нужный лежит не в там, где должен быть по-умолчанию).

а насчет "первый раз работает, второй не работает" -- ерунда полная... ;-)

PS: думаю, даже не стоит упоминать, что выполнение инсталляции/переинсталляции загрузчика возможно только с привилегиями суперпользователя ;-)
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 12:46Tigro Только Grub не нужно заново записывать в бутсектор.
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 14:54DrCasper Tigro писал(а):

> Только Grub не нужно заново записывать в бутсектор.
>

угу.. я его по этому и не упомянул Улыбка правда решил не акцентировать внимание на том, что делать НЕ НУЖНО Улыбка

PS: наверное, надо давать более развернутые ответы Улыбка исправлюсь Улыбка
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 15:15B.X Tigro писал(а):

> Только Grub не нужно заново записывать в бутсектор.

Он это делает самостоятельно?
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 16:02lkanter grub достаточно установить на mbr один раз, после этого при каждой загрузке он просто перечитывает свой конфиг. Все остальные загрузчики конфиг перечитывать не умеют и требуют переписывания mbr после изменения конфига. Кроме того, при обновлении ядра запись rhgb в конфиг груба добавляется для нового ядра. Так что лично я рекомендую использовать груб.
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 16:08B.X lkanter писал(а):

> grub достаточно установить на mbr один раз, после этого при
> каждой загрузке он просто перечитывает свой конфиг. Все
> остальные загрузчики конфиг перечитывать не умеют и требуют
> переписывания mbr после изменения конфига. Кроме того, при
> обновлении ядра запись rhgb в конфиг груба добавляется для
> нового ядра. Так что лично я рекомендую использовать груб.

А тоже самое сделать с ASPLoader нельзя? Это разве не разработка ASPLinux? Почему бы её не улучшить соответственно? Мне, например, больше нравится ASPLoader и даже несмотря на то, что в процессе установке, по умолчанию был указан GRUB (что странно, с одной стороны рядом с ASPLoader стояла в скобочках надпись "рекомендуется";-), я всё равно выбрал ASPLoader...

Или вы больше не поддерживаете ASPLoader?
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 16:18DrCasper B.X писал(а):

> Мне, например, больше нравится ASPLoader и даже несмотря на то,
> что в процессе установке, по умолчанию был указан GRUB (что
> странно, с одной стороны рядом с ASPLoader стояла в скобочках
> надпись "рекомендуется";-), я всё равно выбрал ASPLoader...

Кстати, да! Мне тоже интересно, почему из четырех инсталляций, которые я делал, один раз предлагался (была выставлена "птичка" напротив опции) GRUB по-умолчанию, а в трех других случаях, выл выбран ASPLoader, который "рекомендуется"??? Улыбка При том, что все четыре инсталляции были выполнены одинаково (и одинаковый режим FrameBuffer 1024x768 и экспертный (или как его там) режим и все прочее)...
Каков алгоритм выбора загрузчика инсталлятором? Улыбка

Надеюсь, не random? Улыбка
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 18:43B.X DrCasper писал(а):

> а насчет "первый раз работает, второй не работает" -- ерунда
> полная... ;-)

нет, не ерунда...
в первый раз работает aspldr, а во-второй только /sbin/aspldr
почему так, не знаю... пробовал уже несколько раз...
если во второй раз дать команду "просто aspldr" bash скажет,
что он такой команды не знает... но в первый раз всё же было нормально... почему во второй раз не так? то же касается и lilo.
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 20.01.2005 19:24Bircoph > если во второй раз дать команду "просто aspldr" bash скажет,
> что он такой команды не знает...

А нефиг от юзера это делать, т.к.:
1) У него прав не хватит
2) /sbin/ нет в путях юзера.
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 21.01.2005 01:03B.X Bircoph писал(а):

> > если во второй раз дать команду "просто aspldr" bash скажет,
> > что он такой команды не знает...
>
> А нефиг от юзера это делать, т.к.:
> 1) У него прав не хватит
> 2) /sbin/ нет в путях юзера.

Никто эту команду из под пользователя не даёт...
команда даётся из-под пользователя root
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 21.01.2005 01:33Bircoph > Никто эту команду из под пользователя не даёт...
> команда даётся из-под пользователя root

А вы в рута как заходите? Если через su root, то переменные
окружения, в т.ч. и пути будут юзерские; если это так, то
попробуйте su - root
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 21.01.2005 04:12B.X хорошо, спасибо за совет... но почему в первый раз команда aspldr и lilo срабатывает, а вот во второй раз надо давать команду /sbin/aspldr или /sbin/lilo - мне именно это непонятно...
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 21.01.2005 08:35stall У меня вот тоже довольно похожая проблема - после того как поставил новое ядро (было 2.6.10, поставил то-же 2.6.10 но с 1 новым моделем, причем конфиг старый брал) у меня перестал грузиться Х-сервер.. не грузиться ни автоматом, ни по startx... =( ктонибуть может подсказать в чем тут может быть проблема?
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 21.01.2005 08:39Mikki To Stall>Попробуйте стартовать ядро с параметром acpi=off (мне помогло)
Re: после обновления ядра (на 2.6.10) перестала появляться графическая загрузка... 24.01.2005 18:27stall Отключение acpi не помогает =/ ..X-ы грузяться только с драйвером nv ..
Да, я так подозреваю что проблема тут в том, что не грузиться модуль nvidia.ko (так кажеться), так вот, как можно вручную сделать так, чтобы он грузился автоматом?
RSS-материал