Winmodem под ASP Linux 9 - ping проходит только со шлюзом, сайты недоступны.

Автор: Макс1 Дата: 09.06.2003 19:23 Апгрейдился с P3 Celeron на Athlon XP, материнская плата на чипсете nForce2. Поставил новую версию Linux, ASP Linux 9. Модем - Rockwell Conexant HCF winmodem. На старом компьютере и старом ASP Linux 7.2 драйвера в свое время встали без проблем, и работал выход в Интернет через провайдера. Сейчас - поставил драйвера из *.src.rpm, перед этим пробовал из *.i386.rpm - драйвера для конкретного ядра и Athlon-а все равно не встают. Впрочем, то же самое было и на старой системе, однако все работало. Для настройки использовал утилиты hcfpciconfig и KPPP. В KPPP заменил команду ATDT на ATDP (импульсный набор, тоновый не работал) Дальше добился следующего: набирается номер, появляется надпись, что установлено соединение с провайдером, компьютер получает IP - адрес от провайдера, и можно узнать шлюз. Ping проходит только со шлюзом, при попытке сделать ping с другим IP-адресом безуспешно пытается делать ping с IP - адресом сетевой карты eth0 (она встроенная в nForce2, и MAC-адрес вводится в BIOS, однако из Linux ping проходит с другим компьютером в сети, самбу пока не ставил, в Windows сеть работает и ping по TCP IP работает). В KPPP перепробовал все возможные настройки. Может быть дело в каких-то firewall-ах, которые по умолчанию ставит ASP Linux 9. Или может быть надо включить форвардинг пакетов? Или все-таки дело в модеме? При инсталляции драйверов было следующее сообщение
depmod: **unresolved symbols in
/lib/modules/2.4.20-9.asp/misc/slmdm.o
Но вот еще заметил следующую вещь. После безуспешной попытки выйти в Интернет из-под Linux, хуже стало работать соединение с Интернетом в Windows. Иногда, но не всегда, стал появляться тот же симптом, правда, обычно, только через некоторое время после соединения. Ping только со шлюзом, и невозможность попасть на сайты.
Компьютер под Windows стал иногда виснуть в начале набора номера.
Простите за, возможно, неквалифицированный вопрос, не могла ли установка драйверов под Linux перепрошить BIOS модема?
Re: Winmodem под ASP Linux 9 - ping проходит только со шлюзом, сайты недоступны. 09.06.2003 20:01lkanter Cкорее всего default route привязян к сетевой плате и pppd поэтому его не меняет. Посмотрите, что показывает команда route или ip ro sh до и после запуска ppp. Проверьте, установлен или нет параметр DEFAULTROUTE в файле /etc/sysconfig/network. Насчет перепрошивки биоса модема - весьма сомнительно, что там вообще есть биос, который можно перепрошить.
Re: Winmodem под ASP Linux 9 - ping проходит только со шлюзом, сайты недоступны. 10.06.2003 00:03Макс1 Не уверен, что сделал правильно, но просто закомментировал gateway 192.168.1.254, который мне прописался при инсталляции, для моей карты eth0 192.168.1.1 Во всех конфигурационных файлах. Теперь вот сижу пишу из Linux-а со своего модема. Ping проходит как с сайтами, так и с соседней машиной 192.168.1.3 Вот до сих пор не пойму, нужен ли gateway для карты 192.168.x.1,
если она сама является gateway-ем, соединенным с машинами 192.168.x.2 и больше? Вот буду настраивать самбу и squid, посмотрю как все будет работать.
Или надо оставить этот gateway 192.168.1.254 . Но как сделать, чтобы он был не default? В /etc/sysconfig/network параметра DEFAULTROUTE нет. Никогда не сталкивался с такой проблемой, выходит что плохо я все-таки знаю протокол TCP/IP.
RSS-материал