Archive - 2006

Декабрь 9th

ADSL "STREAM"

Аватар пользователя Hidrag

Доброго времени суток!
Хочу выйти в инет из под линукса через стрим. Здесь на форуме нашел тему где человек просил помощь с настройками, ему помогли и все заработало. Я бы воспользовал всем что там написано, но у меня модем подключается через USB а не Ethernet. Поэтому создавая соеденение в system-config-network и указывая там DSL нужно указать сетевуху...

..и еще запускаю в меню кде "Обзор оборудования" мой модем оказался в вкладке "Системные устройства" ADSL MODEM, Производитель: неизвестный, драйвер unknow... это что линух не определил его?

ASPLinux 11
Модем: Netronix MN-01

Декабрь 8th

Perl редактор или IDE

Аватар пользователя Hidrag

Я программист JAVA, но пришлось быстро разобраться с перлом, хотел спросить если вы на нем пишете то в чем? Улыбка

Обновления GnuPG

Аватар пользователя VSL

Один из разработчиков Gentoo обнаружил в GnuPG серьезную ошибку в механизме обработки пакетов OpenPGP. Следствием этого может стать то, что удаленный нападающий, используя особым образом модифицированный OpenPGP-пакет (т.е. блок зашифрованных или подписанных данных), сможет изменить или переопределить указатель функции в GnuPG.

Решение: Для пользователей версий 1.х установить версию не ниже 1.4.6, дял пользователей версий 2.х не ниже 2.0.2

Скрипт ротации логов - подскажите

Аватар пользователя WebCode

Здравствуйте, Уважаемые форумчани.

Давненько меня тут не было Улыбка.

Вот что меня сюда привело, необходимо мне подсчитать трафик, который проходит через мою машину.

Схема такова, у меня на ПК 2 интерфейса: eth0 - городская сетка, eth1 - сетка с другим кампом. Нужно считать трафик, который проходит через eth1.

Значит в iptables я прописал:

Цитата:
-A FORWARD -o eth1 -j LOG --log-level 7 --log-prefix BANDWIDTH_OUT:
-A FORWARD -i eth1 -j LOG --log-level 7 --log-prefix BANDWIDTH_IN:
-A OUTPUT -o eth1 -j LOG --log-level 7 --log-prefix BANDWIDTH_OUT:
-A INPUT -i eth1 -j LOG --log-level 7 --log-prefix BANDWIDTH_IN:

в syslog.conf:

Цитата:
kern.=debug -/var/log/bandwidth

Теперь у меня в /var/log/bandwidth собирается статистика вида:

Цитата:
Dec 8 13:12:27 home kernel: BANDWIDTH_IN:IN=eth1 OUT=eth0 SRC=192.168.1.2 DST=10.18.1.254 LEN=48 TOS=0x00 PREC=0x00 TTL
=127 ID=37658 DF PROTO=TCP SPT=1071 DPT=80 WINDOW=65535 RES=0x00 SYN URGP=0

Вопрос: есть ли скрипт, который бы на основании такого лога выводил статистику? И где можно почитать, что именно пишется в этот лог (а то стянул пример без понимания)?

Заранее спасибо.

Radeon 9600 pro vs Suse 10.1

Аватар пользователя England

Ставлю драйвер fglrx_6_8_0-8.31.5-1.i386.rpm
стандартно rpm -Uh --force ...
//пробегают две строки с процентами и снова выпадает строка для ввода команды (fglrxconfig сам не запускается)
//пытаюсь запустить его вручную - пишет "нет такого"
В меню гнома появляется пункт Ati, но там только одна вкладка - на ней только скромное инфо про Mesa и OpenGL
Пытаюсь собрать модуль, все вроде хорошо, вылетает только одно предупреждение что не найдена какая-то библиотека ...lib... с кучей расширений.
//Модуль fglrx появляется в папке с модулями
Пытаюсь сам (уже смешно) поправить файл Xorg.conf - меняю драйвер "radeon" на "fglrx" ->
пишет:
[atiddxSetup] X version mismatch detected Xorg 7.0, required 6.8
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No device selected
Fatal server error: no screen found

У меня три! вопроса:
1. Проблема с драйвером и его установкой?
2. Проблема с Suse и установившимся там по умолчанию драйвером "radeon" (без 3D) ?
3. Я чего то не догоняю?

На всякий случай:
Xorg 6.9 (в инфе драйвера написано, что он это может)
Ядро и исходники - все с диска, пока не до обновления Грустный
Что там еще...
Check.sh не хочет ничего показывать, говорит что то непонятное.

Я новичок в этом деле, так что если кто возьмется помочь - прошу поподробнее ;)

Декабрь 7th

Помогите вернуть клавиатуру в сеанс кде

Аватар пользователя aes78

Вчера каким-то образом сумела из сеанса кде исчезнуть поддержка клавиатуры, хотя для этого же пользователя в гномовском сеансе она работает, под рутом в кде-шном сеансе она то же работает. Я работал практически только в этом сеансе, у меня все под него создано, а в гноме работать не хочется. В OpenOffice клавиатура работает, хоть и с тормозами в этом же сеансе, в котором она пропала в системе. Если кто-нибудь знает, помогите вернуть клавиатуру!

Проблемы с Samba 3

Аватар пользователя ignat65

Доброго времени суток! Огромная просьба помочь начинающему. У меня была поставлена 11 -ка и на самбе сделан был домен, всё 28 машин(под ХР) прекрасно вводились в домен без проблем. Пришло время и я стал заменять 5 машин и теперь не одну из этих 5 машин я не могу ввести в домен ...выскакивает ошибка " При подсоединении к домену произошла следующая ошибка: Присоединённое к системе устройство не работает"- это произошло после того как я обновил систему. Но при этом если эти компьтеры в рабочей группе то они всё видят. Что это может быть?

Декабрь 5th

Проблемы с маршрутизацией

Аватар пользователя Hitriy-M

Всем привет!
Вот решил я месяц назад стать линоксоидоим...
Долго собирался, проводил эксперементы, ставил на VmWare при том на 4.5... (Кстати встала, без особых проблем, со всеми красявостями, правда словил глюк прикольный)... Накупил литературу, прочитал теоретическую часть... Начал ставить... Сделать я вобщем-то хотел сервак... Катается от смеха
Имеем такую конфигурашку...
ADSL modem ZyXel P-662HW...
У него есть порт DMZ(192.168.0.1),WiFi+3Lan(192.168.1.1) порта...
Сначала я поставил сервак в один из локальных портов(192.168.1.2), прописал в зухеле Port Mapping, поднял named и sshd...Все работает...Показывает язык И из интернета и из локалки, клева... Катается от смеха
Но если есть DMZ глупо как-то его не использовать...Блюёт Перенес его на (192.168.0.2)... Прописал в модеме что бы по этим портам дружили DMZ<=>Lan... И словил прикольный глюк...
Если я лезу из инета на DNS-пускает, на SSH-тоже пускает... А из локалки на DNS пускает если обращаться 192.168.0.2, а на глобальный IP не пускает. На SSH вообще не пускает, при этом прикольно так не пускает если на 192.168.0.2 AbsoluteTelnet пишет connected, но не ответа ни привета, а на глобальный IP connection refused...
Модемный Firewal и Firewall на ASP'е вообще отрубал... Тот же эффект...
Кто что могет присоветовать??? Хочу я этот сервак засунуть на кухню в дальний угол... А без ssh админить никак...

Nvidia vs i915

Аватар пользователя Meloman

Есть выбор между двумя видеокартами: Intel915 и NVIDIA GeForce2. Объем видеопамяти на обеих картах одинаков: 128М.
i915 сейчас стоит на моем компе, nvidia предлагают обменять, мотивируя, что она, дескать, лучше.
В принципе, мне не критичны доли секунд в отрисовке. Больше меня тревожит возможность поиграть: Quake2 при переходе в opengl-режим начинает очень сильно тормозить. Quake3 же "летает", по словам очевидцев, побыстрее, чем в винде (в настройки видео этой игры даже не заходил, там все по дефолту).

Поэтому решил обратиться с вопросом к честному народу: действительно ли nvidia будет "шустрее" работать?

Как Настрить wine?

Аватар пользователя MORf

В общем поставил я wine с дистрибутива асп11 ..... Пробовал запускать варкрафт и нфс, ничего не пашет только редалерт 2 нормально работал и кс запускалась, но были видны квадратики вместо шрифтов (а в саурз шрифты были размазаны).... Обновил через yum update wine, Варкрафт выдает фатал еррор, а кс вообще не запускается Грустный Кто-нибудь сталкивался с такой проблемой? пс видюха встроенная IEG2 определилась автоматом, я на нее дрова не ставил...
Да и еще такой вопрос где файл conf или config у wine? (в /home/UserName/.wine его нет)

Декабрь 3rd

VgaDrv для IEG2

Аватар пользователя MORf

Помогите пожалуйста найти дрова под Intel Extreme Graphics 2 на асп11 . Видюха встроенная в мать ASUS P4P800-VM чипсет i865G... желательно в rpm просто я нашел но там сырцы а я в них не шарю.. в общем не вышло у меня =:( У кого есть собранные, или кто может помочь собрать дрова буду очень благодарен ;-) вот ссылка download.asus.com.ru

Декабрь 2nd

ASPLinux 11.2 и framebuffer

Аватар пользователя eugene

Здравствуйте!
Имеется установленный ASPLinux 11.2. При установке в дополнительных параметрах ядра оставил rhgb (до этого всегда убирал его). В результате после загрузки в консоли получаю режим 1024х768-85 (со смещением за пределы видимой области монитора), который можно поменять с помощью fbset (например "fbset 800x600-100", предварительно подкорректировав настройки в /etc/fb.modes). Как теперь сохранить этот режим для всех tty (а то после перезагрузки снова 1024х768-85)? На всякий случай - видеокарта Sapphire Radeon 9000 Pro, ядро 2.6.18 из обновлений, монитор Samsung SyncMaster 753DFX.
Кстати, установка vga=ask в lilo.conf (и выбор какого-нибудь режима при загрузке) на конечный результат не влияет - после загрузки на всех tty 1024х768-85.

Админка 2/12/2006

Аватар пользователя Mimino

Сегодня неожиданно ко мне в аську постучался Алекс aka alex_root. Он ушел от отщепенцев. Попытался со мной поговорить о жизни, типа как будто все было давно и должно забыться, но у меня желания говорить с ним не было.

Ноябрь 30th

Privoxy некорректно "отдает" страницы (искажает символы)

Аватар пользователя Meloman

Добрый день!
Есть очень хороший фильтрующий прокси - privoxy. Всем хорош, но я замечаю, что он "отдает" страницы искаженно. Страницы от livejournal.com(русскоязычные), страницы нашей внутренней сети... Если бы не эта неприятность, то к privoxy не было бы нареканий. Как думается, это опять камень преткновения - utf-8 ? Улыбка
Кстати, эти искажения замечены не только на моей машине, но и на машине windows-клиентов.

Ноябрь 28th

Как запустить KDE

Аватар пользователя Lucas

Установил ASPLinux 10, тот что на 3 CD идет.
Вовремя установки выбрал типичную установку с возможностью выбора пакетов.
Снял галочку с устанавливаемого по умолчанию GNOME и поставил галочку для KDE.
От автоматического входа в графический режим отказался.
Видеокарта GeForce 2 MX 400
Монитор NEC.
При установке видео и монитор определились правильно.

Создал нового юзера.
В домашнем каталоге юзера нет файлов .xinitrc и .xserverrc, соответственно как я понимаю должны были быть использованы файлы /etc/X11/xinit/xinitrc и /etc/X11/xinit/xserverrc.
Последнего файла по указанному месту не оказалось.
Сам X-сервер запускается, на экране появляется крестик который можно двигать и все.
Как я понял startx вызывает xinit и передает ему параметры. Xinit смотрит скрипт в файле .XClients, который в свою очередь смотрит скрипт в файле /etc/sysconfig/desktop. Этого файла тоже не оказалось.
Я его создал путем копирования и переименовывания другого файла. В этом файле все стер и написал только слово KDE.
Всеравно не запускается KDE и все.
Больше не знаю где что посмотреть так как только учусь.
Пожалуйста подскажите.