Вопрос по удалению

Автор: Gosha Дата: 13.08.2003 17:07 Здравствуйте уважаемые !

Искал по поиску, но пока не нашел ответа. При удалении пакета

rpm -e .......

пишет-пакет не установлен.

При его установке

rpm -ivh ......

пишет-пакет уже установлен.

Было уже не раз. В чем проблема ? Как же его удалить ?

Спасибо !
Re: Вопрос по удалению 13.08.2003 17:16Raptor Ежели асп9, то rpm как два пальца ... может заглючить.
попробуй
---
rpm -Uvh ...
---

может прокатить.
НО, ежели пакет не был установлен до этой процедуры, а апдейт прошел, то после апдейта проверить
---
rpm -q [имя пакета]
---

если пакет зарегестрился, то сноси его и опять проверь. Если говорит, что пакет не установлен, то ставь нормально и снова проверяй. Потом man rpm и переиндексируй базу.
Re: Вопрос по удалению 13.08.2003 17:41Gosha Да. ASP 9.

rpm -Uvh ..... тоже не получается.

Но я точно знаю, что он уже установлен, но не удаляется.
Re: Вопрос по удалению 13.08.2003 17:51Alexandr Yakunin Gosha писал(а):

> Да. ASP 9.
>
> rpm -Uvh ..... тоже не получается.
>
> Но я точно знаю, что он уже установлен, но не удаляется.

Вбей полное название с цифрами и т.п. и всё получится.
Re: Вопрос по удалению 13.08.2003 18:00Raptor #rpm --rebuilddb
#rpm -q [rpm_name]
Re: Вопрос по удалению 13.08.2003 18:18SergeR Gosha, а ты (случайно) не пользовался redhat-config-packages? Улыбка
Re: Вопрос по удалению 13.08.2003 20:50Woodoo Raptor писал(а):

> Ежели асп9, то rpm как два пальца ... может заглючить.
> попробуй
> ---
> rpm -Uvh ...
> ---

---
# LD_ASSUME_KERNEL=2.2.5 rpm ...
---
Re: Вопрос по удалению 14.08.2003 10:19Gosha Raptor писал(а):

> #rpm --rebuilddb
> #rpm -q [rpm_name]

Результат - пакет не установлен.

SergeR писал(а):

> Gosha, а ты (случайно) не пользовался redhat-config-packages?
> Улыбка

В каком смысле ? Если вообще, то пользовался. redhat-config-packages обновлял. Но тот пакет, который не удаляется, я ставил через rpm -ivh

Woodoo писал(а):

> ---
> # LD_ASSUME_KERNEL=2.2.5 rpm ...
> ---

Нельзя ли пояснить, я не понял, что за KERNEL такой ?
Re: Вопрос по удалению 14.08.2003 10:45Alexandr Yakunin [community.asplinux.ru]
Re: Вопрос по удалению 14.08.2003 11:21Gosha Alexandr Yakunin писал(а):

>
> [community.asplinux.ru]

Спасибо ! Попробую.
Re: Вопрос по удалению 14.08.2003 13:19serg вопрос в тему: а как удалять то, что ставилось не из рпм, а из сорцов Мозги набекрень??
вручную чтоли
Re: Вопрос по удалению 14.08.2003 14:02Gosha Присоединяюсь Улыбка
Re: Вопрос по удалению 14.08.2003 14:26ip82 make uninstall
Re: Вопрос по удалению 14.08.2003 15:28SergeR Если, конечно, в Makefile есть target 'uninstall'...
Re: Вопрос по удалению 14.08.2003 15:40Netman А если нету target 'uninstall'?
Re: Вопрос по удалению 14.08.2003 15:50SergeR руками. ;-/
Re: Вопрос по удалению 15.08.2003 12:47Gosha Попробовал все. Не могу rpm удалить. Еще варианты есть ?
Re: Вопрос по удалению 15.08.2003 12:59swix Есть. Всё просто.

---
[swix@simulakr swix]$ rpm -q mutt
mutt-1.4.1-1asp
[swix@simulakr swix]$ rpm -e mutt-1.4.1-1asp.rpm
ошибка: пакет mutt-1.4.1-1asp.rpm не установлен
[swix@simulakr swix]$ sudo rpm -e mutt
[swix@simulakr swix]$ rpm -q mutt
пакет mutt не установлен
[swix@simulakr swix]$ sudo rpm -Uvh /var/simulakr/Disk2/mutt-1.4.1-1asp.i386.rpm
Подготовка... ########################################### [100%]
1:mutt ########################################### [100%]
[swix@simulakr swix]$ rpm -q mutt
mutt-1.4.1-1asp
[swix@simulakr swix]$
---

Понятно? Улыбка
Re: Вопрос по удалению 15.08.2003 14:15Gosha swix

Получается, что у меня не хватает прав для работы с rpm ?
Если удалять из под root, то sudo не нужно использовать ?
Признаюсь, я сейчас не уверен юзером или рутом пытался удалять.
Вечером буду разбераться с sudo.

Спасибо !
Re: Вопрос по удалению 15.08.2003 14:26swix Удалять/ставить может только root, если иное не оговорено, например, в sudo. Спрашивать систему про установленные пакеты по дефолту может любой пользователь. У Вас была проблема с именем пакета. Пакета blah.rpm в сиcтеме нет. Есть пакет blah - его и удаляйте, а не blah.rpm Улыбка
RSS-материал