Обновление java. Стоит ли рисковать?

Автор: bsm Дата: 18.06.2009 11:20 Решил обновить пакет java.
С сайта [www.java.com] взял пакет.
При попытке обновления получил нижеприведенное-

[root@maestro others]# rpm --test -Uhv jre-6u14-linux-i586.rpm
ошибка: Неудовлетворенные зависимости:
java >= 0:1.4 нужен для (установлен)jessie-1.0.0-8.noarch
java-gcj-compat >= 1.0.33 нужен для (установлен)libswt3-gtk2-3.1.1-1jpp_1fc.FC4.12.i386
java-gcj-compat >= 1.0.33 нужен для (установлен)eclipse-jdt-3.1.1-1jpp_1fc.FC4.12.i386
java-gcj-compat >= 1.0.33 нужен для (установлен)eclipse-pde-3.1.1-1jpp_1fc.FC4.12.i386
java-gcj-compat >= 1.0.33 нужен для (установлен)eclipse-ecj-3.1.1-1jpp_1fc.FC4.12.i386
java-gcj-compat >= 1.0.33 нужен для (установлен)eclipse-cdt-3.0.0_fc-1.FC4.i386
java-gcj-compat >= 1.0.31 нужен для (установлен)geronimo-specs-1.0-0.M2.2jpp_4fc.2.i386
java-gcj-compat >= 1.0.33 нужен для (установлен)eclipse-rcp-3.1.1-1jpp_1fc.FC4.12.i386
java-gcj-compat >= 1.0.33 нужен для (установлен)eclipse-platform-3.1.1-1jpp_1fc.FC4.12.i386
jdbc-stdext нужен для (установлен)tomcat5-5.0.30-5jpp_6fc.i386
jdbc-stdext нужен для (установлен)struts11-1.1-1jpp_7fc.i386
jdbc-stdext нужен для (установлен)avalon-logkit-1.2-3jpp_1fc.6.noarch
jndi нужен для (установлен)tomcat5-5.0.30-5jpp_6fc.i386
jndi нужен для (установлен)ldapjdk-4.17-1jpp_3fc.noarch
java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_31rh.FC4.2 нужен для (установлен)java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2.i386

Стоит ли рисковать и обновляться до версии 1.6.0-14?
Re: Обновление java. Стоит ли рисковать? 18.06.2009 13:03BigAndy поставьте хоть сорок java-машин параллельно и выбирайте их при помощи java_path и java_home
Re: Обновление java. Стоит ли рисковать? 18.06.2009 13:07bsm Понял. Спасибо.
Тема закрыта.
Re: Обновление java. Стоит ли рисковать? 18.06.2009 13:09lg А что вы пытаетесь обновить (в смысле rpm -q jre)?
И что выведет rpm -ivh --test jre-6u14-linux-i586.rpm
Re: Обновление java. Стоит ли рисковать? 18.06.2009 14:18lkanter Как идеологически правильно установить Java 6u14:

1. Скачать файл [mirrors.dotsrc.org], установить его.
2. Зайти в каталог SPECS, открыть java-1.6.0-sun.spec и заменить %define buildver 11 на %define buildver 14
3. Скачать со страницы [java.sun.com] файл jdk-6u14-linux-i586.bin (нужен именно этот файл!) и положить его в каталог SOURCES.
4. Собрать пакеты, выполнив команду rpmbuild -bb java-1.6.0-sun.spec. Если команды rpmbuild нет, установить пакет rpm-devel.
5. Установить собранные пакеты
6. Выполнить команду java -version и убедиться, что всё хорошо.

Эти пакеты подходят практически ко всем версиям ASPLinux/RedHat/Fedora.
Re: Обновление java. Стоит ли рисковать? 18.06.2009 21:11smaharbA у нас говорят просто - "Кто не рискует - тот в тюрьме не сидит" (с)
RSS-материал