Проблемы с Х-ами

Автор: sbssoft Дата: 24.04.2007 09:01
Видеокарта Palit 256Mb GF7300GT DDR2
Мать GA-M55S-S3
ASP Linux 11.2
При загрузке черный экран. Нажимаешь Ctrl-Alt-Backspace - все запускается и прекрасно работает. Т.е. Х-ы при загрузке загибаются, а при перезапуске все нормально.
Где что подправить?
Re: Проблемы с Х-ами 24.04.2007 13:28Bircoph
Посмотрите на ошибки в Xorg.conf* (или Xorg.conf*.old, если
смотрите из уже нормально зупущенных иксов) и приведите их
сюда.
Re: Проблемы с Х-ами 24.04.2007 14:18keng00ru
Тогда уж /var/log/Xorg.0.log смотреть надо. Или /var/log/Xorg.0.log.old.
Re: Проблемы с Х-ами 24.04.2007 15:21Bircoph
2 keng:

Спасибо, что заметил, что-то меня совсем лануло и я к
конфигам вместо логов отправил, позор...

Re: Проблемы с Х-ами 24.04.2007 21:01sbssoft
В Xorg.0.log нашел такое вот место:
(WW) NVIDIA(0): Unable to read EDID for display device CRT-0
(II) NVIDIA(0): NVIDIA GPU GeForce 7300 GT at PCI:2:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.73.22.52.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7300 GT at PCI:2:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): ViewSonic VA1912wSERIES (CRT-1)
(--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(--) NVIDIA(0): ViewSonic VA1912wSERIES (CRT-1): 400.0 MHz maximum pixel
(--) NVIDIA(0): clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1440x900"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768_60.00"; removing.
(WW) NVIDIA(0): No valid modes for "800x600_60.00"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(WW) NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) NVIDIA(0): from EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
После перезапуска Х-ов в логе такого нет
Вместо этого

(II) NVIDIA(0): NVIDIA GPU GeForce 7300 GT at PCI:2:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.73.22.52.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7300 GT at PCI:2:0:0:
(--) NVIDIA(0): ViewSonic VA1912wSERIES (CRT-1)
(--) NVIDIA(0): ViewSonic VA1912wSERIES (CRT-1): 400.0 MHz maximum pixel
(--) NVIDIA(0): clock
(II) NVIDIA(0): Assigned Display Device: CRT-1
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1440x900"
(II) NVIDIA(0): "1024x768_60.00"
(II) NVIDIA(0): "800x600_60.00"
(II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
(--) NVIDIA(0): DPI set to (89, 87); computed from "UseEdidDpi" X config option
(--) Depth 24 pixmap format is 32 bpp
и все работает.
Что сделать, чтобы при загрузке все срабатывало само, без Ctrl-Alt-Backspace?

Re: Проблемы с Х-ами 24.04.2007 21:34keng00ru
Во! А с каких это пор ViewSonic VA1912w стал CRT? Это не видюха, это монитор блажит. На самом деле монитор какой? И давай посмотрим то, что изначально Bircoph по ошибке просил. (Интуиция - великая вещь! Улыбка )
Re: Проблемы с Х-ами 25.04.2007 13:23sbssoft
На самом деле VA1912w, зуб даю. xorg.conf вечером выложу, сейчас я в другом месте.
Re: Проблемы с Х-ами 25.04.2007 19:14sbssoft
Вот мой xorg.conf

# buildxconf *** delete this line to prevent buildxconf from modifying this file
#
# XF86Config auto-generated by buildxconf
#
# Copyright (c) 1999, Corel Corporation
# Robin Burgener, robinb@corel.com
#
# See 'man XF86Config' for info on the format of this file

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules/extensions/nvidia"
ModulePath "/usr/X11R6/lib/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
# Load "xie"
Load "v4l"
Load "type1"
Load "glx"
EndSection

Section "ServerFlags"
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "Protocol" "Standard"
Option "XkbModel" "pc104"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "on"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
EndSection

Section "Monitor"

#1440x900 @ 60.0 Hz, 55.92 kHz hsync
#Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
#1024x768 @ 60.0 Hz, 48.4 kHz hsync
#Modeline "1024x768" 65 1024 1032 1176 1344 768 771 777 806 -hsync -vsync
#800x600 @ 60.3 Hz, 37.9 kHz hsync
#Modeline "800x600" 40 800 840 968 1056 600 601 605 628 +hsync +vsync
#640x480 @ 59.9 Hz, 31.5 kHz hsync
#Modeline "640x480" 25.175 640 664 760 800 480 491 493 525
Identifier "Monitor"
VendorName "unknown"
ModelName "default"
HorizSync 31.5 - 48.5
VertRefresh 50.0 - 90.0
EndSection

Section "Monitor"

#!Description "Super VGA 1024x768 @ 60Hz"
# 1024x768 @ 60 Hz, 48.4 kHz hsync
#1440x900 @ 60.0 Hz, 55.92 kHz hsync
Identifier "Super VGA"
ModelName "Super VGA"
HorizSync 31.5 - 48.5
VertRefresh 50.0 - 90.0
ModeLine "1440x900" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
ModeLine "1024x768_60.00" 64.1 1024 1080 1184 1344 768 769 772 795 -hsync +vsync
ModeLine "800x600_60.00" 38.2 800 832 912 1024 600 601 604 622 -hsync +vsync
EndSection

Section "Device"

# Option "NoAccel"
Identifier "Card:NVIDIA GeForce 7300 GS"
Driver "nvidia"
BoardName "NVIDIA GeForce 7300 GS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card:NVIDIA GeForce 7300 GS"
Monitor "Super VGA"
DefaultDepth 24
SubSection "Display"
Depth 4
Modes "1440x900" "1024x768_60.00" "800x600_60.00"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1024x768_60.00" "800x600_60.00"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900" "1024x768_60.00" "800x600_60.00"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1024x768_60.00" "800x600_60.00"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1024x768_60.00" "800x600_60.00"
EndSubSection
SubSection "Display"
Depth 32
Modes "1440x900" "1024x768_60.00" "800x600_60.00"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Готов выслушать диагноз.

Re: Проблемы с Х-ами 27.04.2007 02:26keng00ru
Одна из Section "Monitor" явно лишняя. Попробуй удалить их по очереди. (Только не забудь сделать Xorg.conf.backup!)
Если будешь оставлять 1-ую секцию, сними решётку со строки:
#Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
Только предварительно проверь правильность моделайна: gtf 1440 900 60
Если не совпадёт, то вставь свою строку, которую gtf выдаст.
Re: Проблемы с Х-ами 28.04.2007 07:55sbssoft
Сделал, не помогает. Причем кто-то редактирует xorg.conf - я раскомментировал строки с моделайнами, а после перезапуска пропали закомментированные строки с описанием (#1024x768 @ 60.0 Hz, 48.4 kHz hsync и т.д.) и две секции Monitor стали практически идентичными, за исключением идентификаторов.
Re: Проблемы с Х-ами 28.04.2007 09:16peter_ir
Если оставлена 1-я секция, там должны быть ModeLine.
Re: Проблемы с Х-ами 28.04.2007 09:52sbssoft
Дык я и говорю, они стали одинаковые:

#1440x900 @ 60.0 Hz, 55.92 kHz hsync
Identifier "Super VGA"
ModelName "Super VGA"
HorizSync 31.5 - 48.5
VertRefresh 50.0 - 90.0
ModeLine "1440x900" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
ModeLine "1024x768_60.00" 64.1 1024 1080 1184 1344 768 769 772 795 -hsync +vsync
ModeLine "800x600_60.00" 38.2 800 832 912 1024 600 601 604 622 -hsync +vsync

только идентификатором отличаются. А Х-ы запускаются только через Ctrl-Alt-Backspace

Re: Проблемы с Х-ами 28.04.2007 12:40peter_ir
Так секция осталась одна или нет? Если нет, 2-ю надо удалить, с в
секции "Screen" написать
Monitor "Monitor"

Петр.

Re: Проблемы с Х-ами 28.04.2007 13:30keng00ru
sbssoft писал(а):

> Причем кто-то редактирует xorg.conf
Выставь на него права - всем только чтение.

Re: Проблемы с Х-ами 28.04.2007 14:05lg
>Причем кто-то редактирует xorg.conf
/sbin/chkconfig --list|grep -i nvidia
Re: Проблемы с Х-ами 28.04.2007 18:17Iskanderus
Интересный факт с nvidia:
две одинаковые машины:
при загрузке черный экран при запуске Xов, только на одной при перезагрузке компьютера иногда x стартуют, а на другой глухо - черный экран. Похоже такой же глюк. Однако Ctrl-alt-backspace не помогает
Re: Проблемы с Х-ами 30.04.2007 21:24sbssoft
Всем спасибо. Ушел я с ASP на SUSE10.2. Там, правда, другие заморочки, но я уж к SUSE давно привык, проще бороться. Да и YAST удобнее чем менеджеры ASP (IMHO)
Re: Проблемы с Х-ами 02.05.2007 18:04StasK
Такая же проблема с Х-ами была и у меня. Мать ASUS K8V-X SE видео GF5500 AGP. Причем на другой материнке с этой картой проблем не было. Ядро 2.6.20 , Х обновлены, дрова 96хх, тоже обновлены. При установке дров 9755 с сайта nvidia проблема частично решилась - Х грузяться, но из-за того что не смог примонтировать модуль ядра не было 3D. Проблема скорее всего в том, что дрова 96хх некорректно работают с некоторыми чипсетами. Остается дождаться, когда девелоперы прикрутят 9755 или выше к ASP.

RSS-материал