В каком пакете находится файл libpisock.so.9 ?

Автор: xfn Дата: 18.05.2006 10:10 Сабж
Re: В каком пакете находится файл libpisock.so.9 ? 18.05.2006 11:00Neonovice Это уже пора в FAQ выносить!
[rpm.pbone.net]
Re: В каком пакете находится файл libpisock.so.9 ? 18.05.2006 11:53xfn в дистрибутиве:
pilot-link-0.12.0-0.pre4.2.fc4.1.i386.rpm.html

в updates:
pilot-link-0.11.8-11.4.fc4.i386.rpm

rpm -q pilot-link
pilot-link-0.12.0-0.pre4.0.fc4.2

получается, что в update более старый вариант?

Далее...

yum update gnome*

--> Populating transaction set with selected packages. Please wait.
---> Package gnome-pilot-conduits.i386 0:2.0.13-1.110.1am set to be updated
---> Package gnome-system-monitor.i386 0:2.14.2-2.110msiu set to be updated
---> Package gnome-vfs2.i386 0:2.14.1-1.110msiu set to be updated
---> Package gnome-utils.i386 1:2.14.0-10.110msiu set to be updated
---> Package gnome-vfs2-devel.i386 0:2.14.1-1.110msiu set to be updated
---> Package gnome-vfs2-smb.i386 0:2.14.1-1.110msiu set to be updated
--> Running transaction check
--> Processing Dependency: zenity for package: gnome-utils
--> Processing Dependency: libgucharmap.so.4 for package: gnome-applets
--> Processing Dependency: gcalctool for package: gnome-utils
--> Processing Dependency: gucharmap for package: gnome-utils
--> Processing Dependency: libpisock.so.8 for package: gnome-pilot-conduits
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package zenity.i386 0:2.14.1-4.110msiu set to be updated
---> Package gcalctool.i386 0:5.7.32-4.110msiu set to be updated
---> Package gucharmap.i386 0:1.6.0-6.110msiu set to be updated
---> Package pilot-link.i386 2:0.11.8-11.4.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.9 for package: gnome-pilot
--> Processing Dependency: libpisock.so.9 for package: evolution
--> Processing Dependency: libpisock.so.9 for package: kdepim
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kdepim.i386 6:3.5.2-2.110msiu set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.9 for package: gnome-pilot
--> Processing Dependency: libpisock.so.9 for package: evolution
--> Finished Dependency Resolution
Error: Missing Dependency: libpisock.so.9 is needed by package gnome-pilot
Error: Missing Dependency: libpisock.so.9 is needed by package evolution


ldconfig показывает, что libpisock.so.9 есть ссылка на libpisock.so.9.0.0 в /usr/lib

что не так?
Re: В каком пакете находится файл libpisock.so.9 ? 18.05.2006 14:57Tigro Там когда-то был баг. Закачайте заново с ftp.asplinux.ru пакеты pilot-link*. И потом:

---
yum clean all && yum update
---
Re: В каком пакете находится файл libpisock.so.9 ? 19.05.2006 10:32xfn Может что-то делаю не так?

Во-первых, из-за ограничения трафика, пакеты скачиваю в другом месте. Создал на данном компе локальный репозиторий, рассовал пакеты в соответствующие каталоги (base update other extras livna), поправил конфиги yum для работы с локальным репозиторием и createrepo /var/cache/yum/base и т.д.

До сих пор все работало замечательно.

По совету Tigro, скачал 4 пакета pilot-link (вместе с devel из base и update). yum clean all, заново createrepo...

yum check-update

в списке появился pilot-link

pilot-link.i386 2:0.11.8-11.4.fc4 updates-released

далее

yum update pilot-link

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
msiu-other [1/5]
base [2/5]
livna [3/5]
msiu-extras [4/5]
updates-released [5/5]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package pilot-link.i386 2:0.11.8-11.4.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.9 for package: kdepim
--> Processing Dependency: libpisock.so.9 for package: gnome-pilot
--> Processing Dependency: libpisock.so.9 for package: evolution
--> Processing Dependency: libpisock.so.9 for package: gnome-pilot-conduits
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kdepim.i386 6:3.5.2-2.110msiu set to be updated
---> Package gnome-pilot-conduits.i386 0:2.0.13-1.110.1am set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.9 for package: gnome-pilot
--> Processing Dependency: libpisock.so.9 for package: evolution
--> Finished Dependency Resolution
Error: Missing Dependency: libpisock.so.9 is needed by package gnome-pilot
Error: Missing Dependency: libpisock.so.9 is needed by package evolution

может принудительно установить этот пилот-линк Улыбка ?
Re: В каком пакете находится файл libpisock.so.9 ? 19.05.2006 14:11Tigro А как насчет того, чтобы обновить evolution и gnome-pilot?

[ftp.msiu.ru]
[ftp.msiu.ru]
[ftp.msiu.ru]
[ftp.msiu.ru]
Re: В каком пакете находится файл libpisock.so.9 ? 22.05.2006 09:35xfn Обновил gnome-pilot-2.0.13-5.110.2am.i386.rpm, все заработало.
Спасибо большое.
RSS-материал