A7N8X-X nFORCE2 помогите с настройкой сети

Аватар пользователя korochinskiy

При установке ASPLinux 10 обнаружил сетевуху и установил драйвера, во вкладке сеть все ОК т.е. в оборудовании пишет ОК и активируется подключение, но когда пытаюсь загрузить страницу из браузера пишет соединение с..... и все. Страницу не загружает. Почту он тоже отказывается загружать, а вот в qFTP файлы загружает нормально. Блюёт

Аватар пользователя sergeil

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Цитата:
korochinskiy писал:
При установке ASPLinux 10 обнаружил сетевуху и установил драйвера, во вкладке сеть все ОК т.е. в оборудовании пишет ОК и активируется подключение

OK

Цитата:
но когда пытаюсь загрузить страницу из браузера пишет соединение с..... и все.
Страницу не загружает. Почту он тоже отказывается загружать, а вот в qFTP файлы загружает нормально. Блюёт

Если идет загрузка по FTP протоколу, то Ваша сеть сконфигурирована верно.
FTP осуществляет пересылку большими пакетами. Это самый тяжелый режим.
То есть, есть все основания предполагать, что сеть на Вашей машине сконфигурирована верно...

что возвращает:
root# ip addr show

что возвращает:
root# ip route show

Что возвращает:
root# lspci -v

Кто Ваш провайдер? Выдает-ли провайдер публичный адрес или адрес из диапазона "частных сетей"? Частные сети: 10.x.x.x, 192.168.x.x 172.16.x.x - 172.32.x.x
Оговорены ли какие-либо ограничения, которые провайдер накладывает на пользование своей сетью?

Аватар пользователя korochinskiy

Re: A7N8X-X nFORCE2 помогите с настройкой сети

ip addr show

1: lo: mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:11:d8:00:73:90 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.2/24 brd 192.168.1.255 scope global eth0
inet6 fe80::211:d8ff:fe00:7390/64 scope link
valid_lft forever preferred_lft forever
3: sit0: mtu 1480 qdisc noop
link/sit 0.0.0.0 brd 0.0.0.0

ip route show

192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.2
169.254.0.0/16 dev eth0 scope link
default via 192.168.1.1 dev eth0

lspci -v

00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
Subsystem: ASUSTeK Computer Inc.: Unknown device 80ac
Flags: bus master, 66Mhz, fast devsel, latency 0
Memory at d0000000 (32-bit, prefetchable) [=128M]
Capabilities: [40] AGP version 3.0
Capabilities: [60] HyperTransport: Host or Secondary Interface

00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 0 (rev c1)
Subsystem: ASUSTeK Computer Inc.: Unknown device 80ac
Flags: 66Mhz, fast devsel

00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
Subsystem: ASUSTeK Computer Inc.: Unknown device 80ac
Flags: 66Mhz, fast devsel

00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
Subsystem: ASUSTeK Computer Inc.: Unknown device 80ac
Flags: 66Mhz, fast devsel

00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
Subsystem: ASUSTeK Computer Inc.: Unknown device 80ac
Flags: 66Mhz, fast devsel

00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
Subsystem: ASUSTeK Computer Inc.: Unknown device 80ac
Flags: 66Mhz, fast devsel

00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard
Flags: bus master, 66Mhz, fast devsel, latency 0
Capabilities: [48] HyperTransport: Slave or Primary Interface

00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
Subsystem: ASUSTeK Computer Inc.: Unknown device 0c11
Flags: 66Mhz, fast devsel, IRQ 3
I/O ports at e000 [=32]
Capabilities: [44] Power Management version 2

00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 5
Memory at eb001000 (32-bit, non-prefetchable) [=4K]
Capabilities: [44] Power Management version 2

00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
Memory at eb002000 (32-bit, non-prefetchable) [=4K]
Capabilities: [44] Power Management version 2

00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
Memory at eb003000 (32-bit, non-prefetchable) [=256]
Capabilities: [44] Debug port
Capabilities: [80] Power Management version 2

00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard onboard nForce2 Ethernet
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
Memory at eb000000 (32-bit, non-prefetchable) [=4K]
I/O ports at e400 [=8]
Capabilities: [44] Power Management version 2

00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
I/O behind bridge: 0000c000-0000cfff
Memory behind bridge: ea000000-eaffffff

00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2) (prog-if 8a [Master SecP PriP])
Subsystem: ASUSTeK Computer Inc.: Unknown device 0c11
Flags: bus master, 66Mhz, fast devsel, latency 0
I/O ports at f000 [=16]
Capabilities: [44] Power Management version 2

00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 32
Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: e8000000-e9ffffff
Prefetchable memory behind bridge: d8000000-e7ffffff

01:08.0 Communication controller: Conexant: Unknown device 10b6 (rev 89)
Subsystem: Conexant: Unknown device 10b6
Flags: bus master, medium devsel, latency 32, IRQ 3
Memory at ea000000 (32-bit, non-prefetchable) [=64K]
I/O ports at c000 [=8]
Capabilities: [40] Power Management version 2

01:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 06)
Subsystem: Creative Labs CT4832 SBLive! Value
Flags: bus master, medium devsel, latency 32, IRQ 5
I/O ports at c400 [=32]
Capabilities: [dc] Power Management version 1

01:09.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 06)
Subsystem: Creative Labs Gameport Joystick
Flags: bus master, medium devsel, latency 32
I/O ports at c800 [=8]
Capabilities: [dc] Power Management version 1

02:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01) (prog-if 00 [VGA])
Subsystem: PC Partner Limited Sapphire Radeon 9200
Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 10
Memory at d8000000 (32-bit, prefetchable) [=128M]
I/O ports at d000 [=256]
Memory at e9000000 (32-bit, non-prefetchable) [=64K]
Capabilities: [58] AGP version 3.0
Capabilities: [50] Power Management version 2

02:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)
Subsystem: PC Partner Limited Sapphire Radeon 9200
Flags: 66Mhz, medium devsel
Memory at e0000000 (32-bit, prefetchable) [disabled] [=128M]
Memory at e9010000 (32-bit, non-prefetchable) [disabled] [=64K]
Capabilities: [50] Power Management version 2

Подключаюсь к интернет по ADSL. Провайдер ни каких ограничений не накладывал кроме указать определение DNS и IP в автомате что я и сделал. (Ростовский DIZEL от ЦТС).
P.S. Мне всетаки удалось загрузить страницу с http://www.asplinux.ru (но это получилось один раз и в последующем он грузить её не хочет) потом с этого же сайта страницы грузятся нормально :-o , а на другие сайты не уходит пишет соединение с.... и молчек. (Фарервол при установке не включал).

Аватар пользователя korochinskiy

Re: A7N8X-X nFORCE2 помогите с настройкой сети

В 9.2 все работало:-? . Попробовал работать через link РАБОТАЕТ страницы загружает :-o . Скачал и установил OPERA страницы не загружает Блюёт .

Аватар пользователя Archont

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Какой ADSL?
В каком режиме?
DNS провайдера (если модем в режиме роутера) лучше прописать на модеме.
Для Ростовского ЦТС это 80.80.111.254 и 80.80.111.244. Кстати, можно писать любой публичный DNS сервер.
Кроме того, поскольку модем у вас, похоже, в режиме роутера, проверьте параметры подключения по DSL и по TCP/IP:
PPPoE connection:
MTU 1400
MRU 1492
VPI 0
VCI 33
DSL connection: MMODE, хотя у них работают и все остальные режимы как правило.
Кроме того нужно проверить качество телефонного подключения. Ребята из ЦТС не отличаются аккуратностью монтажа. У вас элементарно может быть пропадание коннекта по DSL из-за плохих контактов.

Да, еще вам лучше отключить поддержку ipv6, поскольку в настоящий момент она вам абсолютно не нужна. Не знаю, может ли она мешать, но точно не помогает. Это можно сделать либо пересборкой ядра, либо сконфигурировать, чтобы она не включалась при загрузке. По второму способу я не спец, т.к. я всегда пересобираю ядро под себя. На community.asplinux.ru в форумах буквально на днях были ответы на этот вопрос.

Аватар пользователя sergeil

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Цитата:
korochinskiy писал:

2: eth0: mtu 1500 qdisc pfifo_fast qlen 1000
...
inet 192.168.1.2/24 brd 192.168.1.255 scope global eth0
...

А провайдер Вас не балует...
Выдал "серый адрес". Значит, где-то у него настроен NAT.

Цитата:
lspci -v
...

00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
Subsystem: ASUSTeK Computer Inc.: Unknown device 0c11
Flags: 66Mhz, fast devsel, IRQ 3
I/O ports at e000 [=32]
Capabilities: [44] Power Management version 2

У Вас отключен COM2?

Цитата:
01:08.0 Communication controller: Conexant: Unknown device 10b6 (rev 89)
Subsystem: Conexant: Unknown device 10b6
Flags: bus master, medium devsel, latency 32, IRQ 3
Memory at ea000000 (32-bit, non-prefetchable) [=64K]
I/O ports at c000 [=8]
Capabilities: [40] Power Management version 2

И еще одно устройство его использует...

Боюсь, что дело, все же, в провайдере...
Узнайте, какая у него ширина внешнего канала?

Аватар пользователя korochinskiy

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Цитата:
sergeil писал:
У Вас отключен COM2?

Да COM2 у меня отключен.
Устройство которое его использует возможно внутренный модем который я никак не собирусь извлеч за ненадобностью (хотя он был настроен на COM4 (он не PnP)).

Я всё же уверен, что дело не в провайдере т.к. в XP всё великолепно работает и в ASPLinux 9.2 тоже все великолепно работало. 10 ASPLinux накладывает особые требования на канал связи провайдера???

Модем работает в режиме роутера(D-link DSL-500T), настраивал его провайдер. Канал связи тоже не пропадает (на модеме есть индикатор подключения по ADSL).

Аватар пользователя sergeil

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Цитата:
korochinskiy писал:
При установке ASPLinux 10 обнаружил сетевуху и установил драйвера, во вкладке сеть все ОК т.е. в оборудовании пишет ОК и активируется подключение, но когда пытаюсь загрузить страницу из браузера пишет соединение с..... и все. Страницу не загружает. Почту он тоже отказывается загружать, а вот в qFTP файлы загружает нормально. Блюёт

Кстати, а у Вас случайно нигде не прописаны нижеперечисленные переменные окружения?

http_proxy
HTTP_PROXY
ftp_proxy
FTP_PROXY

Или в самом бровзере, случайно не обозначены подключения через PROXY?
Учитывая то, что часть приложений работает, а часть - нет, есть такое подозрение...

Аватар пользователя korochinskiy

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Все оказалость гораздо проще. Я снял галочку в настройке сети Автоматически получать DNS от провайдера и вбил его вручную. Все заработало. Спасибо всем за помощь. Только вот почему так произошло ведь по идее он должен был получать DNS автоматически ?

Аватар пользователя sergeil

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Цитата:
korochinskiy писал:
Все оказалость гораздо проще. Я снял галочку в настройке сети Автоматически получать DNS от провайдера и вбил его вручную. Все заработало. Только вот почему так произошло ведь по идее он должен был получать DNS автоматически?

Причин может быть несколько:
1. Провайдер не настроил DHCP сервер отдавать информацию о DNS сервере. То есть, после получения IP адреса Вы остаетесь без сервера DNS.
2. Провайдер в сессии DHCP возвращает ложный адрес сервера DNS. То есть, адрес хоста, на котором DNS не работает.
3. Провайдер в сессии DHCP возвращает адрес сервера DNS, но сервер временно недоступен (на профилактике).

В любом случае, это недочет в работе провайдера. Вот почему я предпочитаю собственный кэширующий DNS. Без всякой настройки организуется установкой 2 стандартных пакетов из дистрибутива ASPLinux. То есть, я сам себе сервер DNS.

[sergeil@homedesk ~]$ nslookup www.mail.ru
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
Name:   www.mail.ru
Address: 194.67.57.26

Улыбка

Аватар пользователя Archont

Re: A7N8X-X nFORCE2 помогите с настройкой сети

ЦТС НЕ ДАЕТ DNS автоматом! И они, на сколько я знаю, не используют DHCP, по крайней мере IP на PPPoE прописан статически!
Вы или не прочли, или невнимательно прочли мой пост.

Для 500Т очень рекомендую поменять стандартную прошивку, какая бы у вас ни была залита, на какую-нибудь прошивку от McMCC:
http://mcmcc.bat.ru/
http://forum.ixbt.com/topic.cgi?id=14:34671
Лично мне нравится одна из прошивок за февраль 2005: в ней есть встроенный tcpdump, что весьма существенно помогает в решении сетевых проблем, если они возникают. В последних версиях он его выбросил ради других фич. В ней также встроен iptables-1.28, и на нем построен подсчет траффика.

Аватар пользователя sergeil

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Цитата:
Archont писал:
ЦТС НЕ ДАЕТ DNS автоматом! И они, на сколько я знаю, не используют DHCP, по крайней мере IP на PPPoE прописан статически!
Вы или не прочли, или невнимательно прочли мой пост.

Еще раз перечитал Ваш пост. Обнаружил IP адреса DNS серверов и как их лучше прописать. Не обнаружил информации, что провайдер не отдаеет DNS автоматически.

:-?

Аватар пользователя Archont

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Сергей, я не вам адресовал пост по DNS.
И если не указал сразу, что провайдер не отдает DNS в автомате, прошу прощения.

Цитата:
sergeil писал:

Цитата:
Archont писал:
ЦТС НЕ ДАЕТ DNS автоматом! И они, на сколько я знаю, не используют DHCP, по крайней мере IP на PPPoE прописан статически!
Вы или не прочли, или невнимательно прочли мой пост.

Еще раз перечитал Ваш пост. Обнаружил IP адреса DNS серверов и как их лучше прописать. Не обнаружил информации, что провайдер не отдаеет DNS автоматически.

:-?

Аватар пользователя sergeil

Re: A7N8X-X nFORCE2 помогите с настройкой сети

Я так понял, тема закрыта...

RSS-материал